Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] ADT compatibility with eclipse and EMF
icon4.gif  [ATL] ADT compatibility with eclipse and EMF [message #509941] Mon, 25 January 2010 20:15 Go to next message
wafaa is currently offline wafaaFriend
Messages: 163
Registered: January 2010
Location: Egypt
Senior Member
hi all

I am new to ATL

and I want to check if the environment is well set up

I have eclipse 3.4.2
which ADT bundle I should download and which EMF please make ur alias link compatible with the list below

http://www.eclipse.org/modeling/m2m/downloads/index.php?show All=1&hlbuild=R200909220532&project=atl#R20090922053 2

thanks in advanced
wafaa
Re: [ATL] ADT compatibility with eclipse and EMF [message #509962 is a reply to message #509941] Mon, 25 January 2010 22:05 Go to previous messageGo to next message
wafaa is currently offline wafaaFriend
Messages: 163
Registered: January 2010
Location: Egypt
Senior Member
again,this is me,

let me ask u some question,

is it difficult to write rules in ATL, I mean OCL and some expression, should I learn them , if yes what is best tutorial for ocl expression and ATL language.

I have seen ATL examples, and run them but could not get the syntax structure!!



please reply with any info could help me!!!

[Updated on: Mon, 25 January 2010 22:06]

Report message to a moderator

Re: [ATL] ADT compatibility with eclipse and EMF [message #510035 is a reply to message #509941] Tue, 26 January 2010 10:14 Go to previous messageGo to next message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 93
Registered: July 2009
Member
Hi Wafaa,

To install ATL, simply use the eclipse update manager and add this site http://download.eclipse.org/modeling/m2m/updates/releases/, then select and install ATL 3.0. It will work well with your eclipse version.

For documentation and tutorials, refer to this http://eclipse.org/m2m/atl/doc/, especially the user manual.

BRs
Guillaume
Re: [ATL] ADT compatibility with eclipse and EMF [message #510093 is a reply to message #510035] Tue, 26 January 2010 14:21 Go to previous message
wafaa is currently offline wafaaFriend
Messages: 163
Registered: January 2010
Location: Egypt
Senior Member
hi Guillaume

Thank you very much for ur help

Now I have got ATL 3.0.0 and EMF 2.4.2

Yes I saw the doc u pointed to and It seems valuable and will help


Now I am trying to learn Metamodeling EMF and using Ecore

Is this the first step to begin with ATL?
Thank u very much

Wafaa
Previous Topic:[ATL] Running ATL in Java creates empty XMI document
Next Topic:Is VIATRA2 still being developed?
Goto Forum:
  


Current Time: Thu Oct 24 04:35:28 GMT 2019

Powered by FUDForum. Page generated in 0.01955 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top