Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » EMF's OSGI Configuration
EMF's OSGI Configuration [message #509840] Mon, 25 January 2010 14:57 Go to next message
Eclipse UserFriend
Originally posted by: jseng.valen.trick.gov

I have a simple EMF project from schema. I added all the appropriate jars
to the classpath. This is embedded as a plugin into a closed-source
toolkit. The program worked fine.

I did an upgrade of the closed-source toolkit. They apparently fixed a
bug that allowed classes on the classpath to be used, requiring proper
OSGI configuration. This is where the problems start.

Previously, I had only needed a few jars for EMF to work:
* org.eclipse.emf_2.5.0.v200906151043.jar
* org.eclipse.emf.common_2.5.0.v200906151043.jar
* org.eclipse.emf.ecore_2.5.0.v200906151043.jar

and maybe 1 or 2 more.

Now, the OSGI configurations are requiring others which require others and
I just cannot find enough jars to make it run.

All of this starts from the MANIFEST.MF generated by EMF which has the
following:
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport
Bundle-ActivationPolicy: lazy

Is there a complete package of jar files (OSGI speaking) for EMF?

Thank you,

Jonathan
Re: EMF's OSGI Configuration [message #509914 is a reply to message #509840] Mon, 25 January 2010 18:39 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30631
Registered: July 2009
Senior Member
Jonathan,

Comments below.

Jonathan Seng wrote:
> I have a simple EMF project from schema. I added all the appropriate jars
> to the classpath. This is embedded as a plugin into a closed-source
> toolkit. The program worked fine.
>
> I did an upgrade of the closed-source toolkit. They apparently fixed a
> bug that allowed classes on the classpath to be used, requiring proper
> OSGI configuration. This is where the problems start.
>
> Previously, I had only needed a few jars for EMF to work:
> * org.eclipse.emf_2.5.0.v200906151043.jar
> * org.eclipse.emf.common_2.5.0.v200906151043.jar
> * org.eclipse.emf.ecore_2.5.0.v200906151043.jar
>
> and maybe 1 or 2 more.
>
> Now, the OSGI configurations are requiring others which require others and
> I just cannot find enough jars to make it run.
>
> All of this starts from the MANIFEST.MF generated by EMF which has the
> following:
> Require-Bundle: org.eclipse.core.runtime,
> org.eclipse.emf.ecore;visibility:=reexport,
> org.eclipse.emf.ecore.xmi;visibility:=reexport
> Bundle-ActivationPolicy: lazy
>
> Is there a complete package of jar files (OSGI speaking) for EMF?
>
That really depends on the dependencies of org.eclipse.org.runtime. The
Plug-in Dependencies "folder" of the project in the Package Explorer
shows this type of information.
> Thank you,
>
> Jonathan
>
Previous Topic:[CDO Teneo] Does CDOENumStringType.nullSafeGet require identical name and literal for EEnum?
Next Topic:Custom Store Developing
Goto Forum:
  


Current Time: Fri Nov 15 00:34:13 GMT 2019

Powered by FUDForum. Page generated in 0.01482 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top