Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Re: OpenSolaris: Eclipse/SWT hangs in GTK OS call when trying to change fonts
Re: OpenSolaris: Eclipse/SWT hangs in GTK OS call when trying to change fonts [message #507025] Mon, 11 January 2010 12:12
Grant Gayed is currently offline Grant GayedFriend
Messages: 2150
Registered: July 2009
Senior Member
Hi Andreas,

What's the gtk version that ships with the new OpenSolaris build? SWT has
had various problems with GTK 2.18, and one that looks like it could be
related to what you're seeing is . Can you see if
setting Solaris environment variable GDK_NATIVE_WINDOWS=true before running
eclipse helps? If not then please log a report with all of your information
with swt at &component=SWT .


From: "Andreas Loew" <>
Subject: OpenSolaris: Eclipse/SWT hangs in GTK OS call when trying to change
Date: January 8, 2010 8:33 AM

Hi Eclipse community,

on my brand new OpenSolaris build 129 x64 installation, Eclipse IDE hangs
when trying to change fonts (Window - Preferences - General - Appearance -
Colors and Fonts, then clicking the "Edit" button to change e.g. the CVS
console font) or colors. I think this hang happens when trying to open a
standard GTK font or color chooser.

Most surprisingly (although I would expect the exact same event handlers
being configured for both actions), when double-clicking on the currently
configured font name/color instead of using the "Edit" button, there is no
hang and the GTK font and/or color chooser opens up just fine...!?

I have tried with the plain Eclipse 3.5.1 package from
as well as with the 3.4.2 build available from the
repository, and also with both the most recent 1.6.0_17 and 1.5.0_22 JDKs
and the client as well as the server JVM.

While the main thread is hung, I am getting the following jstack and pstack
traces (full thread stacks: see attachments):

"main" prio=3 tid=0x0806fc00 nid=0x2 runnable [0xfe27e000]
java.lang.Thread.State: RUNNABLE
at org.eclipse.swt.internal.gtk.OS.Call(Native Method)
at org.eclipse.swt.widgets.Display.sleep(
org.eclipse.ui.application.WorkbenchAdvisor.eventLoopIdle(Wo rkbenchAdvisor.j
ava :364)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2406)

----------------- lwp# 1 / thread# 1 --------------------
feea4fc5 lwp_wait (2, 8046c94)
fee9bc6c _thrp_join (2, 0, 8046d00, 1) + 63
fee9bdbb thr_join (2, 0, 8046d00) + 23
08058be3 ContinueInNewThread (8052260, 50000, 0, 80475a8, 8047560) + 4f
08051f59 main (19, 806c108, 80476a8) + aa1
0805142a _start (1f, 80477b4, 80477d3, 80477db, 80477e4, 80477f9) + 7a
----------------- lwp# 2 / thread# 2 --------------------
feea49e5 pollsys (94c4ec0, 2, fe27de08, 0)
fee48814 poll (94c4ec0, 2, 64, da4732a4, db58151c) + 4c
da4732bc g_poll (94c4ec0, 2, 64, db581690, 0, fe27de78) + 24
d5432acb Java_org_eclipse_swt_internal_gtk_OS_Call__IIII (806fd10, fe27deb8,
da473298, 94c4ec0, 2, 64) + 17

As the hang does only happen when using the "Edit" button, but not when
double-clicking on the configured font/color, am I correct in assumin that I
am more likely hitting a bug in the Eclipse SWT rather than in OpenSolaris
GTK infrastructure!?

Interestingly, I have also tried with Eclipse 3.5.1 on the official Open
Solaris 2009.06 osol_111b build (running from the live DVD), and opening the
font dialog works fine here even through the "Edit" buttons with JVM

Please find the stack traces on OpenSolaris builds 129 and 111b attached.

It's most interesting that while on build 111b, the whole font dialog
processing (using the exact same Eclipse 3.5.1 binaries) runs from within
one single thread (thread#1/lwp#1), the same thing in 129 uses two threads:
thread#1/lwp#1 uses ContinueInNewThread to spawn thread#2/lwp#2.

Maybe this dynamic thread creation is unexpected behavior from the SWT
perspective and causes the hang!?

Many thanks for looking into this & best regards,

Previous Topic:SWT printing capabilities- followup
Next Topic:Problem in SWT Text widget and Mac
Goto Forum:

Current Time: Sun Jul 12 14:02:24 GMT 2020

Powered by FUDForum. Page generated in 0.02324 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top