Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [QVT] Transformation is using UML 3.0.0 versus 2.1.0(QVT transformation using UML 3.0.0 versus 2.1.0 despite 2.1.0 in the code)
[QVT] Transformation is using UML 3.0.0 versus 2.1.0 [message #505133] Sun, 27 December 2009 14:41 Go to next message
Sean Muir is currently offline Sean MuirFriend
Messages: 7
Registered: July 2009
Junior Member
I have a model to model transformation which I have the following line for the UML modeltype

modeltype uml uses "http://www.eclipse.org/uml2/2.1.0/UML"

but when ran - the http://www.eclipse.org/uml2/3.0.0/UML is used
the resulting xmi

<uml:Package xmi:version="2.1" xmlns:xmi="http://schema.omg.org/spec/XMI/2.1" xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML" xmi:id="_95WRUfL0Ed6HaaidunZbwQ" name="PORX_RM010001UK01">

At one point i did have the 3.0.0 in the transformation but required 2.1.0

In the ide - the mouse hover reads 3.0.0 over the 2.1.0 code

Is there some setting i need to change in order for 2.1.0 to be used or cache to remove?

I included below my configuration details

Thanks in advance

Sean Muir




Eclipse Project SDK

Version: 3.5.0.v20090423-7Q7bA7DPQ1SM6OYQ7wKYJhI-z-xZJCmLTBRhtZ0o61b1 z
Build id: I20090611-1540

(c) Copyright Eclipse contributors and others 2000, 2009. All rights reserved.
Visit http://www.eclipse.org/eclipse


Operational QVT Common

Version: 2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7
Build id: 200906161204

(c) Copyright Borland Software Corporation. 2007, 2008. All rights reserved.

QVT Operational Mapping Language (OML) is used for model-to-model transformation.
Visit http://www.eclipse.org/m2m


Unified Modeling Language 2.x

Version: 3.0.1.v200908281330
Build id: 200906151558

(c) Copyright Eclipse contributors and others 2003, 2008. All rights reserved.
Visit http://www.eclipse.org/uml2
Re: [QVT] Transformation is using UML 3.0.0 versus 2.1.0 [message #507057 is a reply to message #505133] Mon, 11 January 2010 20:54 Go to previous message
Sergey Boyko is currently offline Sergey BoykoFriend
Messages: 171
Registered: July 2009
Senior Member
Hi Sean ,

Described behavior is UML-intrinsic.
UML resource is always saved with highest available version (which is
3.0.0 for UML in Eclipse 3.5). Exactly that UML metamodel is also
registered for "http://www.eclipse.org/uml2/2.0.0/UML" and
"http://www.eclipse.org/uml2/2.1.0/UML" URIs.
For any older UML-instance models implicit upward conversion is performed.

Regards,
Sergey.

Sean Muir wrote:
> I have a model to model transformation which I have the following line
> for the UML modeltype
>
> modeltype uml uses "http://www.eclipse.org/uml2/2.1.0/UML"
>
> but when ran - the http://www.eclipse.org/uml2/3.0.0/UML is used
> the resulting xmi
> <uml:Package xmi:version="2.1"
> xmlns:xmi="http://schema.omg.org/spec/XMI/2.1"
> xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML"
> xmi:id="_95WRUfL0Ed6HaaidunZbwQ" name="PORX_RM010001UK01">
>
> At one point i did have the 3.0.0 in the transformation but required 2.1.0
>
> In the ide - the mouse hover reads 3.0.0 over the 2.1.0 code
>
> Is there some setting i need to change in order for 2.1.0 to be used or
> cache to remove?
>
> I included below my configuration details
>
> Thanks in advance
>
> Sean Muir
>
>
>
>
> Eclipse Project SDK
>
> Version: 3.5.0.v20090423-7Q7bA7DPQ1SM6OYQ7wKYJhI-z-xZJCmLTBRhtZ0o61b1 z
> Build id: I20090611-1540
>
> (c) Copyright Eclipse contributors and others 2000, 2009. All rights
> reserved.
> Visit http://www.eclipse.org/eclipse
>
>
> Operational QVT Common
> Version: 2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7
> Build id: 200906161204
>
> (c) Copyright Borland Software Corporation. 2007, 2008. All rights
> reserved.
>
> QVT Operational Mapping Language (OML) is used for model-to-model
> transformation.
> Visit http://www.eclipse.org/m2m
>
>
> Unified Modeling Language 2.x
>
> Version: 3.0.1.v200908281330
> Build id: 200906151558
>
> (c) Copyright Eclipse contributors and others 2003, 2008. All rights
> reserved.
> Visit http://www.eclipse.org/uml2
Previous Topic:Modifying GLOBALVAR in extend script
Next Topic:[QVTO] Evaluator: QvtRuntimeException by Transformation
Goto Forum:
  


Current Time: Tue Oct 22 14:36:38 GMT 2019

Powered by FUDForum. Page generated in 0.01873 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top