Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Xtext] Debugging an antlr grammar generated with TMF Xtext 0.7.x or 0.8.x
[Xtext] Debugging an antlr grammar generated with TMF Xtext 0.7.x or 0.8.x [message #504757] Tue, 22 December 2009 13:58 Go to next message
Cédric Vidal is currently offline Cédric VidalFriend
Messages: 101
Registered: July 2009
Senior Member
Hi guys,

In oAW Xtext, it was possible to debug the generated antlr grammar with
ANTLRWorks by simply loading the generated *.g file but it doesn't seem
possible anymore with TMF Xtext, at least, it's not obvious. I've tried
to debug the generated Internal<Lang>.g file with Xtext 0.7.[0,1,2] and
0.8.0M4 and ANTLRWorks 1.2.3.

What is the recommended way to do this ?

Regards,

Cédric
Re: [Xtext] Debugging an antlr grammar generated with TMF Xtext 0.7.x or 0.8.x [message #505003 is a reply to message #504757] Thu, 24 December 2009 10:08 Go to previous messageGo to next message
Cédric Vidal is currently offline Cédric VidalFriend
Messages: 101
Registered: July 2009
Senior Member
Actually, I posted this question to the wrong forum, it was intended to
be posted to the TMF forum.

Regards,

Cédric

Cédric Vidal a écrit :
> Hi guys,
>
> In oAW Xtext, it was possible to debug the generated antlr grammar with
> ANTLRWorks by simply loading the generated *.g file but it doesn't seem
> possible anymore with TMF Xtext, at least, it's not obvious. I've tried
> to debug the generated Internal<Lang>.g file with Xtext 0.7.[0,1,2] and
> 0.8.0M4 and ANTLRWorks 1.2.3.
>
> What is the recommended way to do this ?
>
> Regards,
>
> Cédric
Re: [Xtext] Debugging an antlr grammar generated with TMF Xtext 0.7.x or 0.8.x [message #505481 is a reply to message #505003] Thu, 31 December 2009 02:38 Go to previous message
Sven Efftinge is currently offline Sven EfftingeFriend
Messages: 1823
Registered: July 2009
Senior Member
We've already started working on that feature.
Here's the corresponding bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=298672

Cheers,
Sven

Cédric Vidal schrieb:
> Actually, I posted this question to the wrong forum, it was intended to
> be posted to the TMF forum.
>
> Regards,
>
> Cédric
>
> Cédric Vidal a écrit :
>> Hi guys,
>>
>> In oAW Xtext, it was possible to debug the generated antlr grammar
>> with ANTLRWorks by simply loading the generated *.g file but it
>> doesn't seem possible anymore with TMF Xtext, at least, it's not
>> obvious. I've tried to debug the generated Internal<Lang>.g file with
>> Xtext 0.7.[0,1,2] and 0.8.0M4 and ANTLRWorks 1.2.3.
>>
>> What is the recommended way to do this ?
>>
>> Regards,
>>
>> Cédric


--
Need professional support for Xtext and EMF?
Go to: http://xtext.itemis.com
Twitter : @svenefftinge
Blog : blog.efftinge.de
Previous Topic:From generated output how to execute another work flow
Next Topic:Re: Xtext Maven Plugin
Goto Forum:
  


Current Time: Fri Mar 05 13:10:36 GMT 2021

Powered by FUDForum. Page generated in 0.02312 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top