Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] 2.0 / 3.0 compatibility
[CDO] 2.0 / 3.0 compatibility [message #503769] Tue, 15 December 2009 17:01 Go to next message
Joel Rosi-Schwartz is currently offline Joel Rosi-SchwartzFriend
Messages: 624
Registered: July 2009
Location: London. England
Senior Member
Hi,

I am using Eclipse Modeling 3.5 SR1 (CDO 2.0). I have created a Target Platform for CDO 3.0 and updated org.eclipse.emf.cdo.server.db to HEAD. I have also checked out all the examples from HEAD.

What I now find is that I cannot use the CDO Session View against servers that are launched in this environment.

I have another Eclipse installation based on Helios M4 and here I have no problem launching the same two servers and connecting with the CDO Session Viewer.

Further, if I launch a server from the Eclipse 3.5 CDO 3.0 environment I cannot attach the CDO Session Viewer using the Helios install. This is the only one that really surprises me.

Cheers,
Joel
Re: [CDO] 2.0 / 3.0 compatibility [message #503867 is a reply to message #503769] Wed, 16 December 2009 07:45 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6450
Registered: July 2009
Senior Member
Hi Joel,

From other posts I know that these "non-standard" version combinations
are of interst to others, as well, but I'm afraid that I currently don't
have the time to debug the resulting sort of problems myself. I really
hope that you or others can sort it out and report the solution here. If
there's something simple I can change in 3.0 to make it work more
smoothly don't hesitate to ask me. Good luck!

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper



Joel Rosi-Schwartz schrieb:
> Hi,
>
> I am using Eclipse Modeling 3.5 SR1 (CDO 2.0). I have created a Target
> Platform for CDO 3.0 and updated org.eclipse.emf.cdo.server.db to
> HEAD. I have also checked out all the examples from HEAD.
>
> What I now find is that I cannot use the CDO Session View against
> servers that are launched in this environment.
>
> I have another Eclipse installation based on Helios M4 and here I have
> no problem launching the same two servers and connecting with the CDO
> Session Viewer.
> Further, if I launch a server from the Eclipse 3.5 CDO 3.0 environment
> I cannot attach the CDO Session Viewer using the Helios install. This
> is the only one that really surprises me.
>
> Cheers,
> Joel


Previous Topic:[teneo] delete not the references
Next Topic:[CDO] OutOfMemoryError when committing frequently
Goto Forum:
  


Current Time: Tue Nov 12 11:29:59 GMT 2019

Powered by FUDForum. Page generated in 0.01604 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top