Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » SVG
SVG [message #503502] Mon, 14 December 2009 14:25 Go to next message
Ali Koudri is currently offline Ali KoudriFriend
Messages: 118
Registered: July 2009
Senior Member
Hi All,

Has anyone tried the SVG Figure feature of gmfgraph with success ? I
tried but unfortunately it fails for me, although I have installed GMF
experimental features.

Cheers.
Re: SVG [message #503531 is a reply to message #503502] Mon, 14 December 2009 10:51 Go to previous messageGo to next message
Aurélien Pupier is currently offline Aurélien PupierFriend
Messages: 637
Registered: July 2009
Location: Grenoble, FRANCE
Senior Member

Hi,

we succesfully used it in BonitaSoft Open Solutions Studio http://www.bonitasoft.com/

You can look at the source code here : http://www.bonitasoft.org/websvn/

And if you want some help on it, please precise what you have done and what is the result (error, stacktrace,...)

Regards,

Aurelien Pupier


Aurélien Pupier - Red Hat
Senior Software Engineer in Fuse Tooling team
Re: SVG [message #503563 is a reply to message #503531] Mon, 14 December 2009 12:34 Go to previous messageGo to next message
Ali Koudri is currently offline Ali KoudriFriend
Messages: 118
Registered: July 2009
Senior Member
Thx for the help, I tried and I got this error:

java.lang.NoClassDefFoundError: org/eclipse/gmf/runtime/lite/svg/SVGFigure

I have checked the dependency to the org.eclipse.gmf.runtime.lite.svg
plugin, it seems OK ! Plus, I have no error at compile time !

Best regards.

Le 14/12/2009 11:51, Aurelien Pupier a écrit :
> Hi,
>
> we succesfully used it in BonitaSoft Open Solutions Studio
> http://www.bonitasoft.com/
>
> You can look at the source code here : http://www.bonitasoft.org/websvn/
>
> And if you want some help on it, please precise what you have done and
> what is the result (error, stacktrace,...)
>
> Regards,
>
> Aurelien Pupier
Re: SVG [message #503590 is a reply to message #503563] Mon, 14 December 2009 20:18 Go to previous message
Ali Koudri is currently offline Ali KoudriFriend
Messages: 118
Registered: July 2009
Senior Member
Problem solved !
I think this actually a bug of eclipse. The problem comes from the fact
I generated an independant figure plugin and used the mirrored gmfgraph
model in the gmfmap model.

Thx four your help Aurelien,
Best regards.

Le 14/12/2009 18:33, exquisitus a écrit :
> Thx for the help, I tried and I got this error:
>
> java.lang.NoClassDefFoundError: org/eclipse/gmf/runtime/lite/svg/SVGFigure
>
> I have checked the dependency to the org.eclipse.gmf.runtime.lite.svg
> plugin, it seems OK ! Plus, I have no error at compile time !
>
> Best regards.
>
> Le 14/12/2009 11:51, Aurelien Pupier a écrit :
>> Hi,
>>
>> we succesfully used it in BonitaSoft Open Solutions Studio
>> http://www.bonitasoft.com/
>>
>> You can look at the source code here : http://www.bonitasoft.org/websvn/
>>
>> And if you want some help on it, please precise what you have done and
>> what is the result (error, stacktrace,...)
>>
>> Regards,
>>
>> Aurelien Pupier
>
Previous Topic:[TENEO & GMF] problem in closeDataStore function
Next Topic:Issues with Undo/Redo on custom AbstractTransactinnalCommand
Goto Forum:
  


Current Time: Sun Apr 18 22:22:58 GMT 2021

Powered by FUDForum. Page generated in 0.01736 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top