Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Can't launch runtime workspace
Can't launch runtime workspace [message #500726] Fri, 27 November 2009 18:20
Matthew Dickie is currently offline Matthew DickieFriend
Messages: 56
Registered: July 2009
Member
Hi,

I am having difficulties in launching a runtime workspace for my
product. I am using Eclipse 3.5.1 (with GEF and EMF-XSD also installed).
In the process of trying to solve this problem, I have tried the
following:

- Reinstalling Eclipse 3.5.1, GEF-ALL 3.5.1 and emf-xsd-SDK-2.5.0 to a
new location
- Creating a new workspace and importing my projects into it (using
General > Existing Project into workspace)
- Creating a new product definition file (renaming the old one to
my.product.old), adding my projects and pressing 'Add Required'.
- Under 'Testing' in the product configuration page, pressing
'Synchronize' then 'Launch an Eclipse Application'

I get the following error:
- The application could not start. Would you like to view the log?
The log contains the following entry:
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench"
could not be found in the registry. The applications available are:
org.eclipse.equinox.p2.artifact.repository.mirrorApplication ,
org.eclipse.equinox.p2.metadata.repository.mirrorApplication ,
org.eclipse.equinox.app.error.
at
org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
etc....

Searching for references to the org.eclipse.core.runtime.applications
extension point, I find that this plugin is defined in the plugin
org.eclipse.ui.ide.application, which wasn't added when I pressed 'Add
Required Plug-ins'. So, I add this to the list of plugins for my
product. Launching this also fails, with the following log entries:


!ENTRY org.eclipse.osgi 2 0 2009-11-27 18:17:31.464
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-27 18:17:31.464
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.ui.ide.application_1.0.101.M200908 26-0800.jar/
was not resolved.
!SUBENTRY 2 org.eclipse.ui.ide.application 2 0 2009-11-27 18:17:31.464
!MESSAGE Missing required bundle org.eclipse.core.net_[1.0.0,2.0.0).

!ENTRY org.eclipse.osgi 2 0 2009-11-27 18:17:31.466
!MESSAGE The following is a complete list of bundles which are not
resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-27 18:17:31.466
!MESSAGE Bundle org.eclipse.ui.ide.application_1.0.101.M20090826-0800
[68] was not resolved.
!SUBENTRY 2 org.eclipse.ui.ide.application 2 0 2009-11-27 18:17:31.466
!MESSAGE Missing required bundle org.eclipse.core.net_[1.0.0,2.0.0).

!ENTRY org.eclipse.osgi 4 0 2009-11-27 18:17:31.476
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench"
could not be found in the registry. The applications available are:
org.eclipse.equinox.p2.artifact.repository.mirrorApplication ,
org.eclipse.equinox.p2.metadata.repository.mirrorApplication ,
org.eclipse.equinox.app.error.
at
org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
at
org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)



However, launching a plugin as a runtime workbench by right-clicking on
it and selecting Run As > Eclipse Application does work.

Can anyone help me figure out what is going on. Am I doing something wrong?

Thanks in advance...



Matt D.
Previous Topic:Plugin udpate doesn't work
Next Topic:Can't launch runtime workspace
Goto Forum:
  


Current Time: Sun Aug 09 05:57:22 GMT 2020

Powered by FUDForum. Page generated in 0.01717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top