Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Eclipse PDT+Subversive plugin issue(Cannot work with those plugins together on Eclpse Galileo)
Eclipse PDT+Subversive plugin issue [message #500322] Wed, 25 November 2009 16:16 Go to next message
Cristian Gómez is currently offline Cristian GómezFriend
Messages: 13
Registered: October 2009
Junior Member
Hi guys

Here I'm again with a question. I'm interested in working with Subversion on Eclipse. I previosly had a working Eclipse Galileo+PDT environment (with PDT version: 2.2.0.v200911190058-7L7J-F8NcJKhTTUhJK5Y).
I add the subversive plugin [1] to Eclipse. When I restart Eclipse and successfully install the last SVNKit connector version, I proceed to import the SVN repository as a new project (again without any troubles), but when I try to edit a file with the PHP editor I have this error [2], you can see the screenshot here [3]

In the details of the error this is what I see on Session Data:
eclipse.buildId=M20090917-0800
java.version=1.6.0_15
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_CO
Framework arguments:  -product org.eclipse.epp.package.php.product -product org.eclipse.epp.package.php.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.php.product -data C:\Documents and Settings\Jairo Parra\workspace_svn -product org.eclipse.epp.package.php.product

Just in case, when I open a file of the project with the 'Text Editor' option I can see the file contentes withou trouble as you can see on [4]

I hope you can give me a hand on this.

Thanks for your attention

[1] http://www.eclipse.org/subversive/downloads.php#galileo_rele ase
[2] http://pastebin.com/f67e918fc
[3] http://img81.imageshack.us/img81/1877/problemg.png
[4] http://img81.imageshack.us/img81/5357/pruebak.png
Re: Eclipse PDT+Subversive plugin issue [message #500323 is a reply to message #500322] Wed, 25 November 2009 16:19 Go to previous messageGo to next message
Michael Spector is currently offline Michael SpectorFriend
Messages: 110
Registered: July 2009
Senior Member

You have an incompatible version of DLTK. Please install the appropriate one as it's stated on the PDT download page.
Re: Eclipse PDT+Subversive plugin issue [message #500334 is a reply to message #500323] Wed, 25 November 2009 16:39 Go to previous messageGo to next message
Cristian Gómez is currently offline Cristian GómezFriend
Messages: 13
Registered: October 2009
Junior Member
Thanks for your answer. I'm sorry I can't understand you. I don't see anything about DLTK version on [1] that are the instructions that I follow. If you can provide me a URL it will be great!. In this images [2] and [3] you can see the plugins that I have with their versions and the sites that I use to install them.

[1] http://wiki.eclipse.org/PDT/Installation#Eclipse_3.5_.2F_Gal ileo_.2F_PDT_2.2
[2] http://img81.imageshack.us/img81/3103/plugins.png
[3] http://img163.imageshack.us/img163/9383/sources.png
Re: Eclipse PDT+Subversive plugin issue [message #501190 is a reply to message #500322] Tue, 01 December 2009 13:29 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 1
Registered: December 2009
Junior Member
having the same problem. looks like they simply pushed some update to some update-site without updating dependencies. had working installation before applying updates just now killing my pdt.

what Michael is talking about is: http://www.eclipse.org/pdt/downloads/. you can download a version and check the site every other day if a new one came up. maybe this works, don't know.

but installing/updating from update site as stated in [1] you mention is broken.

edit: just tried 2.2.0M3 (2009/11/12) "all-in-one" update site and it won't install until you enable the dltk-v2.0 update site as mentioned in [1] (so this is no "all-in-one"... at least not what it means to me). but this gives the same errors after installation. don't know how to get a working 2.2 pdt atm.

edit2: okey, just found http://www.eclipse.org/forums/index.php?t=msg&th=158419& amp;start=0. looks like 2.2 is experimental. not "stable". so i'm back on 2.1.

[1] http://wiki.eclipse.org/PDT/Installation#Eclipse_3.5_.2F_Gal ileo_.2F_PDT_2.2

[Updated on: Tue, 01 December 2009 14:03]

Report message to a moderator

Re: Eclipse PDT+Subversive plugin issue [message #501200 is a reply to message #501190] Tue, 01 December 2009 14:17 Go to previous message
Cristian Gómez is currently offline Cristian GómezFriend
Messages: 13
Registered: October 2009
Junior Member
No Real Name wrote on Tue, 01 December 2009 08:29
....edit2: okey, just found http://www.eclipse.org/forums/index.php?t=msg&th=158419& amp; amp; amp;start=0. looks like 2.2 is experimental. not "stable". so i'm back on 2.1....
Thanks for your answer No Real Name. What you say it's probably a good workaround but since I have this answer [1] with a hung that I was experiencing I don't know what to expect. I guess I'll have to wait for a working environment with PDT and meanwhile keep working with PHPEclipse.

PD: I'm working with same PDT/DLTK configuration in another instance of Eclipse and it works great, just the instance with Subversive/Subclipse plugin fails to open the editor. It's not problem araised by Subversive/Subclipse as I have a working instance of eEclipse with Subclipse+PHPEclipse.

Thanks for your further answers

[1] http://www.eclipse.org/forums/index.php?t=msg&S=170bf4b0 be39753b9805bef7f45cd8b1&th=156709&goto=495284#msg_4 95284

[Updated on: Tue, 01 December 2009 14:21]

Report message to a moderator

Previous Topic:How to solve the problem of saving a .htm file?
Next Topic:"org.eclipse.ui.ide.workbench" could not be found in the registry
Goto Forum:
  


Current Time: Tue May 18 02:36:08 GMT 2021

Powered by FUDForum. Page generated in 0.02078 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top