Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EEF] EEF fails to create all classes
[EEF] EEF fails to create all classes [message #499411] Sun, 22 November 2009 03:26 Go to next message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 69
Registered: July 2009
Location: Toronto
Member

I am trying to follow the EEF tutorial an generate custom Property Views for a simple ECore Model. I used the latest version of EEF (Nov 17) and an old one (Nov 10). I am not able to generate all classes, only <Model>PropertiesEditionComponent class is generated.

The error log shows few errors like:


java.lang.IllegalArgumentException
at org.eclipse.ocl.ecore.EcoreEvaluationEnvironment.navigatePro perty(EcoreEvaluationEnvironment.java:178)
at org.eclipse.ocl.ecore.EcoreEvaluationEnvironment.navigatePro perty(EcoreEvaluationEnvironment.java:1)
at org.eclipse.ocl.EvaluationVisitorImpl.visitPropertyCallExp(E valuationVisitorImpl.java:1925)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitPropertyCallExp(AcceleoEvaluationVisitor.ja va:953)
at org.eclipse.ocl.ecore.impl.PropertyCallExpImpl.accept(Proper tyCallExpImpl.java:246)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor$ParameterInitExpression.accept(AcceleoEvaluation Visitor.java:1420)
at org.eclipse.ocl.EvaluationVisitorImpl.visitVariable(Evaluati onVisitorImpl.java:1976)
at org.eclipse.ocl.EvaluationVisitorDecorator.visitVariable(Eva luationVisitorDecorator.java:340)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoQueryInvocation(AcceleoEvaluationVis itor.java:653)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 358)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.model.mtl.impl.spec.QueryInvocationSpec. accept(QueryInvocationSpec.java:45)
at org.eclipse.ocl.EvaluationVisitorImpl.visitOperationCallExp( EvaluationVisitorImpl.java:161)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitOperationCallExp(AcceleoEvaluationVisitor.j ava:942)
at org.eclipse.ocl.ecore.impl.OperationCallExpImpl.accept(Opera tionCallExpImpl.java:399)
at org.eclipse.ocl.EvaluationVisitorImpl.visitOperationCallExp( EvaluationVisitorImpl.java:161)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitOperationCallExp(AcceleoEvaluationVisitor.j ava:942)
at org.eclipse.ocl.ecore.impl.OperationCallExpImpl.accept(Opera tionCallExpImpl.java:399)
at org.eclipse.ocl.AbstractEvaluationVisitor.visitExpression(Ab stractEvaluationVisitor.java:246)
at org.eclipse.ocl.EvaluationVisitorDecorator.visitExpression(E valuationVisitorDecorator.java:156)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 366)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.evaluateGuards(AcceleoEvaluationVisitor.java:110 3)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.prepareInvocation(AcceleoEvaluationVisitor.java: 1233)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoTemplateInvocation(AcceleoEvaluation Visitor.java:786)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 356)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoForBlock(AcceleoEvaluationVisitor.ja va:415)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 350)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoBlock(AcceleoEvaluationVisitor.java: 237)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoIfBlock(AcceleoEvaluationVisitor.jav a:496)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 347)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoFileBlock(AcceleoEvaluationVisitor.j ava:304)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 353)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoForBlock(AcceleoEvaluationVisitor.ja va:415)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 350)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoIfBlock(AcceleoEvaluationVisitor.jav a:464)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 347)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoForBlock(AcceleoEvaluationVisitor.ja va:415)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 350)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitAcceleoTemplate(AcceleoEvaluationVisitor.ja va:769)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 345)
at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
at org.eclipse.ocl.internal.evaluation.QueryImpl.evaluate(Query Impl.java:152)
at org.eclipse.ocl.ecore.QueryImpl.evaluate(QueryImpl.java:62)
at org.eclipse.acceleo.engine.generation.AcceleoEngine.doEvalua te(AcceleoEngine.java:266)
at org.eclipse.acceleo.engine.generation.AcceleoEngine.evaluate (AcceleoEngine.java:130)
at org.eclipse.acceleo.engine.service.AcceleoService.doGenerate Template(AcceleoService.java:593)
at org.eclipse.acceleo.engine.service.AcceleoService.doGenerate (AcceleoService.java:429)
at org.eclipse.emf.eef.codegen.components.SubPropertiesEditionC omponent.doGenerate(SubPropertiesEditionComponent.java:285)
at org.eclipse.emf.eef.codegen.ui.generators.common.GenerateAll .doGenerate(GenerateAll.java:122)
at org.eclipse.emf.eef.codegen.ui.generators.actions.AbstractGe nerateEEFAction$1.run(AbstractGenerateEEFAction.java:103)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)


eclipse.buildId=M20090917-0800
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
Framework arguments: -product org.eclipse.epp.package.modeling.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.modeling.product


Any help is greatly appreciated.
Thanks,

Ioan
Re: [EEF] EEF fails to create all classes [message #499522 is a reply to message #499411] Mon, 23 November 2009 07:56 Go to previous messageGo to next message
Goulwen Le Fur is currently offline Goulwen Le FurFriend
Messages: 125
Registered: July 2009
Senior Member
Hi Ioan,

It seems that Acceleo encounter troubles with you models. Can you
validate the 2 models in the .components file (editionContext and
repository) and ensure that they haven't problem.

Cheers,

--
Goulwen Le Fur - goulwen.lefur@obeo.fr

Ioan a écrit :
> I am trying to follow the EEF tutorial an generate custom Property Views
> for a simple ECore Model. I used the latest version of EEF (Nov 17) and
> an old one (Nov 10). I am not able to generate all classes, only
> <Model>PropertiesEditionComponent class is generated.
>
> The error log shows few errors like:
>
> java.lang.IllegalArgumentException
> at org.eclipse.ocl.ecore.EcoreEvaluationEnvironment.navigatePro
> perty(EcoreEvaluationEnvironment.java:178)
> at org.eclipse.ocl.ecore.EcoreEvaluationEnvironment.navigatePro
> perty(EcoreEvaluationEnvironment.java:1)
> at org.eclipse.ocl.EvaluationVisitorImpl.visitPropertyCallExp(E
> valuationVisitorImpl.java:1925)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitPropertyCallExp(AcceleoEvaluationVisitor.ja va:953)
> at org.eclipse.ocl.ecore.impl.PropertyCallExpImpl.accept(Proper
> tyCallExpImpl.java:246)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor$ParameterInitExpression.accept(AcceleoEvaluation
> Visitor.java:1420)
> at org.eclipse.ocl.EvaluationVisitorImpl.visitVariable(Evaluati
> onVisitorImpl.java:1976)
> at org.eclipse.ocl.EvaluationVisitorDecorator.visitVariable(Eva
> luationVisitorDecorator.java:340)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoQueryInvocation(AcceleoEvaluationVis itor.java:653)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 358)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.model.mtl.impl.spec.QueryInvocationSpec.
> accept(QueryInvocationSpec.java:45)
> at org.eclipse.ocl.EvaluationVisitorImpl.visitOperationCallExp(
> EvaluationVisitorImpl.java:161)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitOperationCallExp(AcceleoEvaluationVisitor.j ava:942)
> at org.eclipse.ocl.ecore.impl.OperationCallExpImpl.accept(Opera
> tionCallExpImpl.java:399)
> at org.eclipse.ocl.EvaluationVisitorImpl.visitOperationCallExp(
> EvaluationVisitorImpl.java:161)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitOperationCallExp(AcceleoEvaluationVisitor.j ava:942)
> at org.eclipse.ocl.ecore.impl.OperationCallExpImpl.accept(Opera
> tionCallExpImpl.java:399)
> at org.eclipse.ocl.AbstractEvaluationVisitor.visitExpression(Ab
> stractEvaluationVisitor.java:246)
> at org.eclipse.ocl.EvaluationVisitorDecorator.visitExpression(E
> valuationVisitorDecorator.java:156)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 366)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.evaluateGuards(AcceleoEvaluationVisitor.java:110 3)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.prepareInvocation(AcceleoEvaluationVisitor.java: 1233)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoTemplateInvocation(AcceleoEvaluation
> Visitor.java:786)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 356)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoForBlock(AcceleoEvaluationVisitor.ja va:415)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 350)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoBlock(AcceleoEvaluationVisitor.java: 237)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoIfBlock(AcceleoEvaluationVisitor.jav a:496)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 347)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoFileBlock(AcceleoEvaluationVisitor.j ava:304)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 353)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoForBlock(AcceleoEvaluationVisitor.ja va:415)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 350)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoIfBlock(AcceleoEvaluationVisitor.jav a:464)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 347)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoForBlock(AcceleoEvaluationVisitor.ja va:415)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 350)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitAcceleoTemplate(AcceleoEvaluationVisitor.ja va:769)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.switchExpression(AcceleoEvaluationVisitor.java:1 345)
> at org.eclipse.acceleo.engine.internal.evaluation.AcceleoEvalua
> tionVisitor.visitExpression(AcceleoEvaluationVisitor.java:87 1)
> at org.eclipse.ocl.internal.evaluation.QueryImpl.evaluate(Query
> Impl.java:152)
> at org.eclipse.ocl.ecore.QueryImpl.evaluate(QueryImpl.java:62)
> at org.eclipse.acceleo.engine.generation.AcceleoEngine.doEvalua
> te(AcceleoEngine.java:266)
> at org.eclipse.acceleo.engine.generation.AcceleoEngine.evaluate
> (AcceleoEngine.java:130)
> at org.eclipse.acceleo.engine.service.AcceleoService.doGenerate
> Template(AcceleoService.java:593)
> at org.eclipse.acceleo.engine.service.AcceleoService.doGenerate
> (AcceleoService.java:429)
> at org.eclipse.emf.eef.codegen.components.SubPropertiesEditionC
> omponent.doGenerate(SubPropertiesEditionComponent.java:285)
> at org.eclipse.emf.eef.codegen.ui.generators.common.GenerateAll
> .doGenerate(GenerateAll.java:122)
> at org.eclipse.emf.eef.codegen.ui.generators.actions.AbstractGe
> nerateEEFAction$1.run(AbstractGenerateEEFAction.java:103)
> at org.eclipse.jface.operation.ModalContext$ModalContextThread.
> run(ModalContext.java:121)
>
>
> eclipse.buildId=M20090917-0800
> java.version=1.6.0_13
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
> Framework arguments: -product org.eclipse.epp.package.modeling.product
> Command-line arguments: -os win32 -ws win32 -arch x86 -product
> org.eclipse.epp.package.modeling.product
>
>
> Any help is greatly appreciated.
> Thanks,
>
> Ioan
Re: [EEF] EEF fails to create all classes [message #499780 is a reply to message #499522] Tue, 24 November 2009 05:36 Go to previous messageGo to next message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 69
Registered: July 2009
Location: Toronto
Member

Goulwen Le Fur wrote on Mon, 23 November 2009 02:56
Hi Ioan,

It seems that Acceleo encounter troubles with you models. Can you
validate the 2 models in the .components file (editionContext and
repository) and ensure that they haven't problem.

Cheers,




Hi Goulwen,

I created a Simple.ecore model and Simple.genmodel. Then execute "Simple.genmodel/EEF/Initialize EEF models" followed by "Simple.eefgen/EEF/Generate EEF Architecture". Inside of Simple.components, both models are valid, but I just get one file generated.

<?xml version="1.0" encoding="UTF-8"?>
<ecore:EPackage xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore" name="Simple"
nsURI="http://www.simple.com/2009" nsPrefix="simple">
<eClassifiers xsi:type="ecore:EClass" name="Model">
<eStructuralFeatures xsi:type="ecore:EAttribute" name="name" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EReference" name="elements" upperBound="-1"
eType="#//Element" containment="true"/>
</eClassifiers>
<eClassifiers xsi:type="ecore:EClass" name="Element">
<eStructuralFeatures xsi:type="ecore:EAttribute" name="name" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EAttribute" name="min" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EAttribute" name="max" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EReference" name="attributes" upperBound="-1"
eType="#//Attribute" containment="true"/>
</eClassifiers>
<eClassifiers xsi:type="ecore:EClass" name="Attribute">
<eStructuralFeatures xsi:type="ecore:EAttribute" name="name" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
</eClassifiers>
</ecore:EPackage>


I am working with Eclipse Galileo SR1 + EEF Nightly Build from November 23, 2009. Also, I was able to use Acceleo with a model that conforms to Simple.ecore without problems.

Thanks,

Ioan

[Updated on: Tue, 24 November 2009 05:55]

Report message to a moderator

Re: [EEF] EEF fails to create all classes [message #499821 is a reply to message #499780] Tue, 24 November 2009 09:45 Go to previous messageGo to next message
Goulwen Le Fur is currently offline Goulwen Le FurFriend
Messages: 125
Registered: July 2009
Senior Member
Hi Ioan,

I can't reproduce your problem. Here is the test I done this morning :
- Download eclipse 3.5.1
- Adding M2T update site
(http://download.eclipse.org/modeling/m2t/updates/interim/) and EEF
nightly update site
( http://download.eclipse.org/modeling/emft/eef/updates/nigthl y/)
- installing EMF and the 2 EEF features
- create an Empty EMF project
- Create a Ecore file and copying your example in it
- Creating the EMF Gen model
- Defining a base package (I remembered that EEF need a basePackage for
the moment)
- Generating Model and Edit projects
- Adding EEF runtime as dependency of the Edit project
- Initialize EEF models
- Rename the src-gen target generation directory in src
- Launch generation.

It works !

Can you try this please ?

Cheers,

--
Goulwen Le Fur - goulwen.lefur@obeo.fr


Ioan Salau a écrit :
> Goulwen Le Fur wrote on Mon, 23 November 2009 02:56
>> Hi Ioan,
>>
>> It seems that Acceleo encounter troubles with you models. Can you
>> validate the 2 models in the .components file (editionContext and
>> repository) and ensure that they haven't problem.
>>
>> Cheers,
>
>
> Hi Goulwen,
>
> I created a Simple.ecore model and Simple.genmodel. Then execute
> "Simple.genmodel/EEF/Initialize EEF models" followed by
> "Simple.eefgen/EEF/Generate EEF Architecture". Inside of
> Simple.components, both models are valid, but I just get one file
> generated.
> <?xml version="1.0" encoding="UTF-8"?>
> <ecore:EPackage xmi:version="2.0"
> xmlns:xmi="http://www.omg.org/XMI"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore" name="Simple"
> nsURI="http://www.simple.com/2009" nsPrefix="simple">
> <eClassifiers xsi:type="ecore:EClass" name="Model">
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="name"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EReference" name="elements"
> upperBound="-1"
> eType="#//Element" containment="true"/>
> </eClassifiers>
> <eClassifiers xsi:type="ecore:EClass" name="Element">
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="name"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="min"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="max"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EReference" name="attributes"
> upperBound="-1"
> eType="#//Attribute" containment="true"/>
> </eClassifiers>
> <eClassifiers xsi:type="ecore:EClass" name="Attribute">
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="name"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> </eClassifiers>
> </ecore:EPackage>
>
>
> I am working with Eclipse Galileo SR1 + EEF Nightly Build from November
> 23, 2009.
>
> Thanks,
>
> Ioan
Re: [EEF] EEF fails to create all classes [message #500114 is a reply to message #499821] Wed, 25 November 2009 02:52 Go to previous messageGo to next message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 69
Registered: July 2009
Location: Toronto
Member

Goulwen Le Fur wrote on Tue, 24 November 2009 04:45
Hi Ioan,

I can't reproduce your problem. Here is the test I done this morning :
- Download eclipse 3.5.1
- Adding M2T update site
(http://download.eclipse.org/modeling/m2t/updates/interim/) and EEF
nightly update site
( http://download.eclipse.org/modeling/emft/eef/updates/nigthl y/)
- installing EMF and the 2 EEF features
- create an Empty EMF project
- Create a Ecore file and copying your example in it
- Creating the EMF Gen model
- Defining a base package (I remembered that EEF need a basePackage for
the moment)
- Generating Model and Edit projects
- Adding EEF runtime as dependency of the Edit project
- Initialize EEF models
- Rename the src-gen target generation directory in src
- Launch generation.

It works !

Can you try this please ?

Cheers,




Hi Goulwen,

I followed your recommendations and I was able to generate all EEF classes. Trying to figure out what went wrong before, I realized that I was using Eclipse Modeling Package Galileo SR1 (based on Eclipse SDK 3.5.1) which comes with a newer version of Acceleo 0.9.0v200911100609. The M2T update site
(http://download.eclipse.org/modeling/m2t/updates/interim/) has an older version of Acceleo 0.9.0v200909261229 which works fine with EEF.
I guess it might be a bug on Acceleo
0.9.0v200911100609, but you won't be able to get EEF working once you upgrade your Acceleo to this newer version.

Thanks,
Ioan
Re: [EEF] EEF fails to create all classes [message #500165 is a reply to message #500114] Wed, 25 November 2009 08:50 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1892
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------050900000405000103070509
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

Hi Ioan,

I introduced a blocking bug in the M3 build of Acceleo that prevents
generation in some specific cases. This has been fixed very recently and
though I haven't kicked in a new integration build, the bug will be
fixed in the next.

Laurent Goubet
Obeo

Ioan Salau wrote:
> Goulwen Le Fur wrote on Tue, 24 November 2009 04:45
>> Hi Ioan,
>>
>> I can't reproduce your problem. Here is the test I done this morning :
>> - Download eclipse 3.5.1
>> - Adding M2T update site
>> (http://download.eclipse.org/modeling/m2t/updates/interim/) and EEF
>> nightly update site (
>> http://download.eclipse.org/modeling/emft/eef/updates/nigthl y/)
>> - installing EMF and the 2 EEF features
>> - create an Empty EMF project
>> - Create a Ecore file and copying your example in it
>> - Creating the EMF Gen model
>> - Defining a base package (I remembered that EEF need a
>> basePackage for the moment)
>> - Generating Model and Edit projects
>> - Adding EEF runtime as dependency of the Edit project
>> - Initialize EEF models
>> - Rename the src-gen target generation directory in src
>> - Launch generation.
>>
>> It works !
>>
>> Can you try this please ?
>>
>> Cheers,
>
>
> Hi Goulwen,
>
> I followed your recommendations and I was able to generate all EEF
> classes. Trying to figure out what went wrong before, I realized that I
> was using Eclipse Modeling Package Galileo SR1 (based on Eclipse SDK
> 3.5.1) which comes with a newer version of Acceleo 0.9.0v200911100609.
> The M2T update site
> (http://download.eclipse.org/modeling/m2t/updates/interim/) has an older
> version of Acceleo 0.9.0v200909261229 which works fine with EEF.
> I guess it might be a bug on Acceleo 0.9.0v200911100609, but you won't
> be able to get EEF working once you upgrade your Acceleo to this newer
> version.
> Thanks,
> Ioan


--------------050900000405000103070509
Content-Type: text/x-vcard; charset=utf-8;
name="laurent_goubet.vcf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="laurent_goubet.vcf"

YmVnaW46dmNhcmQNCmZuOkxhdXJlbnQgR291YmV0DQpuOkdvdWJldDtMYXVy ZW50DQpvcmc6
PGEgaHJlZj0iaHR0cDovL3d3dy5vYmVvLmZyIj5PYmVvPC9hPg0KZW1haWw7 aW50ZXJuZXQ6
bGF1cmVudC5nb3ViZXRAb2Jlby5mcg0KdXJsOmh0dHA6Ly93d3cub2Jlby5m cg0KdmVyc2lv
bjoyLjENCmVuZDp2Y2FyZA0KDQo=
--------------050900000405000103070509--
Re: [EEF] EEF fails to create all classes [message #621602 is a reply to message #499522] Tue, 24 November 2009 05:37 Go to previous message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 69
Registered: July 2009
Location: Toronto
Member

Goulwen Le Fur wrote on Mon, 23 November 2009 02:56
> Hi Ioan,
>
> It seems that Acceleo encounter troubles with you models. Can you
> validate the 2 models in the .components file (editionContext and
> repository) and ensure that they haven't problem.
>
> Cheers,


Hi Goulwen,

I created a Simple.ecore model and Simple.genmodel. Then execute "Simple.genmodel/EEF/Initialize EEF models" followed by "Simple.eefgen/EEF/Generate EEF Architecture". Inside of Simple.components, both models are valid, but I just get one file generated.

<?xml version="1.0" encoding="UTF-8"?>
<ecore:EPackage xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore" name="Simple"
nsURI="http://www.simple.com/2009" nsPrefix="simple">
<eClassifiers xsi:type="ecore:EClass" name="Model">
<eStructuralFeatures xsi:type="ecore:EAttribute" name="name" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EReference" name="elements" upperBound="-1"
eType="#//Element" containment="true"/>
</eClassifiers>
<eClassifiers xsi:type="ecore:EClass" name="Element">
<eStructuralFeatures xsi:type="ecore:EAttribute" name="name" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EAttribute" name="min" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EAttribute" name="max" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
<eStructuralFeatures xsi:type="ecore:EReference" name="attributes" upperBound="-1"
eType="#//Attribute" containment="true"/>
</eClassifiers>
<eClassifiers xsi:type="ecore:EClass" name="Attribute">
<eStructuralFeatures xsi:type="ecore:EAttribute" name="name" eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
</eClassifiers>
</ecore:EPackage>


I am working with Eclipse Galileo SR1 + EEF Nightly Build from November 23, 2009.

Thanks,

Ioan
Re: [EEF] EEF fails to create all classes [message #621603 is a reply to message #621602] Tue, 24 November 2009 09:45 Go to previous message
Goulwen Le Fur is currently offline Goulwen Le FurFriend
Messages: 125
Registered: July 2009
Senior Member
Hi Ioan,

I can't reproduce your problem. Here is the test I done this morning :
- Download eclipse 3.5.1
- Adding M2T update site
(http://download.eclipse.org/modeling/m2t/updates/interim/) and EEF
nightly update site
( http://download.eclipse.org/modeling/emft/eef/updates/nigthl y/)
- installing EMF and the 2 EEF features
- create an Empty EMF project
- Create a Ecore file and copying your example in it
- Creating the EMF Gen model
- Defining a base package (I remembered that EEF need a basePackage for
the moment)
- Generating Model and Edit projects
- Adding EEF runtime as dependency of the Edit project
- Initialize EEF models
- Rename the src-gen target generation directory in src
- Launch generation.

It works !

Can you try this please ?

Cheers,

--
Goulwen Le Fur - goulwen.lefur@obeo.fr


Ioan Salau a écrit :
> Goulwen Le Fur wrote on Mon, 23 November 2009 02:56
>> Hi Ioan,
>>
>> It seems that Acceleo encounter troubles with you models. Can you
>> validate the 2 models in the .components file (editionContext and
>> repository) and ensure that they haven't problem.
>>
>> Cheers,
>
>
> Hi Goulwen,
>
> I created a Simple.ecore model and Simple.genmodel. Then execute
> "Simple.genmodel/EEF/Initialize EEF models" followed by
> "Simple.eefgen/EEF/Generate EEF Architecture". Inside of
> Simple.components, both models are valid, but I just get one file
> generated.
> <?xml version="1.0" encoding="UTF-8"?>
> <ecore:EPackage xmi:version="2.0"
> xmlns:xmi="http://www.omg.org/XMI"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore" name="Simple"
> nsURI="http://www.simple.com/2009" nsPrefix="simple">
> <eClassifiers xsi:type="ecore:EClass" name="Model">
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="name"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EReference" name="elements"
> upperBound="-1"
> eType="#//Element" containment="true"/>
> </eClassifiers>
> <eClassifiers xsi:type="ecore:EClass" name="Element">
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="name"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="min"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="max"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> <eStructuralFeatures xsi:type="ecore:EReference" name="attributes"
> upperBound="-1"
> eType="#//Attribute" containment="true"/>
> </eClassifiers>
> <eClassifiers xsi:type="ecore:EClass" name="Attribute">
> <eStructuralFeatures xsi:type="ecore:EAttribute" name="name"
> eType="ecore:EDataType http://www.eclipse.org/emf/2002/Ecore#//EString"/>
> </eClassifiers>
> </ecore:EPackage>
>
>
> I am working with Eclipse Galileo SR1 + EEF Nightly Build from November
> 23, 2009.
>
> Thanks,
>
> Ioan
Re: [EEF] EEF fails to create all classes [message #621607 is a reply to message #499821] Wed, 25 November 2009 02:52 Go to previous message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 69
Registered: July 2009
Location: Toronto
Member

Goulwen Le Fur wrote on Tue, 24 November 2009 04:45
> Hi Ioan,
>
> I can't reproduce your problem. Here is the test I done this morning :
> - Download eclipse 3.5.1
> - Adding M2T update site
> (http://download.eclipse.org/modeling/m2t/updates/interim/) and EEF
> nightly update site
> ( http://download.eclipse.org/modeling/emft/eef/updates/nigthl y/)
> - installing EMF and the 2 EEF features
> - create an Empty EMF project
> - Create a Ecore file and copying your example in it
> - Creating the EMF Gen model
> - Defining a base package (I remembered that EEF need a basePackage for
> the moment)
> - Generating Model and Edit projects
> - Adding EEF runtime as dependency of the Edit project
> - Initialize EEF models
> - Rename the src-gen target generation directory in src
> - Launch generation.
>
> It works !
>
> Can you try this please ?
>
> Cheers,


Hi Goulwen,

I followed your recommendations and I was able to generate all EEF classes. Trying to figure out what went wrong before, I realized that I was using Eclipse Modeling Package Galileo SR1 (based on Eclipse SDK 3.5.1) which comes with a newer version of Acceleo 0.9.0v200911100609. The M2T update site
(http://download.eclipse.org/modeling/m2t/updates/interim/) has an older version of Acceleo 0.9.0v200909261229 which works fine with EEF.
I guess it might be a bug on Acceleo
0.9.0v200911100609, but you won't be able to get EEF working once you upgrade your Acceleo to this newer version.

Thanks,
Ioan
Re: [EEF] EEF fails to create all classes [message #621609 is a reply to message #621607] Wed, 25 November 2009 08:50 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1892
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------050900000405000103070509
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

Hi Ioan,

I introduced a blocking bug in the M3 build of Acceleo that prevents
generation in some specific cases. This has been fixed very recently and
though I haven't kicked in a new integration build, the bug will be
fixed in the next.

Laurent Goubet
Obeo

Ioan Salau wrote:
> Goulwen Le Fur wrote on Tue, 24 November 2009 04:45
>> Hi Ioan,
>>
>> I can't reproduce your problem. Here is the test I done this morning :
>> - Download eclipse 3.5.1
>> - Adding M2T update site
>> (http://download.eclipse.org/modeling/m2t/updates/interim/) and EEF
>> nightly update site (
>> http://download.eclipse.org/modeling/emft/eef/updates/nigthl y/)
>> - installing EMF and the 2 EEF features
>> - create an Empty EMF project
>> - Create a Ecore file and copying your example in it
>> - Creating the EMF Gen model
>> - Defining a base package (I remembered that EEF need a
>> basePackage for the moment)
>> - Generating Model and Edit projects
>> - Adding EEF runtime as dependency of the Edit project
>> - Initialize EEF models
>> - Rename the src-gen target generation directory in src
>> - Launch generation.
>>
>> It works !
>>
>> Can you try this please ?
>>
>> Cheers,
>
>
> Hi Goulwen,
>
> I followed your recommendations and I was able to generate all EEF
> classes. Trying to figure out what went wrong before, I realized that I
> was using Eclipse Modeling Package Galileo SR1 (based on Eclipse SDK
> 3.5.1) which comes with a newer version of Acceleo 0.9.0v200911100609.
> The M2T update site
> (http://download.eclipse.org/modeling/m2t/updates/interim/) has an older
> version of Acceleo 0.9.0v200909261229 which works fine with EEF.
> I guess it might be a bug on Acceleo 0.9.0v200911100609, but you won't
> be able to get EEF working once you upgrade your Acceleo to this newer
> version.
> Thanks,
> Ioan


--------------050900000405000103070509
Content-Type: text/x-vcard; charset=utf-8;
name="laurent_goubet.vcf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="laurent_goubet.vcf"

YmVnaW46dmNhcmQNCmZuOkxhdXJlbnQgR291YmV0DQpuOkdvdWJldDtMYXVy ZW50DQpvcmc6
PGEgaHJlZj0iaHR0cDovL3d3dy5vYmVvLmZyIj5PYmVvPC9hPg0KZW1haWw7 aW50ZXJuZXQ6
bGF1cmVudC5nb3ViZXRAb2Jlby5mcg0KdXJsOmh0dHA6Ly93d3cub2Jlby5m cg0KdmVyc2lv
bjoyLjENCmVuZDp2Y2FyZA0KDQo=
--------------050900000405000103070509--
Previous Topic:[EEF] EEF fails to create all classes
Next Topic:how can i get an create an Instance of EList<Eobject>?
Goto Forum:
  


Current Time: Sun Jun 13 06:37:08 GMT 2021

Powered by FUDForum. Page generated in 0.02107 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top