Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Code assist on Javascript toolkits like Prototype, JQuery etc using JSDT inside Eclipse PDT
Code assist on Javascript toolkits like Prototype, JQuery etc using JSDT inside Eclipse PDT [message #496500] Tue, 10 November 2009 11:09 Go to next message
Christos Pontikis is currently offline Christos PontikisFriend
Messages: 2
Registered: November 2009
Location: Athens, Greece
Junior Member
Hello,

I am using Eclipse PDT for PHP web development (2.1 SR-1 PDT-All-in-one using Galileo platform) on Linux (Ubuntu Jaunty 9.04) in a modern laptop (Fujitsu-Siemens Amilo Xi 3650)

Concerning coding, PHP, HTML, CSS, common JAVASCRIPT and also php debug (using xdebug), everything seems to work very good.

But, I would like to have code assist for Javascript Toolkits like Prototype (http://www.prototypejs.org), JQuery (http://www.jquery.com). I supposed I could use the excellent JSDT included in PDT (really, the whole package is included, or someone has to setup WTP???).

Please, note that
*** I have installed JSEclipse, which is working perfectly with Prototype (but is not supporting JQuery --- another problem is that JSEclipse development is cancelled...).
*** I tried to install Aptana, but I met a lot of problems... installing "Azax Framework Plugins" using plugin manager.
*** I also installed Spket (http://www.spket.com/), that is partially working...

I added Prototype as User Libraries, I selected Javascript Editor in .js File Associations, but code assist is not working.

What I have to do, so JSDT to support external javascript libraries like Prototype, JQuery etc?

Thank you!
Re: Code assist on Javascript toolkits like Prototype, JQuery etc using JSDT inside Eclipse PDT [message #496511 is a reply to message #496500] Tue, 10 November 2009 11:48 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
I'm using Aptana many months without any problem, pls use 1.5.x version
Re: Code assist on Javascript toolkits like Prototype, JQuery etc using JSDT inside Eclipse PDT [message #496615 is a reply to message #496500] Tue, 10 November 2009 17:01 Go to previous messageGo to next message
Christos Pontikis is currently offline Christos PontikisFriend
Messages: 2
Registered: November 2009
Location: Athens, Greece
Junior Member
Hi sNop

yes, you are right! I installed Aptana Studio 1.5.1 as Eclipse plugin in my Ubuntu box from
http://update15.aptana.org/studio/26124/
(thanks Google)

Afterwards, I was able to install Prototype and JQuery support, which are working fine.

But, please, note, I cannot setup neither Prototype nor JQuery support to Aptana Studio 2.0 neither as standalone application nor as Eclipse (Galileo) plugin. I don not know why. Just an infined loop after trying to setup plugins ('Calculating requirements and dependencies ') Confused

Thank you sNop, this is a solution. But I do believe that JSDT can do the job some way
Meet the JavaScript Development Toolkit
http://www.ibm.com/developerworks/library/os-eclipse-jsdt/

If someone has similar experience, let us know.

Regards
Re: Code assist on Javascript toolkits like Prototype, JQuery etc using JSDT inside Eclipse PDT [message #496644 is a reply to message #496615] Tue, 10 November 2009 18:21 Go to previous message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Christos Pontikis napsal(a):
> Hi sNop
>
> yes, you are right! I installed Aptana Studio 1.5.1 as Eclipse plugin in
> my Ubuntu box from
> http://update15.aptana.org/studio/26124/
> (thanks Google)
>
> Afterwards, I was able to install Prototype and JQuery support, which
> are working fine.
>
> But, please, note, I cannot setup neither Prototype nor JQuery support
> to Aptana Studio 2.0 neither as standalone application nor as Eclipse
> (Galileo) plugin. I don not know why. Just an infined loop after trying
> to setup plugins ('Calculating requirements and dependencies ') :?

Aptana 2.0 isn't finished version and there are very much features which doesn't work

> Thank you sNop, this is a solution. But I do believe that JSDT can do
> the job some way
> Meet the JavaScript Development Toolkit
> http://www.ibm.com/developerworks/library/os-eclipse-jsdt/
>
> If someone has similar experience, let us know.

JSDT doesn't support any JS toolkit, if you have question about JSDT pls go to the JSDT newsgroup

>
> Regards
>
Previous Topic:Code folding doesn't work for me
Next Topic:encoding problems
Goto Forum:
  


Current Time: Sun May 16 19:38:19 GMT 2021

Powered by FUDForum. Page generated in 0.02374 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top