Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Cannot export RCP app
Cannot export RCP app [message #493017] Thu, 22 October 2009 18:04 Go to next message
Michael Y is currently offline Michael YFriend
Messages: 5
Registered: July 2009
Junior Member
Hello,

I am trying to export my RCP app. I am able to get the application to
run just fine in eclipse but when I try to export via PDE i get this
error near the end of the export process.

Cannot complete the install because one or more required items could
not be found.
Software being installed: MYApp 2.1.14.1666 (myapp 2.1.14.1666)
Missing requirement: MYApp 2.1.14.1666 (myapp 2.1.14.1666) requires
'MYAppFeature.feature.group [2.1.14.1666]' but it could not be found

I have verified that all my dependencies are correct in the product and
feature configuration files.

I am using eclipse 3.5.1 in Ubuntu 9.0.4 64bit. This was working fine in
eclipse 3.5.1 on windows until my drive crashed.

Any help would be greatly appreciated.

Best Regards,
Mike
Re: Cannot export RCP app [message #493040 is a reply to message #493017] Thu, 22 October 2009 19:53 Go to previous message
Michael Y is currently offline Michael YFriend
Messages: 5
Registered: July 2009
Junior Member
I have discovered that the product will export fine if the "generate
metadata repository option is turned off". I have also tried a fresh
install of eclipse with the original workspace and the issue still arises.

Best Regards,
Mike

Michael Y wrote:
> Hello,
>
> I am trying to export my RCP app. I am able to get the application to
> run just fine in eclipse but when I try to export via PDE i get this
> error near the end of the export process.
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: MYApp 2.1.14.1666 (myapp 2.1.14.1666)
> Missing requirement: MYApp 2.1.14.1666 (myapp 2.1.14.1666) requires
> 'MYAppFeature.feature.group [2.1.14.1666]' but it could not be found
>
> I have verified that all my dependencies are correct in the product and
> feature configuration files.
>
> I am using eclipse 3.5.1 in Ubuntu 9.0.4 64bit. This was working fine in
> eclipse 3.5.1 on windows until my drive crashed.
>
> Any help would be greatly appreciated.
>
> Best Regards,
> Mike
Re: Cannot export RCP app [message #602807 is a reply to message #493017] Thu, 22 October 2009 19:53 Go to previous message
Michael Y is currently offline Michael YFriend
Messages: 5
Registered: July 2009
Junior Member
I have discovered that the product will export fine if the "generate
metadata repository option is turned off". I have also tried a fresh
install of eclipse with the original workspace and the issue still arises.

Best Regards,
Mike

Michael Y wrote:
> Hello,
>
> I am trying to export my RCP app. I am able to get the application to
> run just fine in eclipse but when I try to export via PDE i get this
> error near the end of the export process.
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: MYApp 2.1.14.1666 (myapp 2.1.14.1666)
> Missing requirement: MYApp 2.1.14.1666 (myapp 2.1.14.1666) requires
> 'MYAppFeature.feature.group [2.1.14.1666]' but it could not be found
>
> I have verified that all my dependencies are correct in the product and
> feature configuration files.
>
> I am using eclipse 3.5.1 in Ubuntu 9.0.4 64bit. This was working fine in
> eclipse 3.5.1 on windows until my drive crashed.
>
> Any help would be greatly appreciated.
>
> Best Regards,
> Mike
Previous Topic:Cannot export RCP app
Next Topic:Changing eclipse icon
Goto Forum:
  


Current Time: Mon Aug 03 10:04:51 GMT 2020

Powered by FUDForum. Page generated in 0.06309 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top