Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » support for JUnit4?
support for JUnit4? [message #4328] Thu, 06 November 2008 22:32 Go to next message
Joe Luebker is currently offline Joe LuebkerFriend
Messages: 36
Registered: July 2009
Member
I noticed in the users guide at
http://swtbot.sourceforge.net/users-guide.html that there is a mention
to "Ensure that you're using JUnit 3".

Is there any planned support for JUnit 4? Or maybe that is already built
in and that statement was made only so that the example runs correctly?

Thanks,
Joe Luebker
Re: support for JUnit4? [message #4398 is a reply to message #4328] Fri, 07 November 2008 03:04 Go to previous message
Ketan Padegaonkar is currently offline Ketan PadegaonkarFriend
Messages: 873
Registered: July 2009
Senior Member
Technically you can still use JUnit 4 to write and run your tests, for
both plain SWT and RCP/plugins.

The problem arises if you'd like to run pde based SWTBot tests from the
command line via the eclipse test framework. More info on this bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=153429

-- Ketan

Joe Luebker wrote:
> I noticed in the users guide at
> http://swtbot.sourceforge.net/users-guide.html that there is a mention
> to "Ensure that you're using JUnit 3".
>
> Is there any planned support for JUnit 4? Or maybe that is already built
> in and that statement was made only so that the example runs correctly?
>
> Thanks,
> Joe Luebker
Previous Topic:Changes in SWTBot license from Apache License 2.0 to EPL
Next Topic:test of my SWT application
Goto Forum:
  


Current Time: Fri Sep 17 08:11:58 GMT 2021

Powered by FUDForum. Page generated in 0.01512 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top