Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE Export and Debug Info
PDE Export and Debug Info [message #49014] Wed, 04 March 2009 10:06 Go to next message
Manuel Selva is currently offline Manuel SelvaFriend
Messages: 189
Registered: July 2009
Location: Grenoble, France
Senior Member
Hi there,

I am trying to compare class file size differences between classes with
debug info and classes without.

To do that I just change my project Java Compiler options. Looking at the
class file size generated in my plugin bin directory clearly show a
difference between classes with debug info and classes without.

My problem is that classes files always have the same size in both cases
(with or without debug info) after having exported my plug-in using
"graphical exporter" (righ click -> export as ...)

It seems PDE always export plug-ins with debug info when I export
graphically. Why ? Did I miss something ?

I know I can set javacDebugInfo=true in my headless build but I just want
to understand why graphically export doesn't behave as expected for me ...

Thanks in advance

Manu


Re: PDE Export and Debug Info [message #49072 is a reply to message #49014] Wed, 04 March 2009 15:26 Go to previous messageGo to next message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Manuel Selva wrote:
> Hi there,
>
> I am trying to compare class file size differences between classes with
> debug info and classes without.
>
> To do that I just change my project Java Compiler options. Looking at
> the class file size generated in my plugin bin directory clearly show a
> difference between classes with debug info and classes without.
>
> My problem is that classes files always have the same size in both cases
> (with or without debug info) after having exported my plug-in using
> "graphical exporter" (righ click -> export as ...)
>
> It seems PDE always export plug-ins with debug info when I export
> graphically. Why ? Did I miss something ?
>
> I know I can set javacDebugInfo=true in my headless build but I just
> want to understand why graphically export doesn't behave as expected for
> me ...

PDE doesn't use the class files that you in your workspace when you
export from the UI (this is true before Eclipse 3.5 is released which
you will have the option to use the class files from the workspace). In
your build.properties for your plug-in project, you can set
'javacDebugInfo' to true or false and that will tell PDE Build to build
(compile) the plug-in with debug info.

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: PDE Export and Debug Info [message #49130 is a reply to message #49072] Wed, 04 March 2009 15:41 Go to previous messageGo to next message
Manuel Selva is currently offline Manuel SelvaFriend
Messages: 189
Registered: July 2009
Location: Grenoble, France
Senior Member
Thanks for this info Chris !!!

Now I have an other problem with my headless build where changing the
build.properties file of my "build configuration" and not every
build.properties of all my plug-ins doesn't change nothing in generated
class files.

After looking at the build.xml file generated by pde all seems ok and it
seems that debug=on is passed to the javac task but .... generated classes
don't have debug informations !!!

Any ideas ?

Thanks again

Manu


Re: PDE Export and Debug Info [message #49158 is a reply to message #49072] Wed, 04 March 2009 16:14 Go to previous message
Manuel Selva is currently offline Manuel SelvaFriend
Messages: 189
Registered: July 2009
Location: Grenoble, France
Senior Member
Houpss ... setting javacDebugInfo in my plug-in build.properties file
doesn't seem to work.

Here is my build.properties (I am running eclipse 3.4.2)

source.. = src/
output.. = bin/
bin.includes = plugin.xml,\
META-INF/,\
.,\
icons/
javacDebugInfo = true

Thanks

Manu


Re: PDE Export and Debug Info [message #592690 is a reply to message #49014] Wed, 04 March 2009 15:26 Go to previous message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Manuel Selva wrote:
> Hi there,
>
> I am trying to compare class file size differences between classes with
> debug info and classes without.
>
> To do that I just change my project Java Compiler options. Looking at
> the class file size generated in my plugin bin directory clearly show a
> difference between classes with debug info and classes without.
>
> My problem is that classes files always have the same size in both cases
> (with or without debug info) after having exported my plug-in using
> "graphical exporter" (righ click -> export as ...)
>
> It seems PDE always export plug-ins with debug info when I export
> graphically. Why ? Did I miss something ?
>
> I know I can set javacDebugInfo=true in my headless build but I just
> want to understand why graphically export doesn't behave as expected for
> me ...

PDE doesn't use the class files that you in your workspace when you
export from the UI (this is true before Eclipse 3.5 is released which
you will have the option to use the class files from the workspace). In
your build.properties for your plug-in project, you can set
'javacDebugInfo' to true or false and that will tell PDE Build to build
(compile) the plug-in with debug info.

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: PDE Export and Debug Info [message #592713 is a reply to message #49072] Wed, 04 March 2009 15:41 Go to previous message
Manuel Selva is currently offline Manuel SelvaFriend
Messages: 189
Registered: July 2009
Location: Grenoble, France
Senior Member
Thanks for this info Chris !!!

Now I have an other problem with my headless build where changing the
build.properties file of my "build configuration" and not every
build.properties of all my plug-ins doesn't change nothing in generated
class files.

After looking at the build.xml file generated by pde all seems ok and it
seems that debug=on is passed to the javac task but .... generated classes
don't have debug informations !!!

Any ideas ?

Thanks again

Manu


Re: PDE Export and Debug Info [message #592720 is a reply to message #49072] Wed, 04 March 2009 16:14 Go to previous message
Manuel Selva is currently offline Manuel SelvaFriend
Messages: 189
Registered: July 2009
Location: Grenoble, France
Senior Member
Houpss ... setting javacDebugInfo in my plug-in build.properties file
doesn't seem to work.

Here is my build.properties (I am running eclipse 3.4.2)

source.. = src/
output.. = bin/
bin.includes = plugin.xml,\
META-INF/,\
.,\
icons/
javacDebugInfo = true

Thanks

Manu


Previous Topic:how to observe junit tests
Next Topic:Target 3.4 and 3.5 P2 APIs despite APi changes - fragments?
Goto Forum:
  


Current Time: Sun Jun 20 17:21:41 GMT 2021

Powered by FUDForum. Page generated in 0.01838 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top