Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » Guice in maven?
Guice in maven? [message #478683] Thu, 06 August 2009 12:07 Go to next message
Eclipse UserFriend
Originally posted by: ddd.asd.com

I would like to get started with Guice using maven for a basic offline
application. When I search for 'guice' in the dependency manager I get:

com.google.code.guice guice
com.google.inject guice
com.google.inject guice-parent
com.google.inject.integration guice-servlet
com.google.inject.integration guice-spring
com.google.inject.integration guice-struts2-plugin

But all the above components are version 1.0 and from the website:

http://code.google.com/p/google-guice/

I see that a version 2.0 has been released. I have looked at:

http://code.google.com/p/guice-maven/

and if I search for guice-maven I get:

org.apache.caml guice-maven-plugin

containing:

2.0-M3 - guice-maven-plugin-2.0-M3.maven-plugin
2.0-M2 - guice-maven-plugin-2.0-M2.maven-plugin
2.0-M1 - guice-maven-plugin-2.0-M1.maven-plugin


Any ideas on which guice package to get?
Re: Guice in maven? [message #478686 is a reply to message #478683] Thu, 06 August 2009 12:23 Go to previous message
Eclipse UserFriend
Originally posted by: ddd.asd.com

Adding it maunally to the pom like:

<repositories>
<repository>
<id>guice-maven</id>
<name>guice maven</name>
<url>http://guice-maven.googlecode.com/svn/trunk</url>
</repository>
</repositories>

<dependencies>
<dependency>
<groupId>com.google.code.guice</groupId>
<artifactId>guice</artifactId>
<version>2.0.1</version>
</dependency>
</dependencies>

give the error:

06-08-09 14:20:29 CEST: Missing artifact
com.google.code.guice:guice:jar:2.0.1:compile


"mlt" <ddd@asd.com> wrote in message news:h5eh1q$s5a$1@build.eclipse.org...
>I would like to get started with Guice using maven for a basic offline
>application. When I search for 'guice' in the dependency manager I get:
>
> com.google.code.guice guice
> com.google.inject guice
> com.google.inject guice-parent
> com.google.inject.integration guice-servlet
> com.google.inject.integration guice-spring
> com.google.inject.integration guice-struts2-plugin
>
> But all the above components are version 1.0 and from the website:
>
> http://code.google.com/p/google-guice/
>
> I see that a version 2.0 has been released. I have looked at:
>
> http://code.google.com/p/guice-maven/
>
> and if I search for guice-maven I get:
>
> org.apache.caml guice-maven-plugin
>
> containing:
>
> 2.0-M3 - guice-maven-plugin-2.0-M3.maven-plugin
> 2.0-M2 - guice-maven-plugin-2.0-M2.maven-plugin
> 2.0-M1 - guice-maven-plugin-2.0-M1.maven-plugin
>
>
> Any ideas on which guice package to get?
Previous Topic:phasing out eclipse 3.3 support
Next Topic:Unknow validation error on pom.xml
Goto Forum:
  


Current Time: Sat Nov 18 19:54:43 GMT 2017

Powered by FUDForum. Page generated in 0.02311 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software