Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » 0D0A line ends in Documentation field of UML Editor
0D0A line ends in Documentation field of UML Editor [message #478189] Wed, 11 February 2009 13:58 Go to next message
Andreas Maier is currently offline Andreas MaierFriend
Messages: 32
Registered: July 2009
Member
I am using RSA 7.0.0.8, and the Documentation field of the UML Editor
of RSA uses 0x0D0A sequences as line ends in certain cases, and the 0x0D
character in that sequence causes an issue for us.

In the ECUTE plugin to RSA, we are importing and exporting UML models
from and to the text based CIM MOF format defined by DMTF, where 0x0D
and 0x0A characters in CIM MOF strings (to which we map the
Documentation field) are represented as "\r" and "\n" escape sequences,
respectively.

However, the convention in CIM MOF is that line breaks in strings are
represented as a single "\n", without a preceding "\r".

So the cases in which the field editor uses 0x0D characters as part of
the line end, prevents us from following this CIM MOF convention, i.e.
these cases produce "\r\n" as line end sequence in any exported CIM MOF
files.

The field editor is able to deal with text from imported CIM MOF that
used just "\n" line ends, and produces text that has just 0x0A
characters as line ends, but as soon as the text is modified using the
field editor, that is changed back to 0x0D0A sequences again.

Before we head off to modify our CIM MOF exporter to fold 0x0D0A
sequences in the text into a single "\n" escape in the CIM MOF, I'd like
to understand the following:

1. Is there any setting by which we can get the Documentation field to
get to use just 0x0A characters as line ends ? (I assume no?)

2. Which other fields in the UML Editor have the same behavior as the
Documentation field w.r.t. line end characters ? (I assume all?)

Andy
Re: 0D0A line ends in Documentation field of UML Editor [message #478198 is a reply to message #478189] Tue, 17 February 2009 19:19 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Andy,

The quick answer: 1 - no, 2 - all (I believe).

Please raise a bugzilla if this is a real problem with opensource UML2. If
this is a RSA/UML2 interaction problem you can just email me directly and I
can raise a RTLC on your behalf.

Cheers,
- James.

"Andreas Maier" <maiera@de.ibm.com> wrote in message
news:gmuli6$8va$1@build.eclipse.org...
>I am using RSA 7.0.0.8, and the Documentation field of the UML Editor
> of RSA uses 0x0D0A sequences as line ends in certain cases, and the 0x0D
> character in that sequence causes an issue for us.
>
> In the ECUTE plugin to RSA, we are importing and exporting UML models
> from and to the text based CIM MOF format defined by DMTF, where 0x0D and
> 0x0A characters in CIM MOF strings (to which we map the Documentation
> field) are represented as "\r" and "\n" escape sequences, respectively.
>
> However, the convention in CIM MOF is that line breaks in strings are
> represented as a single "\n", without a preceding "\r".
>
> So the cases in which the field editor uses 0x0D characters as part of the
> line end, prevents us from following this CIM MOF convention, i.e. these
> cases produce "\r\n" as line end sequence in any exported CIM MOF files.
>
> The field editor is able to deal with text from imported CIM MOF that used
> just "\n" line ends, and produces text that has just 0x0A characters as
> line ends, but as soon as the text is modified using the field editor,
> that is changed back to 0x0D0A sequences again.
>
> Before we head off to modify our CIM MOF exporter to fold 0x0D0A
> sequences in the text into a single "\n" escape in the CIM MOF, I'd like
> to understand the following:
>
> 1. Is there any setting by which we can get the Documentation field to
> get to use just 0x0A characters as line ends ? (I assume no?)
>
> 2. Which other fields in the UML Editor have the same behavior as the
> Documentation field w.r.t. line end characters ? (I assume all?)
>
> Andy
>
Re: 0D0A line ends in Documentation field of UML Editor [message #627398 is a reply to message #478189] Tue, 17 February 2009 19:19 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Andy,

The quick answer: 1 - no, 2 - all (I believe).

Please raise a bugzilla if this is a real problem with opensource UML2. If
this is a RSA/UML2 interaction problem you can just email me directly and I
can raise a RTLC on your behalf.

Cheers,
- James.

"Andreas Maier" <maiera@de.ibm.com> wrote in message
news:gmuli6$8va$1@build.eclipse.org...
>I am using RSA 7.0.0.8, and the Documentation field of the UML Editor
> of RSA uses 0x0D0A sequences as line ends in certain cases, and the 0x0D
> character in that sequence causes an issue for us.
>
> In the ECUTE plugin to RSA, we are importing and exporting UML models
> from and to the text based CIM MOF format defined by DMTF, where 0x0D and
> 0x0A characters in CIM MOF strings (to which we map the Documentation
> field) are represented as "\r" and "\n" escape sequences, respectively.
>
> However, the convention in CIM MOF is that line breaks in strings are
> represented as a single "\n", without a preceding "\r".
>
> So the cases in which the field editor uses 0x0D characters as part of the
> line end, prevents us from following this CIM MOF convention, i.e. these
> cases produce "\r\n" as line end sequence in any exported CIM MOF files.
>
> The field editor is able to deal with text from imported CIM MOF that used
> just "\n" line ends, and produces text that has just 0x0A characters as
> line ends, but as soon as the text is modified using the field editor,
> that is changed back to 0x0D0A sequences again.
>
> Before we head off to modify our CIM MOF exporter to fold 0x0D0A
> sequences in the text into a single "\n" escape in the CIM MOF, I'd like
> to understand the following:
>
> 1. Is there any setting by which we can get the Documentation field to
> get to use just 0x0A characters as line ends ? (I assume no?)
>
> 2. Which other fields in the UML Editor have the same behavior as the
> Documentation field w.r.t. line end characters ? (I assume all?)
>
> Andy
>
Previous Topic:Reference to Profile UML stereotype
Next Topic:Extending L2.uml
Goto Forum:
  


Current Time: Thu Apr 02 23:28:18 GMT 2020

Powered by FUDForum. Page generated in 0.04374 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top