Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » stereotypes with MagicDraw
stereotypes with MagicDraw [message #476953] Tue, 19 February 2008 20:55 Go to next message
neto Mising name is currently offline neto Mising nameFriend
Messages: 33
Registered: July 2009
Member
I am using Magicdraw 15.0, eclipse 3.4M4 emf v. 2.3.1 and uml2 v. 2.1.1. I
have a
UML model designed in Magicrdaw and then exported as UML2 (2.x ) EMF model.
In order to use emf and uml2 libraries as standalone I am following the
instrucitons given in:
http://dev.eclipse.org/newslists/news.eclipse.tools.uml2/msg 00833.html

My goal is to perform code generation based on the model stereotypes (using
EMF, UML2 libraries and Velocity templates). However, I am facing some
parsing
problems. The stereotypes used in classes, operations, etc, cannot be read
by
the relevant operation ( element.getAppliedStereotypes()), although they do
appear as applied stereotypes in the exported .uml2 files from Magicdraw.

It is a bug? Of Uml or Magicdraw?

Thanks in advance.

Netuh
Re: stereotypes with MagicDraw [message #476960 is a reply to message #476953] Wed, 20 February 2008 21:58 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Waldemar,

That seems like a rather old posting you make reference to. You might want
to have a look at the code at the bottom of this article..
http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 0_Migration_Guide/guide.html

Also, to determine if your profile is bogus or not, you might want to try to
open it up and apply it using the UML2 sample editor.

If your profile can be applied using the UML2 editor (ie. its good) and you
are still having problems with your standalone application please repost a
question and we can have a more detailed look at it.

Cheers,
- James.

"waldemar neto" <waldemar.neto@gmail.com> wrote in message
news:c45731130f98c0038aa0a38085f8c15e$1@www.eclipse.org...
>I am using Magicdraw 15.0, eclipse 3.4M4 emf v. 2.3.1 and uml2 v. 2.1.1. I
>have a
> UML model designed in Magicrdaw and then exported as UML2 (2.x ) EMF
> model.
> In order to use emf and uml2 libraries as standalone I am following the
> instrucitons given in:
> http://dev.eclipse.org/newslists/news.eclipse.tools.uml2/msg 00833.html
>
> My goal is to perform code generation based on the model stereotypes
> (using
> EMF, UML2 libraries and Velocity templates). However, I am facing some
> parsing
> problems. The stereotypes used in classes, operations, etc, cannot be read
> by
> the relevant operation ( element.getAppliedStereotypes()), although they
> do
> appear as applied stereotypes in the exported .uml2 files from Magicdraw.
>
> It is a bug? Of Uml or Magicdraw?
>
> Thanks in advance.
>
> Netuh
>
Re: stereotypes with MagicDraw [message #626059 is a reply to message #476953] Wed, 20 February 2008 21:58 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Waldemar,

That seems like a rather old posting you make reference to. You might want
to have a look at the code at the bottom of this article..
http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 0_Migration_Guide/guide.html

Also, to determine if your profile is bogus or not, you might want to try to
open it up and apply it using the UML2 sample editor.

If your profile can be applied using the UML2 editor (ie. its good) and you
are still having problems with your standalone application please repost a
question and we can have a more detailed look at it.

Cheers,
- James.

"waldemar neto" <waldemar.neto@gmail.com> wrote in message
news:c45731130f98c0038aa0a38085f8c15e$1@www.eclipse.org...
>I am using Magicdraw 15.0, eclipse 3.4M4 emf v. 2.3.1 and uml2 v. 2.1.1. I
>have a
> UML model designed in Magicrdaw and then exported as UML2 (2.x ) EMF
> model.
> In order to use emf and uml2 libraries as standalone I am following the
> instrucitons given in:
> http://dev.eclipse.org/newslists/news.eclipse.tools.uml2/msg 00833.html
>
> My goal is to perform code generation based on the model stereotypes
> (using
> EMF, UML2 libraries and Velocity templates). However, I am facing some
> parsing
> problems. The stereotypes used in classes, operations, etc, cannot be read
> by
> the relevant operation ( element.getAppliedStereotypes()), although they
> do
> appear as applied stereotypes in the exported .uml2 files from Magicdraw.
>
> It is a bug? Of Uml or Magicdraw?
>
> Thanks in advance.
>
> Netuh
>
Previous Topic:.uml vs. .xmi
Next Topic:Loading a Profile
Goto Forum:
  


Current Time: Fri Aug 12 16:08:09 GMT 2022

Powered by FUDForum. Page generated in 0.02344 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top