Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] how to get more error message when transformation failed?
[ATL] how to get more error message when transformation failed? [message #48295] Fri, 22 June 2007 05:44 Go to next message
stephen Yu is currently offline stephen YuFriend
Messages: 35
Registered: July 2009
Member
Hi,
I wrote a atl file for model transformation, but I always get
NullPointerException like followings: [there are no useful imformation for
me to locate where the problem is :( ]
java.lang.NullPointerException
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:247)
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:168)
at ...........


Is it possible for me to get more error message? I thought I did something
wroing in launchconfiguration, but I revisited it, it seams ok.

Any idea?

Thanks

Stephen
Re: [ATL] how to get more error message when transformation failed? [message #48641 is a reply to message #48295] Mon, 25 June 2007 08:46 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric JouaultFriend
Messages: 572
Registered: July 2009
Senior Member
Hello,


We are constantly working on improving ATL, which includes reporting
more detailed error messages.


Here are three possibilities to help us doing this, ordered by
increasing effectiveness:

1) report an error message issue (preferably as a bugzilla entry) with
as many details as possible.

2) in addition to 1): explain what the error is, and what kind of error
message you would like to see in this case.

3) in addition to 2): submit a patch correcting the issue (i.e.,
providing an appropriate error message for the case identified in 1)).


As you can see, this is simply the usual way open source works ;-).





In your case, because the NullPointerException occurs in the launch
configuration code, your problem is probably in the launch config.

You have already kind of done 1). However, it would be even better to
open a bugzilla entry, and to provide more details (e.g., the version of
ATL you are using).

2) can be done once you have identified the problem. You may do this by
figuring out what is wrong in your launch config. However, it may help
to have a look at the code of AtlLaunchConfigurationDelegate.java,
especially at line 247 ;-).

I have just tried to do this, but without success, because I do not know
which version of ATL you are using.



Regards,

Frédéric Jouault


Stephen Yu wrote:
> Hi,
> I wrote a atl file for model transformation, but I always get
> NullPointerException like followings: [there are no useful imformation
> for me to locate where the problem is :( ]
> java.lang.NullPointerException
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:247)
>
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:168)
>
> at ...........
>
>
> Is it possible for me to get more error message? I thought I did
> something wroing in launchconfiguration, but I revisited it, it seams ok.
>
> Any idea?
>
> Thanks
>
> Stephen
>
Re: [ATL] how to get more error message when transformation failed? [message #50410 is a reply to message #48641] Tue, 03 July 2007 01:21 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: juan.cadavid.gmail.com

Hello,

I'm also having this problem. I'm using the ATL stable development build
of February 16, 2007, with the Europa release versions of Eclipse (3.3)
and EMF (2.3.0).

After trying for a while, I made a checkout from CVS, but had further
problems (No option in the menu to transform from .km3 to .ecore, and
validation problems creating an ATL launch configuration). So I decided to
stay with the development build, and try to find the nature of the error.

The stack trace provided by the error doesn't make sense in the current
CVS version of AtlLaunchConfigurationDelegate.java which is 1.4. But when
exploring version 1.1, the line numbers fit, especially the ones of the
troubled runAtlLauncher() method.

The point where the NullPointerException occurs in that file is:

for(Iterator i = toDispose.iterator() ; i.hasNext() ; ) {
ASMModel model = (ASMModel)i.next();
AtlModelHandler.getHandler(model).disposeOfModel(model);
}

being line 247 the second line of that block statement.

Is there anything we can do as end users to fix this? I can't use the
current code in the CVS since it is not stable. What I'm trying to perform
is not very complicated: I'm trying to run the Author2Person example shown
in the getting started guide.

Here's the complete stack trace:

java.lang.NullPointerException
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:247)
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:168)
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:145)
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:121)
at
org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .launch(AtlLaunchConfigurationDelegate.java:97)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:766)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:608)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:899)
at
org.eclipse.debug.internal.ui.DebugUIPlugin$7.run(DebugUIPlu gin.java:1102)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

I hope I provided enough information about this. Thanks a lot for your
help.

-Juan
juan.cadavid@gmail.com
Re: [ATL] how to get more error message when transformation failed? [message #50628 is a reply to message #50410] Wed, 04 July 2007 08:44 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric JouaultFriend
Messages: 572
Registered: July 2009
Senior Member
Hello Juan,

Thank you very much for your effort.

May I ask you to do a little more work? ;-)

Could you please open a buzilla entry for this issue?
You can copy-and-paste your post as a description.
Also, could you please attach a zip containing your project to this bug
entry?


Thanks,

Frédéric Jouault


Juan wrote:
> Hello,
>
> I'm also having this problem. I'm using the ATL stable development build
> of February 16, 2007, with the Europa release versions of Eclipse (3.3)
> and EMF (2.3.0).
> After trying for a while, I made a checkout from CVS, but had further
> problems (No option in the menu to transform from .km3 to .ecore, and
> validation problems creating an ATL launch configuration). So I decided
> to stay with the development build, and try to find the nature of the
> error.
>
> The stack trace provided by the error doesn't make sense in the current
> CVS version of AtlLaunchConfigurationDelegate.java which is 1.4. But
> when exploring version 1.1, the line numbers fit, especially the ones of
> the troubled runAtlLauncher() method.
>
> The point where the NullPointerException occurs in that file is:
>
> for(Iterator i = toDispose.iterator() ; i.hasNext() ; ) {
> ASMModel model = (ASMModel)i.next();
> AtlModelHandler.getHandler(model).disposeOfModel(model);
> }
>
> being line 247 the second line of that block statement.
> Is there anything we can do as end users to fix this? I can't use the
> current code in the CVS since it is not stable. What I'm trying to
> perform is not very complicated: I'm trying to run the Author2Person
> example shown in the getting started guide.
>
> Here's the complete stack trace:
>
> java.lang.NullPointerException
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:247)
>
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:168)
>
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:145)
>
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .runAtlLauncher(AtlLaunchConfigurationDelegate.java:121)
>
> at
> org.atl.eclipse.adt.launching.AtlLaunchConfigurationDelegate .launch(AtlLaunchConfigurationDelegate.java:97)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:766)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:608)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:899)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin$7.run(DebugUIPlu gin.java:1102)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> I hope I provided enough information about this. Thanks a lot for your
> help.
>
> -Juan
> juan.cadavid@gmail.com
>
Re: [ATL] how to get more error message when transformation failed? [message #51239 is a reply to message #50628] Sat, 07 July 2007 02:53 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: juan.cadavid.gmail.com

Alright, I just posted it with the attachment. I'm not sure if it could be
helpful now that the file has changed so much - version 1.4 of the file is
much shorter than 1.1.

-Juan
Re: [ATL] how to get more error message when transformation failed? [message #51830 is a reply to message #51239] Tue, 10 July 2007 15:07 Go to previous message
Frédéric Jouault is currently offline Frédéric JouaultFriend
Messages: 572
Registered: July 2009
Senior Member
Hello Juan,

> Alright, I just posted it with the attachment. I'm not sure if it could
> be helpful now that the file has changed so much - version 1.4 of the
> file is much shorter than 1.1.

Thank you very much.

We are going to look into this as soon as possible.

Can you please confirm that the bug it still there in the latest CVS
HEAD version? Or do you still have problems getting this version to work?


Regards,

Frédéric Jouault
Previous Topic:[ATL] ATL projector
Next Topic:[ATL]: Create 'thisModule' VariableExp in ATL model
Goto Forum:
  


Current Time: Tue Jan 19 21:39:01 GMT 2021

Powered by FUDForum. Page generated in 0.01892 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top