Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Compatibility of models from 2.0.3 and 2.1
Compatibility of models from 2.0.3 and 2.1 [message #473449] Thu, 28 June 2007 17:04 Go to next message
Dave Carlson is currently offline Dave CarlsonFriend
Messages: 402
Registered: July 2009
Senior Member
I saved a model using UML2 2.1 (created using the UML2Tools editor), then
attempted to open it in an older workspace using UML2 2.0.3. I got lots of
ClassCastException and NullPointerException, resulting from EMF
deserializing everything to AnyType. Opening in the UML2 tree editor for
2.0.3, it defaulted to the EMF generic reflective edit providers.

I discovered that this is because UML2.2.1 saves models using the URI
http://www.eclipse.org/uml2/2.1.0/UML, whereas
http://www.eclipse.org/uml2/2.0.0/UML is used in the 2.0.3 release. I found
a note about this in the New and Noteworthy. However, a specific note about
lack of backward compatibility should be added.

In the 2.1 release of org.eclipse.uml2.uml, the following extension points
allow both new and old models to be opened:

<extension point="org.eclipse.emf.ecore.generated_package">
<package
uri = "http://www.eclipse.org/uml2/2.0.0/UML"
class = "org.eclipse.uml2.uml.UMLPackage"
genModel = "model/UML.genmodel" />
</extension>
<extension point="org.eclipse.emf.ecore.generated_package">
<package
uri = "http://www.eclipse.org/uml2/2.1.0/UML"
class = "org.eclipse.uml2.uml.UMLPackage"
genModel = "model/UML.genmodel" />
</extension>

If I add the 2.1.0 URI declaration to my plugin used with UML2 2.0.3, then
new models are opened there without error. Although, I realize that some
Activity models created using the new release will not open successfully in
the 2.0.3 tools.

Any other workarounds to allow new models to be opened in 2.0.3 release
tools?

Thanks,
Dave Carlson
Re: Compatibility of models from 2.0.3 and 2.1 [message #473451 is a reply to message #473449] Thu, 28 June 2007 17:51 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Dave,

There is a 2.0.4 maintenance release that you should upgrade your 2.0.3
users that will allow them to open up 2.1 models in the older version.
There is a minor issue that was discovered just the other day so a new build
of 2.0.4 will be produced.
There is also a draft version of a migration document that will be published
explaining all of this and why the metamodel was changed.
I will attach the draft version of the migration doc on bugzilla 77413 later
today.

Cheers,

- James.

"Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
news:f60pn3$215$1@build.eclipse.org...
> I saved a model using UML2 2.1 (created using the UML2Tools editor), then
> attempted to open it in an older workspace using UML2 2.0.3. I got lots
of
> ClassCastException and NullPointerException, resulting from EMF
> deserializing everything to AnyType. Opening in the UML2 tree editor for
> 2.0.3, it defaulted to the EMF generic reflective edit providers.
>
> I discovered that this is because UML2.2.1 saves models using the URI
> http://www.eclipse.org/uml2/2.1.0/UML, whereas
> http://www.eclipse.org/uml2/2.0.0/UML is used in the 2.0.3 release. I
found
> a note about this in the New and Noteworthy. However, a specific note
about
> lack of backward compatibility should be added.
>
> In the 2.1 release of org.eclipse.uml2.uml, the following extension points
> allow both new and old models to be opened:
>
> <extension point="org.eclipse.emf.ecore.generated_package">
> <package
> uri = "http://www.eclipse.org/uml2/2.0.0/UML"
> class = "org.eclipse.uml2.uml.UMLPackage"
> genModel = "model/UML.genmodel" />
> </extension>
> <extension point="org.eclipse.emf.ecore.generated_package">
> <package
> uri = "http://www.eclipse.org/uml2/2.1.0/UML"
> class = "org.eclipse.uml2.uml.UMLPackage"
> genModel = "model/UML.genmodel" />
> </extension>
>
> If I add the 2.1.0 URI declaration to my plugin used with UML2 2.0.3, then
> new models are opened there without error. Although, I realize that some
> Activity models created using the new release will not open successfully
in
> the 2.0.3 tools.
>
> Any other workarounds to allow new models to be opened in 2.0.3 release
> tools?
>
> Thanks,
> Dave Carlson
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #473452 is a reply to message #473451] Thu, 28 June 2007 19:27 Go to previous messageGo to next message
Dave Carlson is currently offline Dave CarlsonFriend
Messages: 402
Registered: July 2009
Senior Member
Hi James,
Great, thanks for the details. I was surprised not to see this mentioned
before, but am not surprised by the thoroughness of your team's response in
resolving it :-)

Dave

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f60sed$7ra$2@build.eclipse.org...
> Hi Dave,
>
> There is a 2.0.4 maintenance release that you should upgrade your 2.0.3
> users that will allow them to open up 2.1 models in the older version.
> There is a minor issue that was discovered just the other day so a new
> build
> of 2.0.4 will be produced.
> There is also a draft version of a migration document that will be
> published
> explaining all of this and why the metamodel was changed.
> I will attach the draft version of the migration doc on bugzilla 77413
> later
> today.
Re: Compatibility of models from 2.0.3 and 2.1 [message #473453 is a reply to message #473452] Thu, 28 June 2007 19:38 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Dave,

Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI for
UML2 2.1" . I agree that this might be a little obscure :) The "new &
noteworthy" link is probably the best way to keep on top of new features or
important bug fixes.

I just attached a draft document to bugzilla 77413. Let me know if that
answers all the issues you had.

Cheers,

- James.


"Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
news:f61233$k77$1@build.eclipse.org...
> Hi James,
> Great, thanks for the details. I was surprised not to see this mentioned
> before, but am not surprised by the thoroughness of your team's response
in
> resolving it :-)
>
> Dave
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f60sed$7ra$2@build.eclipse.org...
> > Hi Dave,
> >
> > There is a 2.0.4 maintenance release that you should upgrade your 2.0.3
> > users that will allow them to open up 2.1 models in the older version.
> > There is a minor issue that was discovered just the other day so a new
> > build
> > of 2.0.4 will be produced.
> > There is also a draft version of a migration document that will be
> > published
> > explaining all of this and why the metamodel was changed.
> > I will attach the draft version of the migration doc on bugzilla 77413
> > later
> > today.
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #473765 is a reply to message #473453] Thu, 05 July 2007 14:17 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Dave,

I would recommend picking up the latest M build of 2.0.4 to test migration.
It can be found here:
http://www.eclipse.org/modeling/mdt/news/relnotes.php?projec t=uml2&version=M200707041607
http://www.eclipse.org/modeling/mdt/downloads/?project=uml2& amp;showAll=1&hlbuild=M200707041607#M200707041607


The format of the plugin specification has changed slightly. Try using the
following in a debug envirionment
-Dorg.eclipse.uml2.common.util.CacheAdapter.INSTANCE=org.ecl ipse.uml2.uml:or
g.eclipse.uml2.uml.util.UMLCacheAdapter

Without setting that variable, you will not be able to open up 2.1 models in
2.0.4 environment.

An updated migration document will be posted soon.

Regards,

- James.

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f612nd$lln$2@build.eclipse.org...
> Hi Dave,
>
> Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI
for
> UML2 2.1" . I agree that this might be a little obscure :) The "new &
> noteworthy" link is probably the best way to keep on top of new features
or
> important bug fixes.
>
> I just attached a draft document to bugzilla 77413. Let me know if that
> answers all the issues you had.
>
> Cheers,
>
> - James.
>
>
> "Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
> news:f61233$k77$1@build.eclipse.org...
> > Hi James,
> > Great, thanks for the details. I was surprised not to see this
mentioned
> > before, but am not surprised by the thoroughness of your team's response
> in
> > resolving it :-)
> >
> > Dave
> >
> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
> > news:f60sed$7ra$2@build.eclipse.org...
> > > Hi Dave,
> > >
> > > There is a 2.0.4 maintenance release that you should upgrade your
2.0.3
> > > users that will allow them to open up 2.1 models in the older version.
> > > There is a minor issue that was discovered just the other day so a new
> > > build
> > > of 2.0.4 will be produced.
> > > There is also a draft version of a migration document that will be
> > > published
> > > explaining all of this and why the metamodel was changed.
> > > I will attach the draft version of the migration doc on bugzilla 77413
> > > later
> > > today.
> >
> >
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #473767 is a reply to message #473765] Thu, 05 July 2007 14:19 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
James,

Without that system property, you'll be able to open 2.1 models in 2.0.4,
but models containing transitions and/or connectors will be incomplete.

Kenn

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f6iui5$3qb$2@build.eclipse.org...
> Hi Dave,
>
> I would recommend picking up the latest M build of 2.0.4 to test
> migration.
> It can be found here:
> http://www.eclipse.org/modeling/mdt/news/relnotes.php?projec t=uml2&version=M200707041607
> http://www.eclipse.org/modeling/mdt/downloads/?project=uml2& amp;showAll=1&hlbuild=M200707041607#M200707041607
>
>
> The format of the plugin specification has changed slightly. Try using
> the
> following in a debug envirionment
> -Dorg.eclipse.uml2.common.util.CacheAdapter.INSTANCE=org.ecl ipse.uml2.uml:or
> g.eclipse.uml2.uml.util.UMLCacheAdapter
>
> Without setting that variable, you will not be able to open up 2.1 models
> in
> 2.0.4 environment.
>
> An updated migration document will be posted soon.
>
> Regards,
>
> - James.
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f612nd$lln$2@build.eclipse.org...
>> Hi Dave,
>>
>> Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI
> for
>> UML2 2.1" . I agree that this might be a little obscure :) The "new
>> &
>> noteworthy" link is probably the best way to keep on top of new features
> or
>> important bug fixes.
>>
>> I just attached a draft document to bugzilla 77413. Let me know if that
>> answers all the issues you had.
>>
>> Cheers,
>>
>> - James.
>>
>>
>> "Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
>> news:f61233$k77$1@build.eclipse.org...
>> > Hi James,
>> > Great, thanks for the details. I was surprised not to see this
> mentioned
>> > before, but am not surprised by the thoroughness of your team's
>> > response
>> in
>> > resolving it :-)
>> >
>> > Dave
>> >
>> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
>> > news:f60sed$7ra$2@build.eclipse.org...
>> > > Hi Dave,
>> > >
>> > > There is a 2.0.4 maintenance release that you should upgrade your
> 2.0.3
>> > > users that will allow them to open up 2.1 models in the older
>> > > version.
>> > > There is a minor issue that was discovered just the other day so a
>> > > new
>> > > build
>> > > of 2.0.4 will be produced.
>> > > There is also a draft version of a migration document that will be
>> > > published
>> > > explaining all of this and why the metamodel was changed.
>> > > I will attach the draft version of the migration doc on bugzilla
>> > > 77413
>> > > later
>> > > today.
>> >
>> >
>>
>>
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #473770 is a reply to message #473767] Thu, 05 July 2007 15:24 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
.... that's what I meant ;-)
Thanks for clarifying Kenn.

- James.


"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:f6iulj$43f$1@build.eclipse.org...
> James,
>
> Without that system property, you'll be able to open 2.1 models in 2.0.4,
> but models containing transitions and/or connectors will be incomplete.
>
> Kenn
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f6iui5$3qb$2@build.eclipse.org...
> > Hi Dave,
> >
> > I would recommend picking up the latest M build of 2.0.4 to test
> > migration.
> > It can be found here:
> >
http://www.eclipse.org/modeling/mdt/news/relnotes.php?projec t=uml2&version=M200707041607
> >
http://www.eclipse.org/modeling/mdt/downloads/?project=uml2& amp;showAll=1&hlbuild=M200707041607#M200707041607
> >
> >
> > The format of the plugin specification has changed slightly. Try using
> > the
> > following in a debug envirionment
>
> -Dorg.eclipse.uml2.common.util.CacheAdapter.INSTANCE=org.ecl ipse.uml2.uml:
or
> > g.eclipse.uml2.uml.util.UMLCacheAdapter
> >
> > Without setting that variable, you will not be able to open up 2.1
models
> > in
> > 2.0.4 environment.
> >
> > An updated migration document will be posted soon.
> >
> > Regards,
> >
> > - James.
> >
> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
> > news:f612nd$lln$2@build.eclipse.org...
> >> Hi Dave,
> >>
> >> Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI
> > for
> >> UML2 2.1" . I agree that this might be a little obscure :) The
"new
> >> &
> >> noteworthy" link is probably the best way to keep on top of new
features
> > or
> >> important bug fixes.
> >>
> >> I just attached a draft document to bugzilla 77413. Let me know if
that
> >> answers all the issues you had.
> >>
> >> Cheers,
> >>
> >> - James.
> >>
> >>
> >> "Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
> >> news:f61233$k77$1@build.eclipse.org...
> >> > Hi James,
> >> > Great, thanks for the details. I was surprised not to see this
> > mentioned
> >> > before, but am not surprised by the thoroughness of your team's
> >> > response
> >> in
> >> > resolving it :-)
> >> >
> >> > Dave
> >> >
> >> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
> >> > news:f60sed$7ra$2@build.eclipse.org...
> >> > > Hi Dave,
> >> > >
> >> > > There is a 2.0.4 maintenance release that you should upgrade your
> > 2.0.3
> >> > > users that will allow them to open up 2.1 models in the older
> >> > > version.
> >> > > There is a minor issue that was discovered just the other day so a
> >> > > new
> >> > > build
> >> > > of 2.0.4 will be produced.
> >> > > There is also a draft version of a migration document that will be
> >> > > published
> >> > > explaining all of this and why the metamodel was changed.
> >> > > I will attach the draft version of the migration doc on bugzilla
> >> > > 77413
> >> > > later
> >> > > today.
> >> >
> >> >
> >>
> >>
> >
> >
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #622664 is a reply to message #473449] Thu, 28 June 2007 17:51 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Dave,

There is a 2.0.4 maintenance release that you should upgrade your 2.0.3
users that will allow them to open up 2.1 models in the older version.
There is a minor issue that was discovered just the other day so a new build
of 2.0.4 will be produced.
There is also a draft version of a migration document that will be published
explaining all of this and why the metamodel was changed.
I will attach the draft version of the migration doc on bugzilla 77413 later
today.

Cheers,

- James.

"Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
news:f60pn3$215$1@build.eclipse.org...
> I saved a model using UML2 2.1 (created using the UML2Tools editor), then
> attempted to open it in an older workspace using UML2 2.0.3. I got lots
of
> ClassCastException and NullPointerException, resulting from EMF
> deserializing everything to AnyType. Opening in the UML2 tree editor for
> 2.0.3, it defaulted to the EMF generic reflective edit providers.
>
> I discovered that this is because UML2.2.1 saves models using the URI
> http://www.eclipse.org/uml2/2.1.0/UML, whereas
> http://www.eclipse.org/uml2/2.0.0/UML is used in the 2.0.3 release. I
found
> a note about this in the New and Noteworthy. However, a specific note
about
> lack of backward compatibility should be added.
>
> In the 2.1 release of org.eclipse.uml2.uml, the following extension points
> allow both new and old models to be opened:
>
> <extension point="org.eclipse.emf.ecore.generated_package">
> <package
> uri = "http://www.eclipse.org/uml2/2.0.0/UML"
> class = "org.eclipse.uml2.uml.UMLPackage"
> genModel = "model/UML.genmodel" />
> </extension>
> <extension point="org.eclipse.emf.ecore.generated_package">
> <package
> uri = "http://www.eclipse.org/uml2/2.1.0/UML"
> class = "org.eclipse.uml2.uml.UMLPackage"
> genModel = "model/UML.genmodel" />
> </extension>
>
> If I add the 2.1.0 URI declaration to my plugin used with UML2 2.0.3, then
> new models are opened there without error. Although, I realize that some
> Activity models created using the new release will not open successfully
in
> the 2.0.3 tools.
>
> Any other workarounds to allow new models to be opened in 2.0.3 release
> tools?
>
> Thanks,
> Dave Carlson
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #622665 is a reply to message #473451] Thu, 28 June 2007 19:27 Go to previous message
Dave Carlson is currently offline Dave CarlsonFriend
Messages: 402
Registered: July 2009
Senior Member
Hi James,
Great, thanks for the details. I was surprised not to see this mentioned
before, but am not surprised by the thoroughness of your team's response in
resolving it :-)

Dave

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f60sed$7ra$2@build.eclipse.org...
> Hi Dave,
>
> There is a 2.0.4 maintenance release that you should upgrade your 2.0.3
> users that will allow them to open up 2.1 models in the older version.
> There is a minor issue that was discovered just the other day so a new
> build
> of 2.0.4 will be produced.
> There is also a draft version of a migration document that will be
> published
> explaining all of this and why the metamodel was changed.
> I will attach the draft version of the migration doc on bugzilla 77413
> later
> today.
Re: Compatibility of models from 2.0.3 and 2.1 [message #622666 is a reply to message #473452] Thu, 28 June 2007 19:38 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Dave,

Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI for
UML2 2.1" . I agree that this might be a little obscure :) The "new &
noteworthy" link is probably the best way to keep on top of new features or
important bug fixes.

I just attached a draft document to bugzilla 77413. Let me know if that
answers all the issues you had.

Cheers,

- James.


"Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
news:f61233$k77$1@build.eclipse.org...
> Hi James,
> Great, thanks for the details. I was surprised not to see this mentioned
> before, but am not surprised by the thoroughness of your team's response
in
> resolving it :-)
>
> Dave
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f60sed$7ra$2@build.eclipse.org...
> > Hi Dave,
> >
> > There is a 2.0.4 maintenance release that you should upgrade your 2.0.3
> > users that will allow them to open up 2.1 models in the older version.
> > There is a minor issue that was discovered just the other day so a new
> > build
> > of 2.0.4 will be produced.
> > There is also a draft version of a migration document that will be
> > published
> > explaining all of this and why the metamodel was changed.
> > I will attach the draft version of the migration doc on bugzilla 77413
> > later
> > today.
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #622823 is a reply to message #473453] Thu, 05 July 2007 14:17 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Dave,

I would recommend picking up the latest M build of 2.0.4 to test migration.
It can be found here:
http://www.eclipse.org/modeling/mdt/news/relnotes.php?projec t=uml2&version=M200707041607
http://www.eclipse.org/modeling/mdt/downloads/?project=uml2& amp;showAll=1&hlbuild=M200707041607#M200707041607


The format of the plugin specification has changed slightly. Try using the
following in a debug envirionment
-Dorg.eclipse.uml2.common.util.CacheAdapter.INSTANCE=org.ecl ipse.uml2.uml:or
g.eclipse.uml2.uml.util.UMLCacheAdapter

Without setting that variable, you will not be able to open up 2.1 models in
2.0.4 environment.

An updated migration document will be posted soon.

Regards,

- James.

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f612nd$lln$2@build.eclipse.org...
> Hi Dave,
>
> Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI
for
> UML2 2.1" . I agree that this might be a little obscure :) The "new &
> noteworthy" link is probably the best way to keep on top of new features
or
> important bug fixes.
>
> I just attached a draft document to bugzilla 77413. Let me know if that
> answers all the issues you had.
>
> Cheers,
>
> - James.
>
>
> "Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
> news:f61233$k77$1@build.eclipse.org...
> > Hi James,
> > Great, thanks for the details. I was surprised not to see this
mentioned
> > before, but am not surprised by the thoroughness of your team's response
> in
> > resolving it :-)
> >
> > Dave
> >
> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
> > news:f60sed$7ra$2@build.eclipse.org...
> > > Hi Dave,
> > >
> > > There is a 2.0.4 maintenance release that you should upgrade your
2.0.3
> > > users that will allow them to open up 2.1 models in the older version.
> > > There is a minor issue that was discovered just the other day so a new
> > > build
> > > of 2.0.4 will be produced.
> > > There is also a draft version of a migration document that will be
> > > published
> > > explaining all of this and why the metamodel was changed.
> > > I will attach the draft version of the migration doc on bugzilla 77413
> > > later
> > > today.
> >
> >
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #622829 is a reply to message #473765] Thu, 05 July 2007 14:19 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
James,

Without that system property, you'll be able to open 2.1 models in 2.0.4,
but models containing transitions and/or connectors will be incomplete.

Kenn

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f6iui5$3qb$2@build.eclipse.org...
> Hi Dave,
>
> I would recommend picking up the latest M build of 2.0.4 to test
> migration.
> It can be found here:
> http://www.eclipse.org/modeling/mdt/news/relnotes.php?projec t=uml2&version=M200707041607
> http://www.eclipse.org/modeling/mdt/downloads/?project=uml2& amp;showAll=1&hlbuild=M200707041607#M200707041607
>
>
> The format of the plugin specification has changed slightly. Try using
> the
> following in a debug envirionment
> -Dorg.eclipse.uml2.common.util.CacheAdapter.INSTANCE=org.ecl ipse.uml2.uml:or
> g.eclipse.uml2.uml.util.UMLCacheAdapter
>
> Without setting that variable, you will not be able to open up 2.1 models
> in
> 2.0.4 environment.
>
> An updated migration document will be posted soon.
>
> Regards,
>
> - James.
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f612nd$lln$2@build.eclipse.org...
>> Hi Dave,
>>
>> Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI
> for
>> UML2 2.1" . I agree that this might be a little obscure :) The "new
>> &
>> noteworthy" link is probably the best way to keep on top of new features
> or
>> important bug fixes.
>>
>> I just attached a draft document to bugzilla 77413. Let me know if that
>> answers all the issues you had.
>>
>> Cheers,
>>
>> - James.
>>
>>
>> "Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
>> news:f61233$k77$1@build.eclipse.org...
>> > Hi James,
>> > Great, thanks for the details. I was surprised not to see this
> mentioned
>> > before, but am not surprised by the thoroughness of your team's
>> > response
>> in
>> > resolving it :-)
>> >
>> > Dave
>> >
>> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
>> > news:f60sed$7ra$2@build.eclipse.org...
>> > > Hi Dave,
>> > >
>> > > There is a 2.0.4 maintenance release that you should upgrade your
> 2.0.3
>> > > users that will allow them to open up 2.1 models in the older
>> > > version.
>> > > There is a minor issue that was discovered just the other day so a
>> > > new
>> > > build
>> > > of 2.0.4 will be produced.
>> > > There is also a draft version of a migration document that will be
>> > > published
>> > > explaining all of this and why the metamodel was changed.
>> > > I will attach the draft version of the migration doc on bugzilla
>> > > 77413
>> > > later
>> > > today.
>> >
>> >
>>
>>
>
>
Re: Compatibility of models from 2.0.3 and 2.1 [message #622836 is a reply to message #473767] Thu, 05 July 2007 15:24 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
.... that's what I meant ;-)
Thanks for clarifying Kenn.

- James.


"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:f6iulj$43f$1@build.eclipse.org...
> James,
>
> Without that system property, you'll be able to open 2.1 models in 2.0.4,
> but models containing transitions and/or connectors will be incomplete.
>
> Kenn
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f6iui5$3qb$2@build.eclipse.org...
> > Hi Dave,
> >
> > I would recommend picking up the latest M build of 2.0.4 to test
> > migration.
> > It can be found here:
> >
http://www.eclipse.org/modeling/mdt/news/relnotes.php?projec t=uml2&version=M200707041607
> >
http://www.eclipse.org/modeling/mdt/downloads/?project=uml2& amp;showAll=1&hlbuild=M200707041607#M200707041607
> >
> >
> > The format of the plugin specification has changed slightly. Try using
> > the
> > following in a debug envirionment
>
> -Dorg.eclipse.uml2.common.util.CacheAdapter.INSTANCE=org.ecl ipse.uml2.uml:
or
> > g.eclipse.uml2.uml.util.UMLCacheAdapter
> >
> > Without setting that variable, you will not be able to open up 2.1
models
> > in
> > 2.0.4 environment.
> >
> > An updated migration document will be posted soon.
> >
> > Regards,
> >
> > - James.
> >
> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
> > news:f612nd$lln$2@build.eclipse.org...
> >> Hi Dave,
> >>
> >> Kenn mentioned it in the newsgroup in a posting entitled "Namespace URI
> > for
> >> UML2 2.1" . I agree that this might be a little obscure :) The
"new
> >> &
> >> noteworthy" link is probably the best way to keep on top of new
features
> > or
> >> important bug fixes.
> >>
> >> I just attached a draft document to bugzilla 77413. Let me know if
that
> >> answers all the issues you had.
> >>
> >> Cheers,
> >>
> >> - James.
> >>
> >>
> >> "Dave Carlson" <dcarlson@xmlmodeling.com> wrote in message
> >> news:f61233$k77$1@build.eclipse.org...
> >> > Hi James,
> >> > Great, thanks for the details. I was surprised not to see this
> > mentioned
> >> > before, but am not surprised by the thoroughness of your team's
> >> > response
> >> in
> >> > resolving it :-)
> >> >
> >> > Dave
> >> >
> >> > "James Bruck" <jbruck@ca.ibm.com> wrote in message
> >> > news:f60sed$7ra$2@build.eclipse.org...
> >> > > Hi Dave,
> >> > >
> >> > > There is a 2.0.4 maintenance release that you should upgrade your
> > 2.0.3
> >> > > users that will allow them to open up 2.1 models in the older
> >> > > version.
> >> > > There is a minor issue that was discovered just the other day so a
> >> > > new
> >> > > build
> >> > > of 2.0.4 will be produced.
> >> > > There is also a draft version of a migration document that will be
> >> > > published
> >> > > explaining all of this and why the metamodel was changed.
> >> > > I will attach the draft version of the migration doc on bugzilla
> >> > > 77413
> >> > > later
> >> > > today.
> >> >
> >> >
> >>
> >>
> >
> >
>
>
Previous Topic:Issues with Importing MagicDraw Files into a Simple Project
Next Topic:Connecting DSL-eCore w/ UML2
Goto Forum:
  


Current Time: Thu Apr 02 14:06:32 GMT 2020

Powered by FUDForum. Page generated in 0.02833 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top