Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Bug in UML2Util resource bundle cache?
Bug in UML2Util resource bundle cache? [message #473211] Mon, 18 June 2007 16:15 Go to next message
John Yeung is currently offline John YeungFriend
Messages: 7
Registered: July 2009
Junior Member
Hi,

I've been tracking down some potential memory leaks in my code and found
something in UML2Util.getResourceBundle() which keeps a reference to my
Resource's in the RESOURCE_BUNDLE Map static variable.

It seems that even when a Resource is unloaded, its entry is not removed
from the Map?

I did notice that the Map grows and grows everytime I repeatedly fire up the
sample UML2 model editor, expand the Model element and highlight a Class
element.

Please advice. Am I missing something somewhere to clear the map?

I'm using Eclipse 3.2.1 and UML2 2.0.2

Cheers -
John Yeung
Re: Bug in UML2Util resource bundle cache? [message #473212 is a reply to message #473211] Mon, 18 June 2007 17:33 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi John,

Please log a bugzilla...should probably be using a WeakHashMap.

Cheers,

- James.

"John Yeung" <john@yeungs.net> wrote in message
news:f56an5$7pl$1@build.eclipse.org...
> Hi,
>
> I've been tracking down some potential memory leaks in my code and found
> something in UML2Util.getResourceBundle() which keeps a reference to my
> Resource's in the RESOURCE_BUNDLE Map static variable.
>
> It seems that even when a Resource is unloaded, its entry is not removed
> from the Map?
>
> I did notice that the Map grows and grows everytime I repeatedly fire up
the
> sample UML2 model editor, expand the Model element and highlight a Class
> element.
>
> Please advice. Am I missing something somewhere to clear the map?
>
> I'm using Eclipse 3.2.1 and UML2 2.0.2
>
> Cheers -
> John Yeung
Re: Bug in UML2Util resource bundle cache? [message #473214 is a reply to message #473212] Tue, 19 June 2007 09:23 Go to previous message
John Yeung is currently offline John YeungFriend
Messages: 7
Registered: July 2009
Junior Member
Thanks. I've logged bug #193276. Cheers - John.

James Bruck wrote:

> Hi John,
>
> Please log a bugzilla...should probably be using a WeakHashMap.
>
> Cheers,
>
> - James.
>
> "John Yeung" <john@yeungs.net> wrote in message
> news:f56an5$7pl$1@build.eclipse.org...
>> Hi,
>>
>> I've been tracking down some potential memory leaks in my code and found
>> something in UML2Util.getResourceBundle() which keeps a reference to my
>> Resource's in the RESOURCE_BUNDLE Map static variable.
>>
>> It seems that even when a Resource is unloaded, its entry is not removed
>> from the Map?
>>
>> I did notice that the Map grows and grows everytime I repeatedly fire up
> the
>> sample UML2 model editor, expand the Model element and highlight a Class
>> element.
>>
>> Please advice. Am I missing something somewhere to clear the map?
>>
>> I'm using Eclipse 3.2.1 and UML2 2.0.2
>>
>> Cheers -
>> John Yeung
Re: Bug in UML2Util resource bundle cache? [message #621697 is a reply to message #473211] Mon, 18 June 2007 17:33 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi John,

Please log a bugzilla...should probably be using a WeakHashMap.

Cheers,

- James.

"John Yeung" <john@yeungs.net> wrote in message
news:f56an5$7pl$1@build.eclipse.org...
> Hi,
>
> I've been tracking down some potential memory leaks in my code and found
> something in UML2Util.getResourceBundle() which keeps a reference to my
> Resource's in the RESOURCE_BUNDLE Map static variable.
>
> It seems that even when a Resource is unloaded, its entry is not removed
> from the Map?
>
> I did notice that the Map grows and grows everytime I repeatedly fire up
the
> sample UML2 model editor, expand the Model element and highlight a Class
> element.
>
> Please advice. Am I missing something somewhere to clear the map?
>
> I'm using Eclipse 3.2.1 and UML2 2.0.2
>
> Cheers -
> John Yeung
Re: Bug in UML2Util resource bundle cache? [message #621701 is a reply to message #473212] Tue, 19 June 2007 09:23 Go to previous message
John Yeung is currently offline John YeungFriend
Messages: 7
Registered: July 2009
Junior Member
Thanks. I've logged bug #193276. Cheers - John.

James Bruck wrote:

> Hi John,
>
> Please log a bugzilla...should probably be using a WeakHashMap.
>
> Cheers,
>
> - James.
>
> "John Yeung" <john@yeungs.net> wrote in message
> news:f56an5$7pl$1@build.eclipse.org...
>> Hi,
>>
>> I've been tracking down some potential memory leaks in my code and found
>> something in UML2Util.getResourceBundle() which keeps a reference to my
>> Resource's in the RESOURCE_BUNDLE Map static variable.
>>
>> It seems that even when a Resource is unloaded, its entry is not removed
>> from the Map?
>>
>> I did notice that the Map grows and grows everytime I repeatedly fire up
> the
>> sample UML2 model editor, expand the Model element and highlight a Class
>> element.
>>
>> Please advice. Am I missing something somewhere to clear the map?
>>
>> I'm using Eclipse 3.2.1 and UML2 2.0.2
>>
>> Cheers -
>> John Yeung
Previous Topic:Bug in UML2Util resource bundle cache?
Next Topic:UML2 XMI > SVG via XSLT
Goto Forum:
  


Current Time: Thu Nov 23 07:45:16 GMT 2017

Powered by FUDForum. Page generated in 0.01617 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software