Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Setting stereotype property value
Setting stereotype property value [message #470449] Wed, 29 July 2009 10:05 Go to next message
Terrasson Marc is currently offline Terrasson MarcFriend
Messages: 12
Registered: July 2009
Junior Member
Hi.

I designed a stereotype with a property of type Operation (from UML
metamodel).
I defined the profile.
I applied my profile to another project and the stereotype to a class.

When I want to set the value of my property, Papyrus show me the dialog
box with all operations but when I select any proposal and clic on 'ok',
Papyrus shows me an unhandled event loop exception.

Did I misused something?

Cheers.
Marc.


Here is the errors trace :

java.lang.IllegalArgumentException:
org.eclipse.uml2.uml.internal.impl.OperationImpl@ae48dc (name:
Operation_0, visibility: <unset>) (isLeaf: false, isStatic: false,
isAbstract: false, concurrency: sequential) (isQuery: false)
at
org.eclipse.uml2.uml.internal.operations.ElementOperations.s etValue(ElementOperations.java:838)
at
org.eclipse.uml2.uml.internal.impl.ElementImpl.setValue(Elem entImpl.java:306)
at
com.cea.papyrus.profile.tree.objects.ValueTreeObject.updateV alue(Unknown
Source)
at
com.cea.papyrus.profile.tree.objects.MetaclassValueTreeObjec t.editMe(Unknown
Source)
at
com.cea.papyrus.profile.ui.listeners.DoubleClickListener.ite mDClicked(Unknown
Source)
at
com.cea.papyrus.core.profiles.StereotypePropertiesDoubleClic kListener.itemDClicked(Unknown
Source)
at
com.cea.papyrus.profile.ui.listeners.DoubleClickListener.han dleEvent(Unknown
Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3682)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3293)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2389)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 19)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:289)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:461)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:106)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:169)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
Re: Setting stereotype property value [message #470451 is a reply to message #470449] Thu, 30 July 2009 09:10 Go to previous message
Terrasson Marc is currently offline Terrasson MarcFriend
Messages: 12
Registered: July 2009
Junior Member
Solved.

I unapplied all sterotypes of my profile the
I reapplied the profile and stereotypes and now it works.

Cheers.
Marc.
Re: Setting stereotype property value [message #590803 is a reply to message #470449] Thu, 30 July 2009 09:10 Go to previous message
Terrasson Marc is currently offline Terrasson MarcFriend
Messages: 12
Registered: July 2009
Junior Member
Solved.

I unapplied all sterotypes of my profile the
I reapplied the profile and stereotypes and now it works.

Cheers.
Marc.
Previous Topic:Setting stereotype property value
Next Topic:Best Way to Import Existing UML model into Papyrus
Goto Forum:
  


Current Time: Wed Aug 12 21:49:29 GMT 2020

Powered by FUDForum. Page generated in 0.01498 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top