Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Creating EMF project from xmi file
Creating EMF project from xmi file [message #469720] Tue, 30 January 2007 21:12 Go to next message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
Configuration,
Eclipse 3.2.1 Release
UML 2.0.2 Release


I am trying to create a new EMF project based on an xmi file that was
exported by the Enterprise Architect UML modeling tool.

I created the model with EA, then exported an xmi file. I guess (but not
sure) the xmi is a UML2 model. Beginning of xmi contains:
<?xml version="1.0" encoding="windows-1252"?>
<!DOCTYPE XMI SYSTEM "UML_EA.dtd">
<XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
12:35:07">


Using the File/New/Project wizard, I select EMF project, then select the UML
importer. The UML importer dialog opens, lets me select the xmi file and
press the load button. At this point, there are no obvious errors or
warnings.

However, the NEXT and FINISH buttons are disabled, so I am not able to
continue with the import process.

I tried pressing F1 and/or clicking the ? in the dialog, but the help topics
do not include anything about UML import.

Am I doing something wrong?


Michael
Re: Creating EMF project from xmi file [message #469813 is a reply to message #469720] Wed, 31 January 2007 15:12 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Michael,

Open up the "Error Log" view... go to Window > Show View > PDE Runtime >
Error Log.
Can you see any errors or warnings in there. The importer might have
thrown some exception internally ...
If you can't see anything in the log, please post the file that is causing
you grief and I'll have a look.

Regards,

- James.


"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epocck$cmc$1@utils.eclipse.org...
> Configuration,
> Eclipse 3.2.1 Release
> UML 2.0.2 Release
>
>
> I am trying to create a new EMF project based on an xmi file that was
> exported by the Enterprise Architect UML modeling tool.
>
> I created the model with EA, then exported an xmi file. I guess (but not
> sure) the xmi is a UML2 model. Beginning of xmi contains:
> <?xml version="1.0" encoding="windows-1252"?>
> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
> 12:35:07">
>
>
> Using the File/New/Project wizard, I select EMF project, then select the
UML
> importer. The UML importer dialog opens, lets me select the xmi file and
> press the load button. At this point, there are no obvious errors or
> warnings.
>
> However, the NEXT and FINISH buttons are disabled, so I am not able to
> continue with the import process.
>
> I tried pressing F1 and/or clicking the ? in the dialog, but the help
topics
> do not include anything about UML import.
>
> Am I doing something wrong?
>
>
> Michael
>
>
Re: Creating EMF project from xmi file [message #469814 is a reply to message #469813] Wed, 31 January 2007 15:24 Go to previous messageGo to next message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
James,
There are no entries in Error Log, so here is the xmi. Thanks for offering
to look.

Michael

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:epqblh$7is$2@utils.eclipse.org...
> Hi Michael,
>
> Open up the "Error Log" view... go to Window > Show View > PDE Runtime >
> Error Log.
> Can you see any errors or warnings in there. The importer might have
> thrown some exception internally ...
> If you can't see anything in the log, please post the file that is causing
> you grief and I'll have a look.
>
> Regards,
>
> - James.
>
>
> "Michael Giroux" <michael.giroux@bull.com> wrote in message
> news:epocck$cmc$1@utils.eclipse.org...
>> Configuration,
>> Eclipse 3.2.1 Release
>> UML 2.0.2 Release
>>
>>
>> I am trying to create a new EMF project based on an xmi file that was
>> exported by the Enterprise Architect UML modeling tool.
>>
>> I created the model with EA, then exported an xmi file. I guess (but not
>> sure) the xmi is a UML2 model. Beginning of xmi contains:
>> <?xml version="1.0" encoding="windows-1252"?>
>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>> 12:35:07">
>>
>>
>> Using the File/New/Project wizard, I select EMF project, then select the
> UML
>> importer. The UML importer dialog opens, lets me select the xmi file and
>> press the load button. At this point, there are no obvious errors or
>> warnings.
>>
>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>> continue with the import process.
>>
>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
> topics
>> do not include anything about UML import.
>>
>> Am I doing something wrong?
>>
>>
>> Michael
>>
>>
>
>


Re: Creating EMF project from xmi file [message #469817 is a reply to message #469720] Wed, 31 January 2007 16:00 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Michael,

UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It would
be better if wizard notified you when an invalid input like this is
provided, so please open a Bugzilla report and we'll make the necessary
changes.

Kenn

"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epocck$cmc$1@utils.eclipse.org...
> Configuration,
> Eclipse 3.2.1 Release
> UML 2.0.2 Release
>
>
> I am trying to create a new EMF project based on an xmi file that was
> exported by the Enterprise Architect UML modeling tool.
>
> I created the model with EA, then exported an xmi file. I guess (but not
> sure) the xmi is a UML2 model. Beginning of xmi contains:
> <?xml version="1.0" encoding="windows-1252"?>
> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
> 12:35:07">
>
>
> Using the File/New/Project wizard, I select EMF project, then select the
> UML importer. The UML importer dialog opens, lets me select the xmi file
> and press the load button. At this point, there are no obvious errors or
> warnings.
>
> However, the NEXT and FINISH buttons are disabled, so I am not able to
> continue with the import process.
>
> I tried pressing F1 and/or clicking the ? in the dialog, but the help
> topics do not include anything about UML import.
>
> Am I doing something wrong?
>
>
> Michael
>
Re: Creating EMF project from xmi file [message #469818 is a reply to message #469817] Wed, 31 January 2007 16:11 Go to previous messageGo to next message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
BUG 172330.

Michael

"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:epqeek$msk$1@utils.eclipse.org...
> Michael,
>
> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
> would be better if wizard notified you when an invalid input like this is
> provided, so please open a Bugzilla report and we'll make the necessary
> changes.
>
> Kenn
>
> "Michael Giroux" <michael.giroux@bull.com> wrote in message
> news:epocck$cmc$1@utils.eclipse.org...
>> Configuration,
>> Eclipse 3.2.1 Release
>> UML 2.0.2 Release
>>
>>
>> I am trying to create a new EMF project based on an xmi file that was
>> exported by the Enterprise Architect UML modeling tool.
>>
>> I created the model with EA, then exported an xmi file. I guess (but not
>> sure) the xmi is a UML2 model. Beginning of xmi contains:
>> <?xml version="1.0" encoding="windows-1252"?>
>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>> 12:35:07">
>>
>>
>> Using the File/New/Project wizard, I select EMF project, then select the
>> UML importer. The UML importer dialog opens, lets me select the xmi file
>> and press the load button. At this point, there are no obvious errors or
>> warnings.
>>
>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>> continue with the import process.
>>
>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>> topics do not include anything about UML import.
>>
>> Am I doing something wrong?
>>
>>
>> Michael
>>
>
>
Re: Creating EMF project from xmi file [message #469819 is a reply to message #469818] Wed, 31 January 2007 17:44 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Thanks!

Kenn

"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epqf2k$thq$1@utils.eclipse.org...
> BUG 172330.
>
> Michael
>
> "Kenn Hussey" <khussey@ca.ibm.com> wrote in message
> news:epqeek$msk$1@utils.eclipse.org...
>> Michael,
>>
>> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
>> would be better if wizard notified you when an invalid input like this is
>> provided, so please open a Bugzilla report and we'll make the necessary
>> changes.
>>
>> Kenn
>>
>> "Michael Giroux" <michael.giroux@bull.com> wrote in message
>> news:epocck$cmc$1@utils.eclipse.org...
>>> Configuration,
>>> Eclipse 3.2.1 Release
>>> UML 2.0.2 Release
>>>
>>>
>>> I am trying to create a new EMF project based on an xmi file that was
>>> exported by the Enterprise Architect UML modeling tool.
>>>
>>> I created the model with EA, then exported an xmi file. I guess (but
>>> not sure) the xmi is a UML2 model. Beginning of xmi contains:
>>> <?xml version="1.0" encoding="windows-1252"?>
>>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>>> 12:35:07">
>>>
>>>
>>> Using the File/New/Project wizard, I select EMF project, then select the
>>> UML importer. The UML importer dialog opens, lets me select the xmi
>>> file and press the load button. At this point, there are no obvious
>>> errors or warnings.
>>>
>>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>>> continue with the import process.
>>>
>>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>>> topics do not include anything about UML import.
>>>
>>> Am I doing something wrong?
>>>
>>>
>>> Michael
>>>
>>
>>
>
>
Re: Creating EMF project from xmi file [message #469820 is a reply to message #469817] Wed, 31 January 2007 18:38 Go to previous messageGo to next message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
Kenn,

I exported the xmi file using UML 2.1 format. This resulted in an error
being generated when the UML importer tried to load the file:
The dialog has "Load Problem" in the title with a message of "The class
'Type' is not a valid classifier".

This may reflect an error in the model I'm trying to import.

If you can comment I will appreciate.

Thanks
Michael



"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:epqeek$msk$1@utils.eclipse.org...
> Michael,
>
> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
> would be better if wizard notified you when an invalid input like this is
> provided, so please open a Bugzilla report and we'll make the necessary
> changes.
>
> Kenn
>
> "Michael Giroux" <michael.giroux@bull.com> wrote in message
> news:epocck$cmc$1@utils.eclipse.org...
>> Configuration,
>> Eclipse 3.2.1 Release
>> UML 2.0.2 Release
>>
>>
>> I am trying to create a new EMF project based on an xmi file that was
>> exported by the Enterprise Architect UML modeling tool.
>>
>> I created the model with EA, then exported an xmi file. I guess (but not
>> sure) the xmi is a UML2 model. Beginning of xmi contains:
>> <?xml version="1.0" encoding="windows-1252"?>
>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>> 12:35:07">
>>
>>
>> Using the File/New/Project wizard, I select EMF project, then select the
>> UML importer. The UML importer dialog opens, lets me select the xmi file
>> and press the load button. At this point, there are no obvious errors or
>> warnings.
>>
>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>> continue with the import process.
>>
>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>> topics do not include anything about UML import.
>>
>> Am I doing something wrong?
>>
>>
>> Michael
>>
>
>
Re: Creating EMF project from xmi file [message #469821 is a reply to message #469820] Wed, 31 January 2007 20:36 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Michael,

Are you talking about a different model this time? The one you showed a
snippet from appeared to be UML 1.3, XMI 1.1.

If you can post a sample XMI file that demonstrates the problem, we'll look
into it.

Kenn

"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epqnn5$up8$1@utils.eclipse.org...
> Kenn,
>
> I exported the xmi file using UML 2.1 format. This resulted in an error
> being generated when the UML importer tried to load the file:
> The dialog has "Load Problem" in the title with a message of "The class
> 'Type' is not a valid classifier".
>
> This may reflect an error in the model I'm trying to import.
>
> If you can comment I will appreciate.
>
> Thanks
> Michael
>
>
>
> "Kenn Hussey" <khussey@ca.ibm.com> wrote in message
> news:epqeek$msk$1@utils.eclipse.org...
>> Michael,
>>
>> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
>> would be better if wizard notified you when an invalid input like this is
>> provided, so please open a Bugzilla report and we'll make the necessary
>> changes.
>>
>> Kenn
>>
>> "Michael Giroux" <michael.giroux@bull.com> wrote in message
>> news:epocck$cmc$1@utils.eclipse.org...
>>> Configuration,
>>> Eclipse 3.2.1 Release
>>> UML 2.0.2 Release
>>>
>>>
>>> I am trying to create a new EMF project based on an xmi file that was
>>> exported by the Enterprise Architect UML modeling tool.
>>>
>>> I created the model with EA, then exported an xmi file. I guess (but
>>> not sure) the xmi is a UML2 model. Beginning of xmi contains:
>>> <?xml version="1.0" encoding="windows-1252"?>
>>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>>> 12:35:07">
>>>
>>>
>>> Using the File/New/Project wizard, I select EMF project, then select the
>>> UML importer. The UML importer dialog opens, lets me select the xmi
>>> file and press the load button. At this point, there are no obvious
>>> errors or warnings.
>>>
>>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>>> continue with the import process.
>>>
>>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>>> topics do not include anything about UML import.
>>>
>>> Am I doing something wrong?
>>>
>>>
>>> Michael
>>>
>>
>>
>
>
Re: Creating EMF project from xmi file [message #469823 is a reply to message #469821] Wed, 31 January 2007 23:10 Go to previous message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
Kenn,
This is the same model that I attached to the previous message, but I
exported it using a UML 2.1 option in EA, so my expectation is that it is
UML 2.1.

I posted the file to the bug report

Michael
Re: Creating EMF project from xmi file [message #578794 is a reply to message #469720] Wed, 31 January 2007 15:12 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Michael,

Open up the "Error Log" view... go to Window > Show View > PDE Runtime >
Error Log.
Can you see any errors or warnings in there. The importer might have
thrown some exception internally ...
If you can't see anything in the log, please post the file that is causing
you grief and I'll have a look.

Regards,

- James.


"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epocck$cmc$1@utils.eclipse.org...
> Configuration,
> Eclipse 3.2.1 Release
> UML 2.0.2 Release
>
>
> I am trying to create a new EMF project based on an xmi file that was
> exported by the Enterprise Architect UML modeling tool.
>
> I created the model with EA, then exported an xmi file. I guess (but not
> sure) the xmi is a UML2 model. Beginning of xmi contains:
> <?xml version="1.0" encoding="windows-1252"?>
> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
> 12:35:07">
>
>
> Using the File/New/Project wizard, I select EMF project, then select the
UML
> importer. The UML importer dialog opens, lets me select the xmi file and
> press the load button. At this point, there are no obvious errors or
> warnings.
>
> However, the NEXT and FINISH buttons are disabled, so I am not able to
> continue with the import process.
>
> I tried pressing F1 and/or clicking the ? in the dialog, but the help
topics
> do not include anything about UML import.
>
> Am I doing something wrong?
>
>
> Michael
>
>
Re: Creating EMF project from xmi file [message #578812 is a reply to message #469813] Wed, 31 January 2007 15:24 Go to previous message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
James,
There are no entries in Error Log, so here is the xmi. Thanks for offering
to look.

Michael

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:epqblh$7is$2@utils.eclipse.org...
> Hi Michael,
>
> Open up the "Error Log" view... go to Window > Show View > PDE Runtime >
> Error Log.
> Can you see any errors or warnings in there. The importer might have
> thrown some exception internally ...
> If you can't see anything in the log, please post the file that is causing
> you grief and I'll have a look.
>
> Regards,
>
> - James.
>
>
> "Michael Giroux" <michael.giroux@bull.com> wrote in message
> news:epocck$cmc$1@utils.eclipse.org...
>> Configuration,
>> Eclipse 3.2.1 Release
>> UML 2.0.2 Release
>>
>>
>> I am trying to create a new EMF project based on an xmi file that was
>> exported by the Enterprise Architect UML modeling tool.
>>
>> I created the model with EA, then exported an xmi file. I guess (but not
>> sure) the xmi is a UML2 model. Beginning of xmi contains:
>> <?xml version="1.0" encoding="windows-1252"?>
>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>> 12:35:07">
>>
>>
>> Using the File/New/Project wizard, I select EMF project, then select the
> UML
>> importer. The UML importer dialog opens, lets me select the xmi file and
>> press the load button. At this point, there are no obvious errors or
>> warnings.
>>
>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>> continue with the import process.
>>
>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
> topics
>> do not include anything about UML import.
>>
>> Am I doing something wrong?
>>
>>
>> Michael
>>
>>
>
>


Re: Creating EMF project from xmi file [message #578913 is a reply to message #469720] Wed, 31 January 2007 16:00 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Michael,

UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It would
be better if wizard notified you when an invalid input like this is
provided, so please open a Bugzilla report and we'll make the necessary
changes.

Kenn

"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epocck$cmc$1@utils.eclipse.org...
> Configuration,
> Eclipse 3.2.1 Release
> UML 2.0.2 Release
>
>
> I am trying to create a new EMF project based on an xmi file that was
> exported by the Enterprise Architect UML modeling tool.
>
> I created the model with EA, then exported an xmi file. I guess (but not
> sure) the xmi is a UML2 model. Beginning of xmi contains:
> <?xml version="1.0" encoding="windows-1252"?>
> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
> 12:35:07">
>
>
> Using the File/New/Project wizard, I select EMF project, then select the
> UML importer. The UML importer dialog opens, lets me select the xmi file
> and press the load button. At this point, there are no obvious errors or
> warnings.
>
> However, the NEXT and FINISH buttons are disabled, so I am not able to
> continue with the import process.
>
> I tried pressing F1 and/or clicking the ? in the dialog, but the help
> topics do not include anything about UML import.
>
> Am I doing something wrong?
>
>
> Michael
>
Re: Creating EMF project from xmi file [message #578932 is a reply to message #469817] Wed, 31 January 2007 16:11 Go to previous message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
BUG 172330.

Michael

"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:epqeek$msk$1@utils.eclipse.org...
> Michael,
>
> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
> would be better if wizard notified you when an invalid input like this is
> provided, so please open a Bugzilla report and we'll make the necessary
> changes.
>
> Kenn
>
> "Michael Giroux" <michael.giroux@bull.com> wrote in message
> news:epocck$cmc$1@utils.eclipse.org...
>> Configuration,
>> Eclipse 3.2.1 Release
>> UML 2.0.2 Release
>>
>>
>> I am trying to create a new EMF project based on an xmi file that was
>> exported by the Enterprise Architect UML modeling tool.
>>
>> I created the model with EA, then exported an xmi file. I guess (but not
>> sure) the xmi is a UML2 model. Beginning of xmi contains:
>> <?xml version="1.0" encoding="windows-1252"?>
>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>> 12:35:07">
>>
>>
>> Using the File/New/Project wizard, I select EMF project, then select the
>> UML importer. The UML importer dialog opens, lets me select the xmi file
>> and press the load button. At this point, there are no obvious errors or
>> warnings.
>>
>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>> continue with the import process.
>>
>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>> topics do not include anything about UML import.
>>
>> Am I doing something wrong?
>>
>>
>> Michael
>>
>
>
Re: Creating EMF project from xmi file [message #578968 is a reply to message #469818] Wed, 31 January 2007 17:44 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Thanks!

Kenn

"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epqf2k$thq$1@utils.eclipse.org...
> BUG 172330.
>
> Michael
>
> "Kenn Hussey" <khussey@ca.ibm.com> wrote in message
> news:epqeek$msk$1@utils.eclipse.org...
>> Michael,
>>
>> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
>> would be better if wizard notified you when an invalid input like this is
>> provided, so please open a Bugzilla report and we'll make the necessary
>> changes.
>>
>> Kenn
>>
>> "Michael Giroux" <michael.giroux@bull.com> wrote in message
>> news:epocck$cmc$1@utils.eclipse.org...
>>> Configuration,
>>> Eclipse 3.2.1 Release
>>> UML 2.0.2 Release
>>>
>>>
>>> I am trying to create a new EMF project based on an xmi file that was
>>> exported by the Enterprise Architect UML modeling tool.
>>>
>>> I created the model with EA, then exported an xmi file. I guess (but
>>> not sure) the xmi is a UML2 model. Beginning of xmi contains:
>>> <?xml version="1.0" encoding="windows-1252"?>
>>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>>> 12:35:07">
>>>
>>>
>>> Using the File/New/Project wizard, I select EMF project, then select the
>>> UML importer. The UML importer dialog opens, lets me select the xmi
>>> file and press the load button. At this point, there are no obvious
>>> errors or warnings.
>>>
>>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>>> continue with the import process.
>>>
>>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>>> topics do not include anything about UML import.
>>>
>>> Am I doing something wrong?
>>>
>>>
>>> Michael
>>>
>>
>>
>
>
Re: Creating EMF project from xmi file [message #578992 is a reply to message #469817] Wed, 31 January 2007 18:38 Go to previous message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
Kenn,

I exported the xmi file using UML 2.1 format. This resulted in an error
being generated when the UML importer tried to load the file:
The dialog has "Load Problem" in the title with a message of "The class
'Type' is not a valid classifier".

This may reflect an error in the model I'm trying to import.

If you can comment I will appreciate.

Thanks
Michael



"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:epqeek$msk$1@utils.eclipse.org...
> Michael,
>
> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
> would be better if wizard notified you when an invalid input like this is
> provided, so please open a Bugzilla report and we'll make the necessary
> changes.
>
> Kenn
>
> "Michael Giroux" <michael.giroux@bull.com> wrote in message
> news:epocck$cmc$1@utils.eclipse.org...
>> Configuration,
>> Eclipse 3.2.1 Release
>> UML 2.0.2 Release
>>
>>
>> I am trying to create a new EMF project based on an xmi file that was
>> exported by the Enterprise Architect UML modeling tool.
>>
>> I created the model with EA, then exported an xmi file. I guess (but not
>> sure) the xmi is a UML2 model. Beginning of xmi contains:
>> <?xml version="1.0" encoding="windows-1252"?>
>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>> 12:35:07">
>>
>>
>> Using the File/New/Project wizard, I select EMF project, then select the
>> UML importer. The UML importer dialog opens, lets me select the xmi file
>> and press the load button. At this point, there are no obvious errors or
>> warnings.
>>
>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>> continue with the import process.
>>
>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>> topics do not include anything about UML import.
>>
>> Am I doing something wrong?
>>
>>
>> Michael
>>
>
>
Re: Creating EMF project from xmi file [message #579029 is a reply to message #469820] Wed, 31 January 2007 20:36 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Michael,

Are you talking about a different model this time? The one you showed a
snippet from appeared to be UML 1.3, XMI 1.1.

If you can post a sample XMI file that demonstrates the problem, we'll look
into it.

Kenn

"Michael Giroux" <michael.giroux@bull.com> wrote in message
news:epqnn5$up8$1@utils.eclipse.org...
> Kenn,
>
> I exported the xmi file using UML 2.1 format. This resulted in an error
> being generated when the UML importer tried to load the file:
> The dialog has "Load Problem" in the title with a message of "The class
> 'Type' is not a valid classifier".
>
> This may reflect an error in the model I'm trying to import.
>
> If you can comment I will appreciate.
>
> Thanks
> Michael
>
>
>
> "Kenn Hussey" <khussey@ca.ibm.com> wrote in message
> news:epqeek$msk$1@utils.eclipse.org...
>> Michael,
>>
>> UML2 only supports import of UML 2.1 models serialized in XMI 2.1. It
>> would be better if wizard notified you when an invalid input like this is
>> provided, so please open a Bugzilla report and we'll make the necessary
>> changes.
>>
>> Kenn
>>
>> "Michael Giroux" <michael.giroux@bull.com> wrote in message
>> news:epocck$cmc$1@utils.eclipse.org...
>>> Configuration,
>>> Eclipse 3.2.1 Release
>>> UML 2.0.2 Release
>>>
>>>
>>> I am trying to create a new EMF project based on an xmi file that was
>>> exported by the Enterprise Architect UML modeling tool.
>>>
>>> I created the model with EA, then exported an xmi file. I guess (but
>>> not sure) the xmi is a UML2 model. Beginning of xmi contains:
>>> <?xml version="1.0" encoding="windows-1252"?>
>>> <!DOCTYPE XMI SYSTEM "UML_EA.dtd">
>>> <XMI xmi.version="1.1" xmlns:UML="omg.org/UML1.3" timestamp="2007-01-29
>>> 12:35:07">
>>>
>>>
>>> Using the File/New/Project wizard, I select EMF project, then select the
>>> UML importer. The UML importer dialog opens, lets me select the xmi
>>> file and press the load button. At this point, there are no obvious
>>> errors or warnings.
>>>
>>> However, the NEXT and FINISH buttons are disabled, so I am not able to
>>> continue with the import process.
>>>
>>> I tried pressing F1 and/or clicking the ? in the dialog, but the help
>>> topics do not include anything about UML import.
>>>
>>> Am I doing something wrong?
>>>
>>>
>>> Michael
>>>
>>
>>
>
>
Re: Creating EMF project from xmi file [message #579077 is a reply to message #469821] Wed, 31 January 2007 23:10 Go to previous message
Michael Giroux is currently offline Michael GirouxFriend
Messages: 287
Registered: July 2009
Senior Member
Kenn,
This is the same model that I attached to the previous message, but I
exported it using a UML 2.1 option in EA, so my expectation is that it is
UML 2.1.

I posted the file to the bug report

Michael
Previous Topic:Can't get the graphical features of UML to work
Next Topic:Custom class [1..*] stereotype attribute saved as foo="/-1"
Goto Forum:
  


Current Time: Fri Apr 10 10:34:20 GMT 2020

Powered by FUDForum. Page generated in 0.03008 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top