Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Current available CVS for Papyrus
Current available CVS for Papyrus [message #468973] Wed, 29 October 2008 09:03 Go to next message
Sebastien Gerard is currently offline Sebastien GerardFriend
Messages: 121
Registered: July 2009
Senior Member
Hi,

the Papyrus team is currently working very hard to produce the first bundle
of code for Papyrus. We should be able to deliver this bundle to the Eclipse
IP review process early November, this year of course ;-)

For whose who are very impatiant to have a look, please look at here:
https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/

And do not hesitate to send us bugs/bug fiixes and other new features if you
want.

Regards,

--S
Re: Current available CVS for Papyrus [message #468991 is a reply to message #468973] Fri, 31 October 2008 17:35 Go to previous messageGo to next message
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,

Thanks for the link.

Can you please clarify what is the configuration (branch, head) of
Eclipse against which you develop papyrus?


-- Nicolas.

Sébastien Gérard wrote:
> Hi,
>
> the Papyrus team is currently working very hard to produce the first bundle
> of code for Papyrus. We should be able to deliver this bundle to the Eclipse
> IP review process early November, this year of course ;-)
>
> For whose who are very impatiant to have a look, please look at here:
> https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/
>
> And do not hesitate to send us bugs/bug fiixes and other new features if you
> want.
>
> Regards,
>
> --Séb.
>
>
Re: Current available CVS for Papyrus [message #468994 is a reply to message #468991] Fri, 31 October 2008 20:48 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
I believe it's being done against Ganymede at this point...

Kenn

"Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
news:geffi3$cg4$1@build.eclipse.org...
> Hi,
>
> Thanks for the link.
>
> Can you please clarify what is the configuration (branch, head) of Eclipse
> against which you develop papyrus?
>
>
> -- Nicolas.
>
> S
Re: Current available CVS for Papyrus [message #468996 is a reply to message #468994] Sat, 01 November 2008 05:25 Go to previous messageGo to next message
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
Indeed, that's what it looks like which might be a bit of a problem
because support for the UML 2.2 API would require the UML 3.0 component
which has been built against EMF 2.5 which in turn requires Eclipse 3.5.

So, is the papyrus component really committed to the UML 2.1.2 metamodel
without any reasonable option to use the UML 2.2 metamodel?

For me, the distinction matters because the Executable UML metamodel is
aligned to UML 2.2 instead of UML 2.1.2

-- Nicolas.

Kenn Hussey wrote:
> I believe it's being done against Ganymede at this point...
>
> Kenn
>
> "Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
> news:geffi3$cg4$1@build.eclipse.org...
>> Hi,
>>
>> Thanks for the link.
>>
>> Can you please clarify what is the configuration (branch, head) of Eclipse
>> against which you develop papyrus?
>>
>>
>> -- Nicolas.
>>
>> Sébastien Gérard wrote:
>>> Hi,
>>>
>>> the Papyrus team is currently working very hard to produce the first
>>> bundle of code for Papyrus. We should be able to deliver this bundle to
>>> the Eclipse IP review process early November, this year of course ;-)
>>>
>>> For whose who are very impatiant to have a look, please look at here:
>>> https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/
>>>
>>> And do not hesitate to send us bugs/bug fiixes and other new features if
>>> you want.
>>>
>>> Regards,
>>>
>>> --Séb.
>
>
Building papyrus. [message #468999 is a reply to message #468994] Sat, 01 November 2008 19:59 Go to previous messageGo to next message
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
Could someone post instructions for building the papyrus component?

-- Nicolas.
Re: Current available CVS for Papyrus [message #469002 is a reply to message #468996] Mon, 03 November 2008 17:16 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Nicolas,

I'm sure the Papyrus team will retarget the code for Galileo once the
initial contribution is made and the code is in CVS...

Kenn

"Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
news:490BE860.8020500@jpl.nasa.gov...
> Indeed, that's what it looks like which might be a bit of a problem
> because support for the UML 2.2 API would require the UML 3.0 component
> which has been built against EMF 2.5 which in turn requires Eclipse 3.5.
>
> So, is the papyrus component really committed to the UML 2.1.2 metamodel
> without any reasonable option to use the UML 2.2 metamodel?
>
> For me, the distinction matters because the Executable UML metamodel is
> aligned to UML 2.2 instead of UML 2.1.2
>
> -- Nicolas.
>
> Kenn Hussey wrote:
>> I believe it's being done against Ganymede at this point...
>>
>> Kenn
>>
>> "Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
>> news:geffi3$cg4$1@build.eclipse.org...
>>> Hi,
>>>
>>> Thanks for the link.
>>>
>>> Can you please clarify what is the configuration (branch, head) of
>>> Eclipse against which you develop papyrus?
>>>
>>>
>>> -- Nicolas.
>>>
>>> S
Re: Building papyrus. [message #469004 is a reply to message #468999] Wed, 05 November 2008 11:56 Go to previous messageGo to next message
Sebastien Gerard is currently offline Sebastien GerardFriend
Messages: 121
Registered: July 2009
Senior Member
Bonjour Nicolas,

yes, we are going to do that. R
Re: Building papyrus. [message #469005 is a reply to message #469004] Wed, 12 November 2008 14:32 Go to previous messageGo to next message
Jerome BENOIS is currently offline Jerome BENOISFriend
Messages: 6
Registered: July 2009
Junior Member
Hi Nicolas,

Sorry for the delay. We can found a Papyrus build on the Obeo site. We
have published two Update site:

* The first site contains all plugins selected for the IPZilla (Papyrus
Core and the GMF diagrams : EMFTree, Class, Activity, Sequence and
UseCase diagrams)
- it required this :
- Eclipse Ganymede
- EMF Runtime and Tools 2.4.1
- GMF Runtime 1.1.2
- UML2 End Users 2.2.1
- OCL 2.0 End Users 1.2.2
- EMF Model Query Runtime 1.2.0
- This Update-Site is here :
http://www.obeo.fr/download/papyrus/incubation


* The second site contains all plugins in development/experimentation
(all IPZIlla plugins and several integration plugins kind like Papyrus I
diagrams, UMl2tools clazz diagram integration, Java reverse ...)
- it required additionnal plugins :
- EMFT EcoreTools Runtime 0.8.0
- MDT UML2Tools Runtime 0.8.1
- This Update-Site is here :
http://www.obeo.fr/download/papyrus/all

Regards,
Jérôme.
--
Obeo, Model Driven Company
--
"Code is a model, Show me the model!"
http://www.benois.fr

Le mercredi 05 novembre 2008 à 12:56 +0100, S?bastien G?rard a écrit :
> Bonjour Nicolas,
>
> yes, we are going to do that. Rmi and Jerome are going to setup an update
> site that will enable you to download Papyrus in your eclipse. They will
> provide you that facilities at last for tomorrow. They will post the
> information as soon it is ready.
>
> Cheers,
> Sbastien.
>
> "Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> a crit dans le message
> de news: geicb5$v5f$1@build.eclipse.org...
> > Could someone post instructions for building the papyrus component?
> >
> > -- Nicolas.
Re: Building papyrus. [message #469246 is a reply to message #469005] Thu, 22 January 2009 17:32 Go to previous messageGo to next message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Jerome BENOIS wrote:

> Sorry for the delay. We can found a Papyrus build on the Obeo site. We
> have published two Update site:
....
> - This Update-Site is here :
> http://www.obeo.fr/download/papyrus/incubation

How does the version (0.7.0 currently) on this commercial site relate to
the version on the papyrusuml.org site (1.11.0 currently)?

Which is later and/or preferred?

Tom
Re: Building papyrus. [message #469250 is a reply to message #468999] Thu, 22 January 2009 17:49 Go to previous messageGo to next message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Nicolas Rouquette asked:

> Could someone post instructions for building the papyrus component?

To which Jerome Benois replied with instructions on how to install a
pre-built Papyrus from his company's web site.

Does anyone have an answer to the original question? (How to build Papyrus)

It looks like the sources moved from

https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/

to

https://speedy.supelec.fr/Papyrus/svn/Papyrus/eclipse/

which has the following subdirectories:

core - 12 plugins
other - 21
other - 8
uml - 12

but some of them don't even compile and others seem to be partly using
org.eclipse.papyrus and partly com.cea.papyrus for names.

One thing you definitely need to do is install the ANTLR runtime from
Orbit (the ATL wiki has good directions
http://wiki.eclipse.org/ATL/User_Guide#ANTLR_installation), but a
complete set of instructions, even if very brief, would be very useful.

More recently I saw a note saying the the sources were moving to
svn+ssh://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.p apyrus
but it doesn't look like http access is enabled for that repository
making it impossible for those without accounts on eclipse.org to access
(unless I'm missing something).

Can someone post the correct SVN url and a .psf file or a couple of
sentences worth of instructions?

Tom
Re: Building papyrus. [message #469253 is a reply to message #469246] Thu, 22 January 2009 22:36 Go to previous messageGo to next message
Sebastien Gerard is currently offline Sebastien GerardFriend
Messages: 121
Registered: July 2009
Senior Member
Version 1.11.0 available on the www.papyrusuml.org website is the original
version of Papyrus and the most advanced current version of the tool. But
this version is relying on pure GEF and on EMF.

The new version of Papyrus (resulting from the merging of two other existing
UML modeler, one of the TopCASED project and on eof the oskitt project) has
been acceptedd as an eclipse project under the umbrella of MDT. In this
context, being in its incubation phace is numbering as to be 0.x.y.
Finally, as we only go through the ipzilla process of Eclipse, we had not
the eclipse svn service, so we used our previous svn service but it was
notpossible there to propose rcp. For that resaon, there were momentally
available on the obeo web site whoch one of the participants of the project.
Now, we have the svn provided from Eclipse and other facilities, so
everything sould be available soon in a transparent manner on the
www.eclipse.org/mdt web site uder the Papyrus component.

S
Re: Building papyrus. [message #469261 is a reply to message #469253] Mon, 26 January 2009 19:34 Go to previous messageGo to next message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Thanks for the reply Sébastien. So, to summarize on the status of the
kits, 0.7.0 is later than 1.11.0, but has a lower number because of
Eclipse numbering rules. However, 1.11.0, although older, is currently
still the preferred version because it is more capable.

Any feedback on what SVN URL we should be using to build from source?
I looked on the MDT web site and checked the wiki, but didn't see
anything relevant.

Tom

Sébastien Gérard wrote:
> Version 1.11.0 available on the www.papyrusuml.org website is the original
> version of Papyrus and the most advanced current version of the tool. But
> this version is relying on pure GEF and on EMF.
>
> The new version of Papyrus (resulting from the merging of two other existing
> UML modeler, one of the TopCASED project and on eof the oskitt project) has
> been acceptedd as an eclipse project under the umbrella of MDT. In this
> context, being in its incubation phace is numbering as to be 0.x.y.
> Finally, as we only go through the ipzilla process of Eclipse, we had not
> the eclipse svn service, so we used our previous svn service but it was
> notpossible there to propose rcp. For that resaon, there were momentally
> available on the obeo web site whoch one of the participants of the project.
> Now, we have the svn provided from Eclipse and other facilities, so
> everything sould be available soon in a transparent manner on the
> www.eclipse.org/mdt web site uder the Papyrus component.
>
> Sébastien.
>
>
> "Tom Morris" <tfmorris@gmail.com> a écrit dans le message de news:
> glaaj2$9c2$1@build.eclipse.org...
>> Jerome BENOIS wrote:
>>
>>> Sorry for the delay. We can found a Papyrus build on the Obeo site. We
>>> have published two Update site:
>> ...
>>> - This Update-Site is here :
>>> http://www.obeo.fr/download/papyrus/incubation
>> How does the version (0.7.0 currently) on this commercial site relate to
>> the version on the papyrusuml.org site (1.11.0 currently)?
>>
>> Which is later and/or preferred?
>>
>> Tom
>
>
Re: Building papyrus. [message #469327 is a reply to message #469250] Mon, 09 February 2009 16:27 Go to previous message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Tom Morris wrote:
> Nicolas Rouquette asked:
>
>> Could someone post instructions for building the papyrus component?
>
> To which Jerome Benois replied with instructions on how to install a
> pre-built Papyrus from his company's web site.
[...]
> More recently I saw a note saying the the sources were moving to
> svn+ssh://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.p apyrus
> but it doesn't look like http access is enabled for that repository
> making it impossible for those without accounts on eclipse.org to access
> (unless I'm missing something).
>
> Can someone post the correct SVN url and a .psf file or a couple of
> sentences worth of instructions?

Since no one would reply here, I sent email directly to the Eclipse
webmaster.

HTTP access is now enabled and the sources can be accessed at
http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papy rus.

I also had Papyrus added to the ViewCVS config to make it easier to find
from the web site.

I hope this keeps the next person from having to waste as much time as I
did. I'll post build directions separately.

Tom
Re: Current available CVS for Papyrus [message #573034 is a reply to message #468973] Fri, 31 October 2008 17:35 Go to previous message
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,

Thanks for the link.

Can you please clarify what is the configuration (branch, head) of
Eclipse against which you develop papyrus?


-- Nicolas.

Sébastien Gérard wrote:
> Hi,
>
> the Papyrus team is currently working very hard to produce the first bundle
> of code for Papyrus. We should be able to deliver this bundle to the Eclipse
> IP review process early November, this year of course ;-)
>
> For whose who are very impatiant to have a look, please look at here:
> https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/
>
> And do not hesitate to send us bugs/bug fiixes and other new features if you
> want.
>
> Regards,
>
> --Séb.
>
>
Re: Current available CVS for Papyrus [message #573095 is a reply to message #468991] Fri, 31 October 2008 20:48 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
I believe it's being done against Ganymede at this point...

Kenn

"Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
news:geffi3$cg4$1@build.eclipse.org...
> Hi,
>
> Thanks for the link.
>
> Can you please clarify what is the configuration (branch, head) of Eclipse
> against which you develop papyrus?
>
>
> -- Nicolas.
>
> S
Re: Current available CVS for Papyrus [message #573122 is a reply to message #468994] Sat, 01 November 2008 05:25 Go to previous message
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
Indeed, that's what it looks like which might be a bit of a problem
because support for the UML 2.2 API would require the UML 3.0 component
which has been built against EMF 2.5 which in turn requires Eclipse 3.5.

So, is the papyrus component really committed to the UML 2.1.2 metamodel
without any reasonable option to use the UML 2.2 metamodel?

For me, the distinction matters because the Executable UML metamodel is
aligned to UML 2.2 instead of UML 2.1.2

-- Nicolas.

Kenn Hussey wrote:
> I believe it's being done against Ganymede at this point...
>
> Kenn
>
> "Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
> news:geffi3$cg4$1@build.eclipse.org...
>> Hi,
>>
>> Thanks for the link.
>>
>> Can you please clarify what is the configuration (branch, head) of Eclipse
>> against which you develop papyrus?
>>
>>
>> -- Nicolas.
>>
>> Sébastien Gérard wrote:
>>> Hi,
>>>
>>> the Papyrus team is currently working very hard to produce the first
>>> bundle of code for Papyrus. We should be able to deliver this bundle to
>>> the Eclipse IP review process early November, this year of course ;-)
>>>
>>> For whose who are very impatiant to have a look, please look at here:
>>> https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/
>>>
>>> And do not hesitate to send us bugs/bug fiixes and other new features if
>>> you want.
>>>
>>> Regards,
>>>
>>> --Séb.
>
>
Building papyrus. [message #573140 is a reply to message #468994] Sat, 01 November 2008 19:59 Go to previous message
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
Could someone post instructions for building the papyrus component?

-- Nicolas.
Re: Current available CVS for Papyrus [message #573185 is a reply to message #468996] Mon, 03 November 2008 17:16 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Nicolas,

I'm sure the Papyrus team will retarget the code for Galileo once the
initial contribution is made and the code is in CVS...

Kenn

"Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
news:490BE860.8020500@jpl.nasa.gov...
> Indeed, that's what it looks like which might be a bit of a problem
> because support for the UML 2.2 API would require the UML 3.0 component
> which has been built against EMF 2.5 which in turn requires Eclipse 3.5.
>
> So, is the papyrus component really committed to the UML 2.1.2 metamodel
> without any reasonable option to use the UML 2.2 metamodel?
>
> For me, the distinction matters because the Executable UML metamodel is
> aligned to UML 2.2 instead of UML 2.1.2
>
> -- Nicolas.
>
> Kenn Hussey wrote:
>> I believe it's being done against Ganymede at this point...
>>
>> Kenn
>>
>> "Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> wrote in message
>> news:geffi3$cg4$1@build.eclipse.org...
>>> Hi,
>>>
>>> Thanks for the link.
>>>
>>> Can you please clarify what is the configuration (branch, head) of
>>> Eclipse against which you develop papyrus?
>>>
>>>
>>> -- Nicolas.
>>>
>>> S
Re: Building papyrus. [message #573209 is a reply to message #468999] Wed, 05 November 2008 11:56 Go to previous message
Sebastien Gerard is currently offline Sebastien GerardFriend
Messages: 121
Registered: July 2009
Senior Member
Bonjour Nicolas,

yes, we are going to do that. R
Re: Building papyrus. [message #573229 is a reply to message #469004] Wed, 12 November 2008 14:32 Go to previous message
Jerome BENOIS is currently offline Jerome BENOISFriend
Messages: 6
Registered: July 2009
Junior Member
Hi Nicolas,

Sorry for the delay. We can found a Papyrus build on the Obeo site. We
have published two Update site:

* The first site contains all plugins selected for the IPZilla (Papyrus
Core and the GMF diagrams : EMFTree, Class, Activity, Sequence and
UseCase diagrams)
- it required this :
- Eclipse Ganymede
- EMF Runtime and Tools 2.4.1
- GMF Runtime 1.1.2
- UML2 End Users 2.2.1
- OCL 2.0 End Users 1.2.2
- EMF Model Query Runtime 1.2.0
- This Update-Site is here :
http://www.obeo.fr/download/papyrus/incubation


* The second site contains all plugins in development/experimentation
(all IPZIlla plugins and several integration plugins kind like Papyrus I
diagrams, UMl2tools clazz diagram integration, Java reverse ...)
- it required additionnal plugins :
- EMFT EcoreTools Runtime 0.8.0
- MDT UML2Tools Runtime 0.8.1
- This Update-Site is here :
http://www.obeo.fr/download/papyrus/all

Regards,
Jérôme.
--
Obeo, Model Driven Company
--
"Code is a model, Show me the model!"
http://www.benois.fr

Le mercredi 05 novembre 2008 à 12:56 +0100, S?bastien G?rard a écrit :
> Bonjour Nicolas,
>
> yes, we are going to do that. Rmi and Jerome are going to setup an update
> site that will enable you to download Papyrus in your eclipse. They will
> provide you that facilities at last for tomorrow. They will post the
> information as soon it is ready.
>
> Cheers,
> Sbastien.
>
> "Nicolas Rouquette" <nicolas.rouquette@jpl.nasa.gov> a crit dans le message
> de news: geicb5$v5f$1@build.eclipse.org...
> > Could someone post instructions for building the papyrus component?
> >
> > -- Nicolas.
Re: Building papyrus. [message #581477 is a reply to message #469005] Thu, 22 January 2009 17:32 Go to previous message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Jerome BENOIS wrote:

> Sorry for the delay. We can found a Papyrus build on the Obeo site. We
> have published two Update site:
....
> - This Update-Site is here :
> http://www.obeo.fr/download/papyrus/incubation

How does the version (0.7.0 currently) on this commercial site relate to
the version on the papyrusuml.org site (1.11.0 currently)?

Which is later and/or preferred?

Tom
Re: Building papyrus. [message #581487 is a reply to message #468999] Thu, 22 January 2009 17:49 Go to previous message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Nicolas Rouquette asked:

> Could someone post instructions for building the papyrus component?

To which Jerome Benois replied with instructions on how to install a
pre-built Papyrus from his company's web site.

Does anyone have an answer to the original question? (How to build Papyrus)

It looks like the sources moved from

https://speedy.supelec.fr/Papyrus/svn/Papyrus/core/experimen t/papyrus-gmf/

to

https://speedy.supelec.fr/Papyrus/svn/Papyrus/eclipse/

which has the following subdirectories:

core - 12 plugins
other - 21
other - 8
uml - 12

but some of them don't even compile and others seem to be partly using
org.eclipse.papyrus and partly com.cea.papyrus for names.

One thing you definitely need to do is install the ANTLR runtime from
Orbit (the ATL wiki has good directions
http://wiki.eclipse.org/ATL/User_Guide#ANTLR_installation), but a
complete set of instructions, even if very brief, would be very useful.

More recently I saw a note saying the the sources were moving to
svn+ssh://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.p apyrus
but it doesn't look like http access is enabled for that repository
making it impossible for those without accounts on eclipse.org to access
(unless I'm missing something).

Can someone post the correct SVN url and a .psf file or a couple of
sentences worth of instructions?

Tom
Re: Building papyrus. [message #581493 is a reply to message #469246] Thu, 22 January 2009 22:36 Go to previous message
Sebastien Gerard is currently offline Sebastien GerardFriend
Messages: 121
Registered: July 2009
Senior Member
Version 1.11.0 available on the www.papyrusuml.org website is the original
version of Papyrus and the most advanced current version of the tool. But
this version is relying on pure GEF and on EMF.

The new version of Papyrus (resulting from the merging of two other existing
UML modeler, one of the TopCASED project and on eof the oskitt project) has
been acceptedd as an eclipse project under the umbrella of MDT. In this
context, being in its incubation phace is numbering as to be 0.x.y.
Finally, as we only go through the ipzilla process of Eclipse, we had not
the eclipse svn service, so we used our previous svn service but it was
notpossible there to propose rcp. For that resaon, there were momentally
available on the obeo web site whoch one of the participants of the project.
Now, we have the svn provided from Eclipse and other facilities, so
everything sould be available soon in a transparent manner on the
www.eclipse.org/mdt web site uder the Papyrus component.

S
Re: Building papyrus. [message #581503 is a reply to message #469253] Mon, 26 January 2009 19:34 Go to previous message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Thanks for the reply Sébastien. So, to summarize on the status of the
kits, 0.7.0 is later than 1.11.0, but has a lower number because of
Eclipse numbering rules. However, 1.11.0, although older, is currently
still the preferred version because it is more capable.

Any feedback on what SVN URL we should be using to build from source?
I looked on the MDT web site and checked the wiki, but didn't see
anything relevant.

Tom

Sébastien Gérard wrote:
> Version 1.11.0 available on the www.papyrusuml.org website is the original
> version of Papyrus and the most advanced current version of the tool. But
> this version is relying on pure GEF and on EMF.
>
> The new version of Papyrus (resulting from the merging of two other existing
> UML modeler, one of the TopCASED project and on eof the oskitt project) has
> been acceptedd as an eclipse project under the umbrella of MDT. In this
> context, being in its incubation phace is numbering as to be 0.x.y.
> Finally, as we only go through the ipzilla process of Eclipse, we had not
> the eclipse svn service, so we used our previous svn service but it was
> notpossible there to propose rcp. For that resaon, there were momentally
> available on the obeo web site whoch one of the participants of the project.
> Now, we have the svn provided from Eclipse and other facilities, so
> everything sould be available soon in a transparent manner on the
> www.eclipse.org/mdt web site uder the Papyrus component.
>
> Sébastien.
>
>
> "Tom Morris" <tfmorris@gmail.com> a écrit dans le message de news:
> glaaj2$9c2$1@build.eclipse.org...
>> Jerome BENOIS wrote:
>>
>>> Sorry for the delay. We can found a Papyrus build on the Obeo site. We
>>> have published two Update site:
>> ...
>>> - This Update-Site is here :
>>> http://www.obeo.fr/download/papyrus/incubation
>> How does the version (0.7.0 currently) on this commercial site relate to
>> the version on the papyrusuml.org site (1.11.0 currently)?
>>
>> Which is later and/or preferred?
>>
>> Tom
>
>
Re: Building papyrus. [message #581685 is a reply to message #469250] Mon, 09 February 2009 16:27 Go to previous message
Tom Morris is currently offline Tom MorrisFriend
Messages: 89
Registered: July 2009
Member
Tom Morris wrote:
> Nicolas Rouquette asked:
>
>> Could someone post instructions for building the papyrus component?
>
> To which Jerome Benois replied with instructions on how to install a
> pre-built Papyrus from his company's web site.
[...]
> More recently I saw a note saying the the sources were moving to
> svn+ssh://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.p apyrus
> but it doesn't look like http access is enabled for that repository
> making it impossible for those without accounts on eclipse.org to access
> (unless I'm missing something).
>
> Can someone post the correct SVN url and a .psf file or a couple of
> sentences worth of instructions?

Since no one would reply here, I sent email directly to the Eclipse
webmaster.

HTTP access is now enabled and the sources can be accessed at
http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papy rus

I also had Papyrus added to the ViewCVS config to make it easier to find
from the web site.

I hope this keeps the next person from having to waste as much time as I
did. I'll post build directions separately.

Tom
Previous Topic:Problem with the use case diagram
Next Topic:Project set file for SVN checkout
Goto Forum:
  


Current Time: Tue Aug 11 19:49:50 GMT 2020

Powered by FUDForum. Page generated in 0.04037 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top