Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » How to achieve HTTP Post using Ole Automation in SWT
How to achieve HTTP Post using Ole Automation in SWT [message #464914] Thu, 01 December 2005 07:07 Go to next message
Sun  is currently offline Sun Friend
Messages: 20
Registered: July 2009
Junior Member
Hi,
I am using OleAutomation to do an HTTP Post in SWT. I am able to do an
HTTP Get on a URL. However I am not able to do an HTTP POST. I have gone
through the forums and the newsgroup however there is no topic that
addresses HTTP Post.
I am not able to figure out how to pass the parameters. Could anyone
please help.

The url I am trying is http://www.someurl.com and I need to pass the
paramters
param1=123&param2=abc&param3=dc
Re: How to achieve HTTP Post using Ole Automation in SWT [message #464935 is a reply to message #464914] Thu, 01 December 2005 15:44 Go to previous messageGo to next message
Veronika Irvine is currently offline Veronika IrvineFriend
Messages: 1272
Registered: July 2009
Senior Member
See:
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.swt.sni ppets/src/org/eclipse/swt/snippets/Snippet186.java?rev=HEAD& amp;content-type=text/vnd.viewcvs-markup

"Sun" <sohoni008@yahoo.com> wrote in message
news:50936a50b897cabf28dce3bcc401327b$1@www.eclipse.org...
> Hi,
> I am using OleAutomation to do an HTTP Post in SWT. I am able to do an
> HTTP Get on a URL. However I am not able to do an HTTP POST. I have gone
> through the forums and the newsgroup however there is no topic that
> addresses HTTP Post.
> I am not able to figure out how to pass the parameters. Could anyone
> please help.
>
> The url I am trying is http://www.someurl.com and I need to pass the
> paramters param1=123&param2=abc&param3=dc
>
Re: How to achieve HTTP Post using Ole Automation in SWT [message #464960 is a reply to message #464935] Fri, 02 December 2005 07:49 Go to previous messageGo to next message
Sun  is currently offline Sun Friend
Messages: 20
Registered: July 2009
Junior Member
Hi Veronika,
I have gone through the example snippet, however I am not able to figure
out how to pass multiple parameters in the post. My requirement is to
navigate to the website address www.someurl.com and post the paramters
param1=ab&param2=cd&param3=12
Could you please kindly help.
Thanks,
Sun
Re: How to achieve HTTP Post using Ole Automation in SWT [message #465013 is a reply to message #464960] Fri, 02 December 2005 17:25 Go to previous messageGo to next message
Veronika Irvine is currently offline Veronika IrvineFriend
Messages: 1272
Registered: July 2009
Senior Member
Have you tried

rgvarg[1] = writeSafeArray("param1=ab&param2=cd&param3=12");

"Sun" <sohoni008@yahoo.com> wrote in message
news:c4330718d51bcea7e14a5374096dbeaf$1@www.eclipse.org...
> Hi Veronika,
> I have gone through the example snippet, however I am not able to figure
> out how to pass multiple parameters in the post. My requirement is to
> navigate to the website address www.someurl.com and post the paramters
> param1=ab&param2=cd&param3=12
> Could you please kindly help.
> Thanks,
> Sun
>
Re: How to achieve HTTP Post using Ole Automation in SWT [message #465071 is a reply to message #465013] Mon, 05 December 2005 13:26 Go to previous message
Sun  is currently offline Sun Friend
Messages: 20
Registered: July 2009
Junior Member
Hi Veronika,
I tried with the method writeSafeArray("param1=ab&param2=12&param3=cd");
however it is not giving me any result.
Could you please kindly help.
Thanks,
Suneet
Previous Topic:libflashplayer inside browser component
Next Topic:Centering a Dialog on Screen
Goto Forum:
  


Current Time: Wed Dec 11 06:07:07 GMT 2019

Powered by FUDForum. Page generated in 0.02094 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top