Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » TableItem.setImage() does not redraw
TableItem.setImage() does not redraw [message #461719] Wed, 28 September 2005 11:51 Go to next message
Peter Kullmann is currently offline Peter KullmannFriend
Messages: 240
Registered: July 2009
Senior Member
I'm having problems with a table when setting an image to null in a
column other than the first: TableItem.setImage(column, null) does not
update the screen area properly. Only after hiding the window behind
another one and the revealing it again does the image disappear.

I have opened a bug report in bugzilla:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=110923 A snippet
illustrating the problem is also there.

I'd be greatful for any ideas for a workaround.

Peter
Re: TableItem.setImage() does not redraw [message #461721 is a reply to message #461719] Wed, 28 September 2005 13:25 Go to previous messageGo to next message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2150
Registered: July 2009
Senior Member
The easiest workaround for drawing problems like this is to add a
Table.redraw() after you have set the images to null.

Grant

"Peter Kullmann" <p.kullmann@arenae.ch> wrote in message
news:dhe04v$qqj$1@news.eclipse.org...
> I'm having problems with a table when setting an image to null in a
> column other than the first: TableItem.setImage(column, null) does not
> update the screen area properly. Only after hiding the window behind
> another one and the revealing it again does the image disappear.
>
> I have opened a bug report in bugzilla:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=110923 A snippet
> illustrating the problem is also there.
>
> I'd be greatful for any ideas for a workaround.
>
> Peter
Re: TableItem.setImage() does not redraw [message #462014 is a reply to message #461719] Wed, 05 October 2005 01:39 Go to previous message
Steve Northover is currently offline Steve NorthoverFriend
Messages: 1636
Registered: July 2009
Senior Member
Fixed > 20051004

"Peter Kullmann" <p.kullmann@arenae.ch> wrote in message
news:dhe04v$qqj$1@news.eclipse.org...
> I'm having problems with a table when setting an image to null in a
> column other than the first: TableItem.setImage(column, null) does not
> update the screen area properly. Only after hiding the window behind
> another one and the revealing it again does the image disappear.
>
> I have opened a bug report in bugzilla:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=110923 A snippet
> illustrating the problem is also there.
>
> I'd be greatful for any ideas for a workaround.
>
> Peter
Previous Topic:Can I use TabFolder widget on IBM J9 ?
Next Topic:Two types of Menus?
Goto Forum:
  


Current Time: Tue Sep 29 08:15:53 GMT 2020

Powered by FUDForum. Page generated in 0.02119 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top