Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » java and swt libs compatibility
java and swt libs compatibility [message #460514] Tue, 30 August 2005 16:52 Go to next message
Andreas Niemeyer is currently offline Andreas NiemeyerFriend
Messages: 40
Registered: July 2009
Member
Hi all,

I'm looking for a list, which swt version requires which java version, e.g.

swt 3.01(3064) -> 1.4.2_03
swt 3.1(3138) -> 1.4.2_06

to define a minimum and acceptable jre version/subversions for a swt
application.

For instance, one of our customers used hardware/software combination is
a HP c8000 workstation with HP-UX 11.11 and a installed Java 1.4.2_00 .

For this env we have problems to launch an SWT application with swt libs
like 3064 or above and I guess there is a version conflict which force
us to use a newer java version or to downgrade the used swt libs.

The application starts first, a user is able to login about a shell
dialog box and then, nothing happens - the main app window doesn't
appear, a process is just running - the app hangs; no idea to find out
what's going wrong.

Exists there a debug capability to pin down those kinds of problems?

If we try it with an own jre 1.4.2_03, the app starts without problems.


Many thanks for some suggestions!

Regards,
ANdreas
Re: java and swt libs compatibility [message #460517 is a reply to message #460514] Tue, 30 August 2005 18:30 Go to previous messageGo to next message
Andreas Niemeyer is currently offline Andreas NiemeyerFriend
Messages: 40
Registered: July 2009
Member
Hi all,

i read the older release notes of

http://www.eclipse.org/eclipse/development/readme_eclipse_3_ 0.html up to
http://www.eclipse.org/eclipse/development/readme_eclipse_3_ 0_2.html

and see that eclipse has been tested and validated with hp-ux and the
jre 1.4.2.00.

Then I see following note, probably is this the problem we have and will
be checked tomorrow:

Missing permissions for SWT native libraries in workspace (HP-UX only)

When retrieving the SWT Motif fragment into an Eclipse workspace, the
permissions of the native libraries are reset. This creates a problem on
HP-UX because shared libraries need to have execute permission.
Attempting to self-host with this fragment throws an
UnsatisfiedLinkError...Permission Denied error. You must manually change
the permissions to make these libraries accessible (assume the workspace
is at /workspace):

cd /workspace/org.eclipse.swt.motif/os/hpux/PA_RISC
chmod 555 *.sl



Regards,
ANdreas


Andreas Niemeyer wrote:
> Hi all,
>
> I'm looking for a list, which swt version requires which java version, e.g.
>
> swt 3.01(3064) -> 1.4.2_03
> swt 3.1(3138) -> 1.4.2_06
>
> to define a minimum and acceptable jre version/subversions for a swt
> application.
>
> For instance, one of our customers used hardware/software combination is
> a HP c8000 workstation with HP-UX 11.11 and a installed Java 1.4.2_00 .
>
> For this env we have problems to launch an SWT application with swt libs
> like 3064 or above and I guess there is a version conflict which force
> us to use a newer java version or to downgrade the used swt libs.
>
> The application starts first, a user is able to login about a shell
> dialog box and then, nothing happens - the main app window doesn't
> appear, a process is just running - the app hangs; no idea to find out
> what's going wrong.
>
> Exists there a debug capability to pin down those kinds of problems?
>
> If we try it with an own jre 1.4.2_03, the app starts without problems.
>
>
> Many thanks for some suggestions!
>
> Regards,
> ANdreas
Re: java and swt libs compatibility [message #460749 is a reply to message #460517] Tue, 06 September 2005 16:45 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
As a side note, swt itself only requires a jre >= 1.1.8, but eclipse
requires the newer versions that you listed.

Grant

"Andreas Niemeyer" <andreas.niemeyer@gutzmann.com> wrote in message
news:df28jl$k1p$1@news.eclipse.org...
> Hi all,
>
> i read the older release notes of
>
> http://www.eclipse.org/eclipse/development/readme_eclipse_3_ 0.html up to
> http://www.eclipse.org/eclipse/development/readme_eclipse_3_ 0_2.html
>
> and see that eclipse has been tested and validated with hp-ux and the
> jre 1.4.2.00.
>
> Then I see following note, probably is this the problem we have and will
> be checked tomorrow:
>
> Missing permissions for SWT native libraries in workspace (HP-UX only)
>
> When retrieving the SWT Motif fragment into an Eclipse workspace, the
> permissions of the native libraries are reset. This creates a problem on
> HP-UX because shared libraries need to have execute permission.
> Attempting to self-host with this fragment throws an
> UnsatisfiedLinkError...Permission Denied error. You must manually change
> the permissions to make these libraries accessible (assume the workspace
> is at /workspace):
>
> cd /workspace/org.eclipse.swt.motif/os/hpux/PA_RISC
> chmod 555 *.sl
>
>
>
> Regards,
> ANdreas
>
>
> Andreas Niemeyer wrote:
> > Hi all,
> >
> > I'm looking for a list, which swt version requires which java version,
e.g.
> >
> > swt 3.01(3064) -> 1.4.2_03
> > swt 3.1(3138) -> 1.4.2_06
> >
> > to define a minimum and acceptable jre version/subversions for a swt
> > application.
> >
> > For instance, one of our customers used hardware/software combination is
> > a HP c8000 workstation with HP-UX 11.11 and a installed Java 1.4.2_00 .
> >
> > For this env we have problems to launch an SWT application with swt libs
> > like 3064 or above and I guess there is a version conflict which force
> > us to use a newer java version or to downgrade the used swt libs.
> >
> > The application starts first, a user is able to login about a shell
> > dialog box and then, nothing happens - the main app window doesn't
> > appear, a process is just running - the app hangs; no idea to find out
> > what's going wrong.
> >
> > Exists there a debug capability to pin down those kinds of problems?
> >
> > If we try it with an own jre 1.4.2_03, the app starts without problems.
> >
> >
> > Many thanks for some suggestions!
> >
> > Regards,
> > ANdreas
Previous Topic:Column editable in a Tree
Next Topic:TabFolder with tabItem at right/left side
Goto Forum:
  


Current Time: Mon Aug 19 03:46:36 GMT 2019

Powered by FUDForum. Page generated in 0.02287 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top