Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » MWE Interim Update issue
MWE Interim Update issue [message #448003] Sat, 01 August 2009 02:14 Go to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1341
Registered: July 2009
Senior Member
Hi guys,

MWE 20090725 appears broken on my install. M20090729-0903 Its looking
for a (very) specific version of commons.lang that apparantly isn't
there..

Missing requirement: MWE Core (Incubation) 0.7.1.v200907251900
(org.eclipse.emf.mwe.core.feature.group 0.7.1.v200907251900) requires
'org.apache.commons.lang [2.1.0.v200803061811]' but it could not be
found

thanks,

Miles
Re: MWE Interim Update issue [message #452969 is a reply to message #448003] Sat, 01 August 2009 14:41 Go to previous messageGo to next message
ekkehard gentz is currently offline ekkehard gentzFriend
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

its never a good idea to use a required-bundle dependency if using common things like:

* logging
* apache commons
etc.

If working with some projects and 3rd frameworks,
then you always have problems with those common used dependencies resolved by required-bundle

I opened 3 bugzillas for this about logging against mwe, xpand and xtext. (bugzilla 284714, 284715 and 284716)

Miles, please open a bugzilla to change the dependency to package-import

ekke


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Re: MWE Interim Update issue [message #468053 is a reply to message #452969] Mon, 03 August 2009 19:24 Go to previous message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1341
Registered: July 2009
Senior Member
It's a good point and will do. I can't help but feel a little worry
about this issue altogether, because after all I suppose that it is
possible to have some sort of configuration where noone actually
provides apache commons. :) I do think that at least one should have no
version specified. Unfortunatly PDE complicates this because it always
wants to add in the most exact version. :( Have you come across any
good discussions of this?

On 2009-08-01 07:41:52 -0700, ekke (ekkehard gentz)
<ekke@ekkes-corner.org> said:

> its never a good idea to use a required-bundle dependency if using
> common things like:
>
> * logging
> * apache commons
> etc.
>
> If working with some projects and 3rd frameworks,
> then you always have problems with those common used dependencies
> resolved by required-bundle
>
> I opened 3 bugzillas for this about logging against mwe, xpand and
> xtext. (bugzilla 284714, 284715 and 284716)
>
> Miles, please open a bugzilla to change the dependency to package-import
>
> ekke
Re: MWE Interim Update issue [message #621291 is a reply to message #448003] Sat, 01 August 2009 14:41 Go to previous message
ekkehard gentz is currently offline ekkehard gentzFriend
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

its never a good idea to use a required-bundle dependency if using common things like:

* logging
* apache commons
etc.

If working with some projects and 3rd frameworks,
then you always have problems with those common used dependencies resolved by required-bundle

I opened 3 bugzillas for this about logging against mwe, xpand and xtext. (bugzilla 284714, 284715 and 284716)

Miles, please open a bugzilla to change the dependency to package-import

ekke


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Re: MWE Interim Update issue [message #621297 is a reply to message #452969] Mon, 03 August 2009 19:24 Go to previous message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1341
Registered: July 2009
Senior Member
It's a good point and will do. I can't help but feel a little worry
about this issue altogether, because after all I suppose that it is
possible to have some sort of configuration where noone actually
provides apache commons. :) I do think that at least one should have no
version specified. Unfortunatly PDE complicates this because it always
wants to add in the most exact version. :( Have you come across any
good discussions of this?

On 2009-08-01 07:41:52 -0700, ekke (ekkehard gentz)
<ekke@ekkes-corner.org> said:

> its never a good idea to use a required-bundle dependency if using
> common things like:
>
> * logging
> * apache commons
> etc.
>
> If working with some projects and 3rd frameworks,
> then you always have problems with those common used dependencies
> resolved by required-bundle
>
> I opened 3 bugzillas for this about logging against mwe, xpand and
> xtext. (bugzilla 284714, 284715 and 284716)
>
> Miles, please open a bugzilla to change the dependency to package-import
>
> ekke
Previous Topic:properties view tab refresh
Next Topic:MWE JavaBeautifier differs from oAW Version(?)
Goto Forum:
  


Current Time: Mon Feb 26 02:48:49 GMT 2024

Powered by FUDForum. Page generated in 0.02075 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top