Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [TENEO] mapping problem
[TENEO] mapping problem [message #431669] Tue, 21 July 2009 12:19 Go to next message
Eclipse UserFriend
Originally posted by: krdbrm.gmail.com

Hallo,

i have following problem if i mapp my ecore model,

org.hibernate.MappingException: Could not determine type for: org.eclipse.emf.teneo.hibernate.mapping.ENumUserType, at table: ecore_eobject, for columns: [org.hibernate.mapping.Column(measurementunit)]
at org.hibernate.mapping.SimpleValue.getType(SimpleValue.java:2 92)
at org.hibernate.mapping.SimpleValue.isValid(SimpleValue.java:2 76)
at org.hibernate.mapping.Property.isValid(Property.java:207)
at org.hibernate.mapping.PersistentClass.validate(PersistentCla ss.java:458)
at org.hibernate.mapping.SingleTableSubclass.validate(SingleTab leSubclass.java:66)
at org.hibernate.cfg.Configuration.validate(Configuration.java: 1135)
at org.hibernate.cfg.Configuration.buildSessionFactory(Configur ation.java:1320)
at org.eclipse.emf.teneo.hibernate.HbSessionDataStore.buildSess ionFactory(HbSessionDataStore.java:171)
at org.eclipse.emf.teneo.hibernate.HbSessionDataStore.initializ e(HbSessionDataStore.java:83)
at org.efixes.dataaccess.db.EfStoreController.initializeDataSto re(EfStoreController.java:159)


i use

EMf 2.4
teneo 1.0.4
Eclipse 3.4


anybody has an idea?




thank you very much.
Bahram
Re: [TENEO] mapping problem [message #431670 is a reply to message #431669] Tue, 21 July 2009 12:30 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Bahram,
This is often a classloading issue. Hibernate does not have access to the
org.eclipse.emf.teneo.hibernate.mapping.ENumUserType class.

Did you set the eclipse buddy policy to dependent?

gr. Martin

Bahram Kord wrote:
> Hallo,
>
> i have following problem if i mapp my ecore model,
>
> org.hibernate.MappingException: Could not determine type for:
> org.eclipse.emf.teneo.hibernate.mapping.ENumUserType, at table:
> ecore_eobject, for columns: [org.hibernate.mapping.Column(measurementunit)]
> at org.hibernate.mapping.SimpleValue.getType(SimpleValue.java:2 92)
> at org.hibernate.mapping.SimpleValue.isValid(SimpleValue.java:2 76)
> at org.hibernate.mapping.Property.isValid(Property.java:207)
> at org.hibernate.mapping.PersistentClass.validate(PersistentCla ss.java:458)
> at
> org.hibernate.mapping.SingleTableSubclass.validate(SingleTab leSubclass.java:66)
>
> at org.hibernate.cfg.Configuration.validate(Configuration.java: 1135)
> at
> org.hibernate.cfg.Configuration.buildSessionFactory(Configur ation.java:1320)
>
> at
> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.buildSess ionFactory(HbSessionDataStore.java:171)
>
> at
> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.initializ e(HbSessionDataStore.java:83)
>
> at
> org.efixes.dataaccess.db.EfStoreController.initializeDataSto re(EfStoreController.java:159)
>
>
>
> i use
>
> EMf 2.4
> teneo 1.0.4
> Eclipse 3.4
>
>
> anybody has an idea?
>
>
>
>
> thank you very much.
> Bahram


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [TENEO] mapping problem [message #431671 is a reply to message #431670] Tue, 21 July 2009 12:44 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: krdbrm.gmail.com

hi martin,

yes following entries are in my MANIFEST.MF.

org.eclipse.emf.teneo.hibernate;bundle-version="1.0.1";visibility:=reexport,
org.efixes.hibernate.distribution;bundle-version="1.0.0";visibility:=reexport,
Eclipse-BuddyPolicy: dependent

br
Bahram
Martin Taal schrieb:
> Hi Bahram,
> This is often a classloading issue. Hibernate does not have access to
> the org.eclipse.emf.teneo.hibernate.mapping.ENumUserType class.
>
> Did you set the eclipse buddy policy to dependent?
>
> gr. Martin
>
> Bahram Kord wrote:
>> Hallo,
>>
>> i have following problem if i mapp my ecore model,
>>
>> org.hibernate.MappingException: Could not determine type for:
>> org.eclipse.emf.teneo.hibernate.mapping.ENumUserType, at table:
>> ecore_eobject, for columns:
>> [org.hibernate.mapping.Column(measurementunit)]
>> at org.hibernate.mapping.SimpleValue.getType(SimpleValue.java:2 92)
>> at org.hibernate.mapping.SimpleValue.isValid(SimpleValue.java:2 76)
>> at org.hibernate.mapping.Property.isValid(Property.java:207)
>> at
>> org.hibernate.mapping.PersistentClass.validate(PersistentCla ss.java:458)
>> at
>> org.hibernate.mapping.SingleTableSubclass.validate(SingleTab leSubclass.java:66)
>>
>> at org.hibernate.cfg.Configuration.validate(Configuration.java: 1135)
>> at
>> org.hibernate.cfg.Configuration.buildSessionFactory(Configur ation.java:1320)
>>
>> at
>> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.buildSess ionFactory(HbSessionDataStore.java:171)
>>
>> at
>> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.initializ e(HbSessionDataStore.java:83)
>>
>> at
>> org.efixes.dataaccess.db.EfStoreController.initializeDataSto re(EfStoreController.java:159)
>>
>>
>>
>> i use
>>
>> EMf 2.4
>> teneo 1.0.4
>> Eclipse 3.4
>>
>>
>> anybody has an idea?
>>
>>
>>
>>
>> thank you very much.
>> Bahram
>
>
Re: [TENEO] mapping problem [message #431674 is a reply to message #431671] Tue, 21 July 2009 13:13 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Bahram,
The eclipse buddy policy dependent should be in the hibernate plugin (in your case I think it is the
org.efixes.hibernate.distribution plugin).

gr. Martin

Bahram Kord wrote:
> hi martin,
>
> yes following entries are in my MANIFEST.MF.
>
> org.eclipse.emf.teneo.hibernate;bundle-version="1.0.1";visibility:=reexport,
>
> org.efixes.hibernate.distribution;bundle-version="1.0.0";visibility:=reexport,
>
> Eclipse-BuddyPolicy: dependent
>
> br
> Bahram
> Martin Taal schrieb:
>> Hi Bahram,
>> This is often a classloading issue. Hibernate does not have access to
>> the org.eclipse.emf.teneo.hibernate.mapping.ENumUserType class.
>>
>> Did you set the eclipse buddy policy to dependent?
>>
>> gr. Martin
>>
>> Bahram Kord wrote:
>>> Hallo,
>>>
>>> i have following problem if i mapp my ecore model,
>>>
>>> org.hibernate.MappingException: Could not determine type for:
>>> org.eclipse.emf.teneo.hibernate.mapping.ENumUserType, at table:
>>> ecore_eobject, for columns:
>>> [org.hibernate.mapping.Column(measurementunit)]
>>> at org.hibernate.mapping.SimpleValue.getType(SimpleValue.java:2 92)
>>> at org.hibernate.mapping.SimpleValue.isValid(SimpleValue.java:2 76)
>>> at org.hibernate.mapping.Property.isValid(Property.java:207)
>>> at
>>> org.hibernate.mapping.PersistentClass.validate(PersistentCla ss.java:458)
>>> at
>>> org.hibernate.mapping.SingleTableSubclass.validate(SingleTab leSubclass.java:66)
>>>
>>> at org.hibernate.cfg.Configuration.validate(Configuration.java: 1135)
>>> at
>>> org.hibernate.cfg.Configuration.buildSessionFactory(Configur ation.java:1320)
>>>
>>> at
>>> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.buildSess ionFactory(HbSessionDataStore.java:171)
>>>
>>> at
>>> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.initializ e(HbSessionDataStore.java:83)
>>>
>>> at
>>> org.efixes.dataaccess.db.EfStoreController.initializeDataSto re(EfStoreController.java:159)
>>>
>>>
>>>
>>> i use
>>>
>>> EMf 2.4
>>> teneo 1.0.4
>>> Eclipse 3.4
>>>
>>>
>>> anybody has an idea?
>>>
>>>
>>>
>>>
>>> thank you very much.
>>> Bahram
>>
>>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [TENEO] mapping problem [message #431675 is a reply to message #431674] Tue, 21 July 2009 13:34 Go to previous message
Eclipse UserFriend
Originally posted by: krdbrm.gmail.com

thank you very much it works for me.
br
Bahram
Martin Taal schrieb:
> Hi Bahram,
> The eclipse buddy policy dependent should be in the hibernate plugin (in
> your case I think it is the org.efixes.hibernate.distribution plugin).
>
> gr. Martin
>
> Bahram Kord wrote:
>> hi martin,
>>
>> yes following entries are in my MANIFEST.MF.
>>
>> org.eclipse.emf.teneo.hibernate;bundle-version="1.0.1";visibility:=reexport,
>>
>> org.efixes.hibernate.distribution;bundle-version="1.0.0";visibility:=reexport,
>>
>> Eclipse-BuddyPolicy: dependent
>>
>> br
>> Bahram
>> Martin Taal schrieb:
>>> Hi Bahram,
>>> This is often a classloading issue. Hibernate does not have access to
>>> the org.eclipse.emf.teneo.hibernate.mapping.ENumUserType class.
>>>
>>> Did you set the eclipse buddy policy to dependent?
>>>
>>> gr. Martin
>>>
>>> Bahram Kord wrote:
>>>> Hallo,
>>>>
>>>> i have following problem if i mapp my ecore model,
>>>>
>>>> org.hibernate.MappingException: Could not determine type for:
>>>> org.eclipse.emf.teneo.hibernate.mapping.ENumUserType, at table:
>>>> ecore_eobject, for columns:
>>>> [org.hibernate.mapping.Column(measurementunit)]
>>>> at org.hibernate.mapping.SimpleValue.getType(SimpleValue.java:2 92)
>>>> at org.hibernate.mapping.SimpleValue.isValid(SimpleValue.java:2 76)
>>>> at org.hibernate.mapping.Property.isValid(Property.java:207)
>>>> at
>>>> org.hibernate.mapping.PersistentClass.validate(PersistentCla ss.java:458)
>>>>
>>>> at
>>>> org.hibernate.mapping.SingleTableSubclass.validate(SingleTab leSubclass.java:66)
>>>>
>>>> at org.hibernate.cfg.Configuration.validate(Configuration.java: 1135)
>>>> at
>>>> org.hibernate.cfg.Configuration.buildSessionFactory(Configur ation.java:1320)
>>>>
>>>> at
>>>> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.buildSess ionFactory(HbSessionDataStore.java:171)
>>>>
>>>> at
>>>> org.eclipse.emf.teneo.hibernate.HbSessionDataStore.initializ e(HbSessionDataStore.java:83)
>>>>
>>>> at
>>>> org.efixes.dataaccess.db.EfStoreController.initializeDataSto re(EfStoreController.java:159)
>>>>
>>>>
>>>>
>>>> i use
>>>>
>>>> EMf 2.4
>>>> teneo 1.0.4
>>>> Eclipse 3.4
>>>>
>>>>
>>>> anybody has an idea?
>>>>
>>>>
>>>>
>>>>
>>>> thank you very much.
>>>> Bahram
>>>
>>>
>
>
Previous Topic:When to use "is abstract" and when "is interface"
Next Topic:EMF XML Serialization
Goto Forum:
  


Current Time: Fri Dec 13 12:36:04 GMT 2019

Powered by FUDForum. Page generated in 0.01475 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top