Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Derby drivers
[CDO] Derby drivers [message #431523] Wed, 15 July 2009 11:19 Go to next message
Egidijus Vaisnora is currently offline Egidijus VaisnoraFriend
Messages: 47
Registered: July 2009
Member
I have downloaded newer derby drivers but jar doesn't contain class files.
Location: http://net4j.sourceforge.net/update/features/org.apache.derb y_10.5.1.200907040904.jar
Re: [CDO] Derby drivers [message #431526 is a reply to message #431523] Wed, 15 July 2009 11:56 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6457
Registered: July 2009
Senior Member
Egidijus Vaisnora schrieb:
>
> I have downloaded newer derby drivers but jar doesn't contain class
> files.
> Location:
> http://net4j.sourceforge.net/update/features/org.apache.derb y_10.5.1.200907040904.jar
>

This is a p2 repository. You can not manually download the individual
bundles and put them in dropins or so.

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: [CDO] Derby drivers [message #431529 is a reply to message #431523] Wed, 15 July 2009 12:17 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6457
Registered: July 2009
Senior Member
BTW. I try to keep this up to date as well, but no guarantees:

http://net4j.sourceforge.net/update/downloads/ThirdPartyDriv ers.zip

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper



Egidijus Vaisnora schrieb:
>
> I have downloaded newer derby drivers but jar doesn't contain class
> files.
> Location:
> http://net4j.sourceforge.net/update/features/org.apache.derb y_10.5.1.200907040904.jar
>


Re: [CDO] Derby drivers [message #431555 is a reply to message #431529] Thu, 16 July 2009 14:35 Go to previous messageGo to next message
Egidijus Vaisnora is currently offline Egidijus VaisnoraFriend
Messages: 47
Registered: July 2009
Member
Seems that org.apache.derby_10.5.1.200907040904.jar doesn't export pacakge org.apache.derby.jdbc, which is required by the
org.eclipse.net4j.db.derby (I still use RC4).


Eike Stepper wrote:
> BTW. I try to keep this up to date as well, but no guarantees:
>
> http://net4j.sourceforge.net/update/downloads/ThirdPartyDriv ers.zip
>
> Cheers
> /Eike
>
> ----
> http://thegordian.blogspot.com
> http://twitter.com/eikestepper
>
>
>
> Egidijus Vaisnora schrieb:
>> I have downloaded newer derby drivers but jar doesn't contain class
>> files.
>> Location:
>> http://net4j.sourceforge.net/update/features/org.apache.derb y_10.5.1.200907040904.jar
>>
Re: [CDO] Derby drivers [message #431557 is a reply to message #431555] Thu, 16 July 2009 15:13 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6457
Registered: July 2009
Senior Member
Egidijus Vaisnora schrieb:
>
> Seems that org.apache.derby_10.5.1.200907040904.jar doesn't export
> pacakge org.apache.derby.jdbc, which is required by the
> org.eclipse.net4j.db.derby (I still use RC4).
IIRC. we don't use that bundle ourselves because that Derby version is
not compatible with former ones. The ones we have to ship, because
they're part of Orbit ;-(

BTW. I heard rumors that the H2 engine/driver is a better choice than
Derby. Maybe Stefan can comment if we can ship H2 through Orbit in the
future...

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper


>
>
> Eike Stepper wrote:
>> BTW. I try to keep this up to date as well, but no guarantees:
>>
>> http://net4j.sourceforge.net/update/downloads/ThirdPartyDriv ers.zip
>>
>> Cheers
>> /Eike
>>
>> ----
>> http://thegordian.blogspot.com
>> http://twitter.com/eikestepper
>>
>>
>>
>> Egidijus Vaisnora schrieb:
>>> I have downloaded newer derby drivers but jar doesn't contain class
>>> files.
>>> Location:
>>> http://net4j.sourceforge.net/update/features/org.apache.derb y_10.5.1.200907040904.jar
>>>
>>>


Re: [CDO] Derby drivers [message #431558 is a reply to message #431557] Thu, 16 July 2009 15:49 Go to previous message
Egidijus Vaisnora is currently offline Egidijus VaisnoraFriend
Messages: 47
Registered: July 2009
Member
> IIRC. we don't use that bundle ourselves because that Derby version is
> not compatible with former ones. The ones we have to ship, because
> they're part of Orbit ;-(

If I correctly understood - newer derby is not compatible with an older derby DB right?

> BTW. I heard rumors that the H2 engine/driver is a better choice than
> Derby. Maybe Stefan can comment if we can ship H2 through Orbit in the
> future...

At current time we have made choice for derby, but in future who know... Have you made some benchmark tests for H2 and Derby?
Previous Topic:ecore for operation returning EList<? extends XXX>
Next Topic:[Databinding API] Path over multi-valued features
Goto Forum:
  


Current Time: Tue Dec 10 08:00:20 GMT 2019

Powered by FUDForum. Page generated in 0.02375 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top