Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » "Cannot complete the request."
"Cannot complete the request." [message #431225] Fri, 03 July 2009 03:35 Go to next message
Tom H is currently offline Tom HFriend
Messages: 136
Registered: July 2009
Senior Member
My updates are stuck on the following dependency;

Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements
org.eclipse.emf.codegen [2.4.0.v200902171115].

eclipse is offering me an update to web tool platform 3.1 and EMF 2.5,
I am thinking that I have added a update site that is only for eclipse 3.5?

Thanks,

Tom
Re: "Cannot complete the request." [message #431228 is a reply to message #431225] Fri, 03 July 2009 09:52 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30686
Registered: July 2009
Senior Member
Tom,

I'd heard that you can't update a 3.4-based Eclipse to 3.5. Certainly
things that depend on EMF 2.4 with a hard upper bound won't install
happily with things that depend on EMF 2.5 with a hard lower bound...


Tom H wrote:
>
> My updates are stuck on the following dependency;
>
> Cannot complete the request. See the details.
> Cannot find a solution satisfying the following requirements
> org.eclipse.emf.codegen [2.4.0.v200902171115].
>
> eclipse is offering me an update to web tool platform 3.1 and EMF
> 2.5, I am thinking that I have added a update site that is only for
> eclipse 3.5?
>
> Thanks,
>
> Tom
Previous Topic:[CDO] ClassCastException: model class cannot be cast to InternalCDORevision
Next Topic:Ecore2Java ant task
Goto Forum:
  


Current Time: Mon Dec 09 01:54:22 GMT 2019

Powered by FUDForum. Page generated in 0.02016 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top