Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Teneo 1.0.4/Teneo 1.1.1 Maintenance Builds, Hibernate version, xsd:any/xsd:anytype
Teneo 1.0.4/Teneo 1.1.1 Maintenance Builds, Hibernate version, xsd:any/xsd:anytype [message #431157] Tue, 30 June 2009 12:56 Go to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,
I did a new build/promote today of a Teneo 1.0.4 and a Teneo 1.1.1 Maintenance build. Here are some special things to note.

>>> Teneo 1.1.1: Depends on Hibernate 3.3.2 GA (Hibernate 3.3.1 won't work)
This maintenance version depends on the latest Hibernate GA release: 3.3.2 (released last week). In this version
Hibernate has made changes in it's extension api's which needed to be followed by Teneo. Afaics these Hibernate changes
are not backward compatible with earlier versions of Hibernate. Therefore, this means that Teneo 1.1.1 will only work
with Hibernate 3.3.2 and not with earlier versions of Hibernate.

>>> Teneo 1.0.4: works with Hibernate versions < 3.3.2
Teneo 1.0.4 works with Hibernate 3.2 and 3.3.1 but not with Hibernate 3.3.2.

>>> Support for xsd:any/xsd:anytype
To not only talk about dependency details, this build also adds something nice: support for xsd:any and xsd:anytype.
Also the support for mixed xsd types has been improved.

In addition some other smaller issues have been solved.

--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo 1.0.4/Teneo 1.1.1 Maintenance Builds, Hibernate version, xsd:any/xsd:anytype [message #431181 is a reply to message #431157] Wed, 01 July 2009 17:21 Go to previous messageGo to next message
Matt Biggs is currently offline Matt BiggsFriend
Messages: 71
Registered: July 2009
Member
Martin,

Are these supposed to be on one of the update sites? I can't seem to find
1.1.1?

I must be going mad!

cheers

Matt
Re: Teneo 1.0.4/Teneo 1.1.1 Maintenance Builds, Hibernate version, xsd:any/xsd:anytype [message #431189 is a reply to message #431181] Wed, 01 July 2009 19:29 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Matt,
I don't think you are going mad, or maybe I am to, I can't find it either... I will redo the promote and see what happens.

The 1.1.1 release can also be downloaded directly here:
http://www.eclipse.org/modeling/emf/downloads/?project=teneo
(see a little bit down on the page).

gr. Martin

Matt Biggs wrote:
> Martin,
>
> Are these supposed to be on one of the update sites? I can't seem to
> find 1.1.1?
>
> I must be going mad!
>
> cheers
>
> Matt
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:ECore to XSD roundtripping question regarding keys
Next Topic:Hide elements in [List]Viewer
Goto Forum:
  


Current Time: Sat Dec 07 13:33:58 GMT 2019

Powered by FUDForum. Page generated in 0.02626 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top