Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] CDO 2.0.0 installation under Eclipse 3.5M4
[CDO] CDO 2.0.0 installation under Eclipse 3.5M4 [message #426194] Thu, 18 December 2008 17:26 Go to next message
Kai Schlamp is currently offline Kai SchlampFriend
Messages: 344
Registered: July 2009
Senior Member
Hello.

I just tried to install CDO 2.0.0 in Eclipse 3.5M4.
My problem is that some plug-ins after the installation are missing:
org.eclipse.emf.cdo.server.hibernate,
org.eclipse.emf.cdo.server.hibernate.teneo.
Those were available in my CDO 1.0.x installation under Eclipse 3.4
Ganymede.
I tried the latest CDO integration build and the latest milestone.
The files org.eclipse.emf.cdo.server.hibernate.teneo_2.0.0.v2008112702 13 and
org.eclipse.emf.cdo.server.hibernate_2.0.0.v200811270213
are in the Eclipse dropin folder (dropins\eclipse\plugins), but it seems
that those plugins are not loaded at eclipse startup (not available in
the Plug-Ins view).
All dependencies as stated on the CDO download site are installed (also
in the dropin folder) and Hibernate Tools as well.
Any suggestions how to get those CDO Hibernate/Teneo plug-ins to be loaded?

Best regards,
Kai
Re: [CDO] CDO 2.0.0 installation under Eclipse 3.5M4 [message #426202 is a reply to message #426194] Fri, 19 December 2008 09:35 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6477
Registered: July 2009
Senior Member
Kai,

I guess it's the problem described in
http://wiki.eclipse.org/FAQ_for_CDO_and_Net4j#Why_does_p2_co mplain_about_unsatisfied_dependencies.3F
Does that help?

Cheers
/Eike

----
http://thegordian.blogspot.com



Kai Schlamp schrieb:
> Hello.
>
> I just tried to install CDO 2.0.0 in Eclipse 3.5M4.
> My problem is that some plug-ins after the installation are missing:
> org.eclipse.emf.cdo.server.hibernate,
> org.eclipse.emf.cdo.server.hibernate.teneo.
> Those were available in my CDO 1.0.x installation under Eclipse 3.4
> Ganymede.
> I tried the latest CDO integration build and the latest milestone.
> The files
> org.eclipse.emf.cdo.server.hibernate.teneo_2.0.0.v2008112702 13 and
> org.eclipse.emf.cdo.server.hibernate_2.0.0.v200811270213
> are in the Eclipse dropin folder (dropins\eclipse\plugins), but it
> seems that those plugins are not loaded at eclipse startup (not
> available in the Plug-Ins view).
> All dependencies as stated on the CDO download site are installed
> (also in the dropin folder) and Hibernate Tools as well.
> Any suggestions how to get those CDO Hibernate/Teneo plug-ins to be
> loaded?
>
> Best regards,
> Kai


Re: [CDO] CDO 2.0.0 installation under Eclipse 3.5M4 [message #426214 is a reply to message #426202] Fri, 19 December 2008 16:00 Go to previous messageGo to next message
Kai Schlamp is currently offline Kai SchlampFriend
Messages: 344
Registered: July 2009
Senior Member
Hy Eike,

I thought that this P2 problem only appears when using the Update
Manager, and not when installing the Plug-Ins manually inside the
dropins folder (what I did).
Also the core CDO plug-ins are there. It's only
org.eclipse.emf.cdo.server.hibernate.teneo_2.0.0.v2008112702 13 and
org.eclipse.emf.cdo.server.hibernate_2.0.0.v200811270213 that are not
recognized correctly. Any ideas?
Do I have to install those Spring dependencies also when using the zip
archives of CDO?

Eike Stepper schrieb:
> Kai,
>
> I guess it's the problem described in
> http://wiki.eclipse.org/FAQ_for_CDO_and_Net4j#Why_does_p2_co mplain_about_unsatisfied_dependencies.3F
>
> Does that help?
>
> Cheers
> /Eike
>
> ----
> http://thegordian.blogspot.com
>
>
>
> Kai Schlamp schrieb:
>> Hello.
>>
>> I just tried to install CDO 2.0.0 in Eclipse 3.5M4.
>> My problem is that some plug-ins after the installation are missing:
>> org.eclipse.emf.cdo.server.hibernate,
>> org.eclipse.emf.cdo.server.hibernate.teneo.
>> Those were available in my CDO 1.0.x installation under Eclipse 3.4
>> Ganymede.
>> I tried the latest CDO integration build and the latest milestone.
>> The files
>> org.eclipse.emf.cdo.server.hibernate.teneo_2.0.0.v2008112702 13 and
>> org.eclipse.emf.cdo.server.hibernate_2.0.0.v200811270213
>> are in the Eclipse dropin folder (dropins\eclipse\plugins), but it
>> seems that those plugins are not loaded at eclipse startup (not
>> available in the Plug-Ins view).
>> All dependencies as stated on the CDO download site are installed
>> (also in the dropin folder) and Hibernate Tools as well.
>> Any suggestions how to get those CDO Hibernate/Teneo plug-ins to be
>> loaded?
>>
>> Best regards,
>> Kai
Re: [CDO] CDO 2.0.0 installation under Eclipse 3.5M4 [message #426215 is a reply to message #426214] Fri, 19 December 2008 16:27 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6477
Registered: July 2009
Senior Member
Kai,

Comments below...


Kai Schlamp schrieb:
> Hy Eike,
>
> I thought that this P2 problem only appears when using the Update
> Manager, and not when installing the Plug-Ins manually inside the
> dropins folder (what I did).
> Also the core CDO plug-ins are there. It's only
> org.eclipse.emf.cdo.server.hibernate.teneo_2.0.0.v2008112702 13 and
> org.eclipse.emf.cdo.server.hibernate_2.0.0.v200811270213 that are not
> recognized correctly. Any ideas?
> Do I have to install those Spring dependencies also when using the zip
> archives of CDO?
Yes. We are not allowed to redistribute Hibernate or the dependencies of
Hibernate. Neither through p2 nor through the download zips.

Cheers
/Eike

----
http://thegordian.blogspot.com


>
> Eike Stepper schrieb:
>> Kai,
>>
>> I guess it's the problem described in
>> http://wiki.eclipse.org/FAQ_for_CDO_and_Net4j#Why_does_p2_co mplain_about_unsatisfied_dependencies.3F
>>
>> Does that help?
>>
>> Cheers
>> /Eike
>>
>> ----
>> http://thegordian.blogspot.com
>>
>>
>>
>> Kai Schlamp schrieb:
>>> Hello.
>>>
>>> I just tried to install CDO 2.0.0 in Eclipse 3.5M4.
>>> My problem is that some plug-ins after the installation are missing:
>>> org.eclipse.emf.cdo.server.hibernate,
>>> org.eclipse.emf.cdo.server.hibernate.teneo.
>>> Those were available in my CDO 1.0.x installation under Eclipse 3.4
>>> Ganymede.
>>> I tried the latest CDO integration build and the latest milestone.
>>> The files
>>> org.eclipse.emf.cdo.server.hibernate.teneo_2.0.0.v2008112702 13 and
>>> org.eclipse.emf.cdo.server.hibernate_2.0.0.v200811270213
>>> are in the Eclipse dropin folder (dropins\eclipse\plugins), but it
>>> seems that those plugins are not loaded at eclipse startup (not
>>> available in the Plug-Ins view).
>>> All dependencies as stated on the CDO download site are installed
>>> (also in the dropin folder) and Hibernate Tools as well.
>>> Any suggestions how to get those CDO Hibernate/Teneo plug-ins to be
>>> loaded?
>>>
>>> Best regards,
>>> Kai


Previous Topic:Problem loading model as a resource
Next Topic:Re: Multi root EPackages support
Goto Forum:
  


Current Time: Tue Feb 18 21:22:35 GMT 2020

Powered by FUDForum. Page generated in 0.05903 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top