Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Second CDOResource with name=null
[CDO] Second CDOResource with name=null [message #425432] Wed, 26 November 2008 09:44 Go to next message
Bjoern Sundin is currently offline Bjoern SundinFriend
Messages: 47
Registered: July 2009
Member
Today I wanted to move my project from CDO/NET4J version I200810161652 to
2.0.0M3.



Without modifying any of my code yet, I encountered two problems of which I
could solve the first (missing element 'jdbcDelegate' in cdo-server.xml).
For the second problem I haven't found a solution yet and so I turn to the
community for assistance:



Out of my IDE (3.5 M3) I successfully start the server instance (creating a
new derby db), however when I start the client and read in some initial data
the server gets a problem during the commit which I didn't have with the
I200810161652 version:

....

Thread-3 [debug] Writing revision: CDOResource@OID1v1

Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE cdo_container=0
AND name='kgk' AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
1227689750645>=cdo_created)

Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
name='kgk' AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
1227689750645>=cdo_created)

Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?,
?) (CDOResource@OID1v1)

Thread-3 [debug] INSERT IGNORE INTO CDOResource_contents_refs VALUES (?, ?, ?, ?)
(0,1,1,0,58)

Thread-3 [debug.sql] CREATE TABLE cdo_objects (cdo_id BIGINT, cdo_class
INTEGER)

Thread-3 [debug.sql] CREATE INDEX cdo_objects_idx0 ON cdo_objects (cdo_id)

Thread-3 [debug.sql] INSERT IGNORE INTO cdo_objects VALUES (1, -2)

Thread-3 [debug] Writing revision: CDOResource@OID2v1

Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE cdo_container=0
AND name IS NULL AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
1227689750645>=cdo_created)

Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
name IS NULL AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
1227689750645>=cdo_created)

Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?,
?) (CDOResource@OID2v1)

[ERROR] SQL Exception: An attempt was made to get a data value of type
'VARCHAR' from a data value of type 'null'.

....



It is obvious that the problem is that the CDOResource name is NULL. What I
cannot see though, is why there is an apparent second CDOResource to be
inserted to...?



Attached is the complete server trace log.



Thanks!

Bjoern


Re: [CDO] Second CDOResource with name=null [message #425437 is a reply to message #425432] Wed, 26 November 2008 10:31 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6483
Registered: July 2009
Senior Member
Bjoern,

I discovered this regression only yesterday and filed:

256462: [DB] preparedStatement problem during commit
https://bugs.eclipse.org/bugs/show_bug.cgi?id=256462

Stefan has found a fix and will commit it later today.
As a work-around in the meantime please change back the
jdbcDelegate from preparedStatement to statement in the cdo-server.xml.

Cheers
/Eike

----
http://thegordian.blogspot.com



Bjoern Sundin schrieb:
> Today I wanted to move my project from CDO/NET4J version I200810161652 to
> 2.0.0M3.
>
>
>
> Without modifying any of my code yet, I encountered two problems of which I
> could solve the first (missing element 'jdbcDelegate' in cdo-server.xml).
> For the second problem I haven't found a solution yet and so I turn to the
> community for assistance:
>
>
>
> Out of my IDE (3.5 M3) I successfully start the server instance (creating a
> new derby db), however when I start the client and read in some initial data
> the server gets a problem during the commit which I didn't have with the
> I200810161652 version:
>
> ....
>
> Thread-3 [debug] Writing revision: CDOResource@OID1v1
>
> Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE cdo_container=0
> AND name='kgk' AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
> 1227689750645>=cdo_created)
>
> Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
> name='kgk' AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
> 1227689750645>=cdo_created)
>
> Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?,
> ?) (CDOResource@OID1v1)
>
> Thread-3 [debug] INSERT IGNORE INTO CDOResource_contents_refs VALUES (?, ?, ?, ?)
> (0,1,1,0,58)
>
> Thread-3 [debug.sql] CREATE TABLE cdo_objects (cdo_id BIGINT, cdo_class
> INTEGER)
>
> Thread-3 [debug.sql] CREATE INDEX cdo_objects_idx0 ON cdo_objects (cdo_id)
>
> Thread-3 [debug.sql] INSERT IGNORE INTO cdo_objects VALUES (1, -2)
>
> Thread-3 [debug] Writing revision: CDOResource@OID2v1
>
> Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE cdo_container=0
> AND name IS NULL AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
> 1227689750645>=cdo_created)
>
> Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
> name IS NULL AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
> 1227689750645>=cdo_created)
>
> Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?,
> ?) (CDOResource@OID2v1)
>
> [ERROR] SQL Exception: An attempt was made to get a data value of type
> 'VARCHAR' from a data value of type 'null'.
>
> ....
>
>
>
> It is obvious that the problem is that the CDOResource name is NULL. What I
> cannot see though, is why there is an apparent second CDOResource to be
> inserted to...?
>
>
>
> Attached is the complete server trace log.
>
>
>
> Thanks!
>
> Bjoern
>
>
>


Re: [CDO] Second CDOResource with name=null [message #425441 is a reply to message #425437] Wed, 26 November 2008 10:41 Go to previous messageGo to next message
Bjoern Sundin is currently offline Bjoern SundinFriend
Messages: 47
Registered: July 2009
Member
Great, thanks for the fast reply and fix!

Greetings
Bjoern

"Eike Stepper" <stepper@esc-net.de> schrieb im Newsbeitrag
news:ggj8ia$aop$1@build.eclipse.org...
> Bjoern,
>
> I discovered this regression only yesterday and filed:
>
> 256462: [DB] preparedStatement problem during commit
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=256462
>
> Stefan has found a fix and will commit it later today.
> As a work-around in the meantime please change back the
> jdbcDelegate from preparedStatement to statement in the cdo-server.xml.
>
> Cheers
> /Eike
>
> ----
> http://thegordian.blogspot.com
>
>
>
> Bjoern Sundin schrieb:
>> Today I wanted to move my project from CDO/NET4J version I200810161652 to
>> 2.0.0M3.
>>
>>
>>
>> Without modifying any of my code yet, I encountered two problems of which
>> I could solve the first (missing element 'jdbcDelegate' in
>> cdo-server.xml). For the second problem I haven't found a solution yet
>> and so I turn to the community for assistance:
>>
>>
>>
>> Out of my IDE (3.5 M3) I successfully start the server instance (creating
>> a new derby db), however when I start the client and read in some initial
>> data the server gets a problem during the commit which I didn't have with
>> the I200810161652 version:
>>
>> ....
>>
>> Thread-3 [debug] Writing revision: CDOResource@OID1v1
>>
>> Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE
>> cdo_container=0 AND name='kgk' AND ((cdo_revised=0 OR
>> cdo_revised>=1227689750645) AND 1227689750645>=cdo_created)
>>
>> Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
>> name='kgk' AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
>> 1227689750645>=cdo_created)
>>
>> Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?,
>> ?, ?) (CDOResource@OID1v1)
>>
>> Thread-3 [debug] INSERT IGNORE INTO CDOResource_contents_refs VALUES (?, ?, ?,
>> ?) (0,1,1,0,58)
>>
>> Thread-3 [debug.sql] CREATE TABLE cdo_objects (cdo_id BIGINT, cdo_class
>> INTEGER)
>>
>> Thread-3 [debug.sql] CREATE INDEX cdo_objects_idx0 ON cdo_objects
>> (cdo_id)
>>
>> Thread-3 [debug.sql] INSERT IGNORE INTO cdo_objects VALUES (1, -2)
>>
>> Thread-3 [debug] Writing revision: CDOResource@OID2v1
>>
>> Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE
>> cdo_container=0 AND name IS NULL AND ((cdo_revised=0 OR
>> cdo_revised>=1227689750645) AND 1227689750645>=cdo_created)
>>
>> Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
>> name IS NULL AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
>> 1227689750645>=cdo_created)
>>
>> Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?,
>> ?, ?) (CDOResource@OID2v1)
>>
>> [ERROR] SQL Exception: An attempt was made to get a data value of type
>> 'VARCHAR' from a data value of type 'null'.
>>
>> ....
>>
>>
>>
>> It is obvious that the problem is that the CDOResource name is NULL. What
>> I cannot see though, is why there is an apparent second CDOResource to be
>> inserted to...?
>>
>>
>>
>> Attached is the complete server trace log.
>>
>>
>>
>> Thanks!
>>
>> Bjoern
>>
>>
>>
Re: [CDO] Second CDOResource with name=null [message #425443 is a reply to message #425441] Wed, 26 November 2008 12:06 Go to previous message
Stefan Winkler is currently offline Stefan WinklerFriend
Messages: 301
Registered: July 2009
Location: Germany
Senior Member
Fix is available in HEAD now. (The problem seemed only to occur with
Derby DB ...)

Bjoern Sundin schrieb:
> Great, thanks for the fast reply and fix!
>
> Greetings
> Bjoern
>
> "Eike Stepper" <stepper@esc-net.de> schrieb im Newsbeitrag
> news:ggj8ia$aop$1@build.eclipse.org...
>
>> Bjoern,
>>
>> I discovered this regression only yesterday and filed:
>>
>> 256462: [DB] preparedStatement problem during commit
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=256462
>>
>> Stefan has found a fix and will commit it later today.
>> As a work-around in the meantime please change back the
>> jdbcDelegate from preparedStatement to statement in the cdo-server.xml.
>>
>> Cheers
>> /Eike
>>
>> ----
>> http://thegordian.blogspot.com
>>
>>
>>
>> Bjoern Sundin schrieb:
>>
>>> Today I wanted to move my project from CDO/NET4J version I200810161652 to
>>> 2.0.0M3.
>>>
>>>
>>>
>>> Without modifying any of my code yet, I encountered two problems of which
>>> I could solve the first (missing element 'jdbcDelegate' in
>>> cdo-server.xml). For the second problem I haven't found a solution yet
>>> and so I turn to the community for assistance:
>>>
>>>
>>>
>>> Out of my IDE (3.5 M3) I successfully start the server instance (creating
>>> a new derby db), however when I start the client and read in some initial
>>> data the server gets a problem during the commit which I didn't have with
>>> the I200810161652 version:
>>>
>>> ....
>>>
>>> Thread-3 [debug] Writing revision: CDOResource@OID1v1
>>>
>>> Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE
>>> cdo_container=0 AND name='kgk' AND ((cdo_revised=0 OR
>>> cdo_revised>=1227689750645) AND 1227689750645>=cdo_created)
>>>
>>> Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
>>> name='kgk' AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
>>> 1227689750645>=cdo_created)
>>>
>>> Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?,
>>> ?, ?) (CDOResource@OID1v1)
>>>
>>> Thread-3 [debug] INSERT IGNORE INTO CDOResource_contents_refs VALUES (?, ?, ?,
>>> ?) (0,1,1,0,58)
>>>
>>> Thread-3 [debug.sql] CREATE TABLE cdo_objects (cdo_id BIGINT, cdo_class
>>> INTEGER)
>>>
>>> Thread-3 [debug.sql] CREATE INDEX cdo_objects_idx0 ON cdo_objects
>>> (cdo_id)
>>>
>>> Thread-3 [debug.sql] INSERT IGNORE INTO cdo_objects VALUES (1, -2)
>>>
>>> Thread-3 [debug] Writing revision: CDOResource@OID2v1
>>>
>>> Thread-3 [debug] SELECT cdo_id FROM CDOResourceFolder WHERE
>>> cdo_container=0 AND name IS NULL AND ((cdo_revised=0 OR
>>> cdo_revised>=1227689750645) AND 1227689750645>=cdo_created)
>>>
>>> Thread-3 [debug] SELECT cdo_id FROM CDOResource WHERE cdo_container=0 AND
>>> name IS NULL AND ((cdo_revised=0 OR cdo_revised>=1227689750645) AND
>>> 1227689750645>=cdo_created)
>>>
>>> Thread-3 [debug] INSERT IGNORE INTO CDOResource VALUES (?, ?, ?, ?, ?, ?, ?, ?,
>>> ?, ?) (CDOResource@OID2v1)
>>>
>>> [ERROR] SQL Exception: An attempt was made to get a data value of type
>>> 'VARCHAR' from a data value of type 'null'.
>>>
>>> ....
>>>
>>>
>>>
>>> It is obvious that the problem is that the CDOResource name is NULL. What
>>> I cannot see though, is why there is an apparent second CDOResource to be
>>> inserted to...?
>>>
>>>
>>>
>>> Attached is the complete server trace log.
>>>
>>>
>>>
>>> Thanks!
>>>
>>> Bjoern
>>>
>>>
>>>
>>>
>
>
>
Previous Topic:how to get IItemLabelProvider of an object without knowing its adpater factory in advance
Next Topic:XSD and EList
Goto Forum:
  


Current Time: Sun Feb 23 21:34:20 GMT 2020

Powered by FUDForum. Page generated in 0.12524 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top