Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » EMF 2.5M3 with Eclipse SDK 3.5 M2
EMF 2.5M3 with Eclipse SDK 3.5 M2 [message #425279] Fri, 21 November 2008 13:57 Go to next message
J F is currently offline J FFriend
Messages: 256
Registered: July 2009
Senior Member
I wish to try out the Dynamic feature delegation of EMF 2.5 ( yes I'm
migrating to CDO as in
http://dev.eclipse.org/newslists/news.eclipse.tools.emf/msg3 5390.html )

To that end I have installed a vanilla eclipse-SDK-3.5M2-win32 platform.


I then add an update site:

http://download.eclipse.org/modeling/emf/updates/milestones/

and attempt to install EMF SDK 2.5M3 ( I can't find an M2 ).

But I get the following error message from p2

"Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements
org.eclipse.equinox.security [1.0.100.v20080722-0430]."

Okay so I try unzipping emf-sdo-xsd-SDK-2.5.0M3.zip into the dropins
directory.

All I can see installed in the are the doc and source features in the
Software Updates->Installed Software tab, though in the plugins list and
features list off the About Dialog I can see other EMF plugins and
features, and I have no GUI to create new Empty EMF Projects etc...

Is there something else I should be installing as well, or is it just not
working ?
What version should I be using?

Thanks
Re: EMF 2.5M3 with Eclipse SDK 3.5 M2 [message #425283 is a reply to message #425279] Fri, 21 November 2008 14:19 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30903
Registered: July 2009
Senior Member
JF,

It's best to use the M3 version of the platform.


JF wrote:
> I wish to try out the Dynamic feature delegation of EMF 2.5 ( yes I'm
> migrating to CDO as in
> http://dev.eclipse.org/newslists/news.eclipse.tools.emf/msg3 5390.html )
>
> To that end I have installed a vanilla eclipse-SDK-3.5M2-win32 platform.
>
>
> I then add an update site:
>
> http://download.eclipse.org/modeling/emf/updates/milestones/
>
> and attempt to install EMF SDK 2.5M3 ( I can't find an M2 ).
>
> But I get the following error message from p2
>
> "Cannot complete the request. See the details.
> Cannot find a solution satisfying the following requirements
> org.eclipse.equinox.security [1.0.100.v20080722-0430]."
>
> Okay so I try unzipping emf-sdo-xsd-SDK-2.5.0M3.zip into the dropins
> directory.
>
> All I can see installed in the are the doc and source features in the
> Software Updates->Installed Software tab, though in the plugins list
> and features list off the About Dialog I can see other EMF plugins and
> features, and I have no GUI to create new Empty EMF Projects etc...
>
> Is there something else I should be installing as well, or is it just
> not working ? What version should I be using?
>
> Thanks
>
Previous Topic:XSD to Ecore Union Enum h pattern
Next Topic:StrictCompoundCommand
Goto Forum:
  


Current Time: Tue Feb 25 13:45:23 GMT 2020

Powered by FUDForum. Page generated in 0.06175 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top