Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO]: IHTTPConnector is present in 2 bundles!
[CDO]: IHTTPConnector is present in 2 bundles! [message #423819] Tue, 07 October 2008 14:05 Go to next message
Andre Dietisheim is currently offline Andre DietisheimFriend
Messages: 131
Registered: July 2009
Senior Member
Hi!

I just noticed that and indentical interface IHTTPConnector is present
in 2 bundles:

- org.eclipse.net4.http
- org.eclipse.net4.http.common

HTTPClientConnector does implement the version in common. HTTPUtil in
the http bundle is the only class that uses it. Strange enough
everything seems to work without classcast-exceptions so far.

I guess this is a mistake or do I overlook something?
Re: [CDO]: IHTTPConnector is present in 2 bundles! [message #423826 is a reply to message #423819] Tue, 07 October 2008 16:09 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6508
Registered: July 2009
Senior Member
André Dietisheim schrieb:
> Hi!
>
> I just noticed that and indentical interface IHTTPConnector is present
> in 2 bundles:
>
> - org.eclipse.net4.http
> - org.eclipse.net4.http.common
>
> HTTPClientConnector does implement the version in common. HTTPUtil in
> the http bundle is the only class that uses it. Strange enough
> everything seems to work without classcast-exceptions so far.
>
> I guess this is a mistake or do I overlook something?
This looks like a refactoring left-over.
Can you please file a Bugzilla so that I can remove
org.eclipse.net4j.http.IHTTPConnector ?

Cheers
/Eike


Re: [CDO]: IHTTPConnector is present in 2 bundles! [message #423827 is a reply to message #423826] Tue, 07 October 2008 16:25 Go to previous message
Andre Dietisheim is currently offline Andre DietisheimFriend
Messages: 131
Registered: July 2009
Senior Member
Eike Stepper wrote:
> André Dietisheim schrieb:
>> Hi!
>>
>> I just noticed that and indentical interface IHTTPConnector is present
>> in 2 bundles:
>>
>> - org.eclipse.net4.http
>> - org.eclipse.net4.http.common
>>
>> HTTPClientConnector does implement the version in common. HTTPUtil in
>> the http bundle is the only class that uses it. Strange enough
>> everything seems to work without classcast-exceptions so far.
>>
>> I guess this is a mistake or do I overlook something?
> This looks like a refactoring left-over.
> Can you please file a Bugzilla so that I can remove
> org.eclipse.net4j.http.IHTTPConnector ?
>
> Cheers
> /Eike

sure!

bug 249988

Cheers!
André
Previous Topic:Use EObject for Behavioral Extensions
Next Topic:[CDO] SQLException
Goto Forum:
  


Current Time: Mon Sep 28 16:48:44 GMT 2020

Powered by FUDForum. Page generated in 0.01699 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top