Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » cannot add type parameter to a class in EMF
cannot add type parameter to a class in EMF [message #422602] Thu, 11 September 2008 00:07 Go to next message
Simon Chen is currently offline Simon ChenFriend
Messages: 13
Registered: July 2009
Junior Member
Hi all,

I have a question regarding building ecore models in EMF. I created a
model, trying to add classes. I need to use type parameters,
essentially generics, say node<T>.

However, when I right-click a class, under the "add child" menu, I can
only add EAnnotation, EAttribute, EOperation and EReference. I cannot
find anything related to ETypeParameter anywhere.

BTW, I am using the latest Eclipse with EMF 2.4.

Thanks!

-Simon
Re: cannot add type parameter to a class in EMF [message #422603 is a reply to message #422602] Thu, 11 September 2008 01:39 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.zeligsoft.com

Hi, Simon,

Ensure that the "Show Generics" option is enabled in the Ecore Editor menu.

HTH,

Christian

Simon Chen wrote:
> Hi all,
>
> I have a question regarding building ecore models in EMF. I created a
> model, trying to add classes. I need to use type parameters,
> essentially generics, say node<T>.
>
> However, when I right-click a class, under the "add child" menu, I can
> only add EAnnotation, EAttribute, EOperation and EReference. I cannot
> find anything related to ETypeParameter anywhere.
>
> BTW, I am using the latest Eclipse with EMF 2.4.
>
> Thanks!
>
> -Simon
>
Previous Topic:[emf-dev] cannot add type parameter to a class in EMF
Next Topic:Structural Model changes (e.g. attribute is added removed)
Goto Forum:
  


Current Time: Tue Jan 21 19:33:33 GMT 2020

Powered by FUDForum. Page generated in 0.01803 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top