Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » updated to M4, now can't deploy to tomcat
updated to M4, now can't deploy to tomcat [message #36300] Mon, 02 July 2007 11:43 Go to next message
Vedran Blazevic is currently offline Vedran BlazevicFriend
Messages: 8
Registered: July 2009
Junior Member
Hello,

A while ago I updated rap from M3 to M4. I am working with the target M4.
Before the update I was able to deploy my app to Tomcat quite easily using
the servlet bridge. I tried the same approach with M4 but I had some
problems. First of all, it seems as if additional plugins are required. I
tried to add them manually using the console and found a configuration in
which my own plugin would start, however when I try to access the
webapplication I get the following error message:


++++++++
HTTP Status 404 - BridgeServlet: /adoit/rap
------------------------------------------------------------ --------------------
type Status report
message BridgeServlet: /myapp/rap
description The requested resource (BridgeServlet: /myapp/rap) is not
available.
------------------------------------------------------------ --------------------
Apache Tomcat/5.5.20
++++++++


This is the launch configuration I am using. Everything seems to be fine. In
eclipse the application is running perfectly.

++++++++
INFO: Server startup in 6579 ms
ss
Framework is launched.
id State Bundle
0 ACTIVE system.bundle_3.2.2.R32x_v20070118
1 ACTIVE com.boc_eu.adoweb.ui_1.0.0 <-- this is myapp
2 ACTIVE javax.servlet_2.4.0.200706081749
3 ACTIVE org.eclipse.core.commands_3.2.0.I20060605-1400
4 ACTIVE org.eclipse.core.contenttype_3.2.0.v20060603
5 ACTIVE org.eclipse.core.expressions_3.2.2.r322_v20070109a
6 ACTIVE org.eclipse.core.jobs_3.2.0.v20060603
7 ACTIVE org.eclipse.core.runtime_3.2.0.v20060603
8 ACTIVE org.eclipse.equinox.common_3.2.0.v20060603
9 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200706081749
10 ACTIVE org.eclipse.equinox.http.servletbridge_1.0.0.200706291832
11 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200706081749
12 ACTIVE org.eclipse.equinox.preferences_3.2.1.R32x_v20060717
13 ACTIVE org.eclipse.equinox.registry_3.2.1.R32x_v20060814
14 ACTIVE org.eclipse.equinox.servletbridge_1.0.0.200707021040
15 ACTIVE org.eclipse.osgi.services_3.1.100.v20060601
16 ACTIVE org.eclipse.rap.jface_1.0.0.200706081749
17 ACTIVE org.eclipse.rap.rwt_1.0.0.200706081749
18 ACTIVE org.eclipse.rap.ui.workbench_1.0.0.200706081749
19 ACTIVE org.eclipse.rap.w4t_1.0.0.200706081749
++++++++

I have checked whether the plugin.xml is included and it is, I am emptying
the work directory and I always deploy cleanly. What I have noticed is that
when I test the servlet with: http://localhost:8080/myapp/sp_test the
following line appears: "Servlet delegate not registered."

I have no idea why and I don't know exactly what that means. I have just
added some plugins (compared to M3) and nothing more.
Any comments will be appreciated. Thanks in advance,

Vedran Blazevic
Re: updated to M4, now can't deploy to tomcat [message #36513 is a reply to message #36300] Tue, 03 July 2007 10:30 Go to previous message
Vedran Blazevic is currently offline Vedran BlazevicFriend
Messages: 8
Registered: July 2009
Junior Member
The problem was solved by cleanly reinstalling the target and checking out
the last equinox.servletbridge and equinox.http.servletbridge.
My launch configuration looks like this now:

Framework is launched.

id State Bundle
0 ACTIVE system.bundle_3.2.2.R32x_v20070118
Fragments=31
1 ACTIVE com.boc_eu.adoweb.ui_1.0.0
2 ACTIVE org.eclipse.core.commands_3.2.0.I20060605-1400
3 ACTIVE org.eclipse.core.contenttype_3.2.0.v20060603
4 ACTIVE org.eclipse.core.expressions_3.2.2.r322_v20070109a
5 ACTIVE org.eclipse.core.jobs_3.2.0.v20060603
6 ACTIVE org.eclipse.core.runtime_3.2.0.v20060603
7 ACTIVE org.eclipse.equinox.common_3.2.0.v20060603
8 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200706081749
9 ACTIVE org.eclipse.equinox.http.servletbridge_1.0.0.200707031209
10 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200706081749
11 ACTIVE org.eclipse.equinox.preferences_3.2.1.R32x_v20060717
12 ACTIVE org.eclipse.equinox.registry_3.2.1.R32x_v20060814
13 ACTIVE org.eclipse.osgi.services_3.1.100.v20060601
14 ACTIVE org.eclipse.rap.jface_1.0.0.200706081749
15 ACTIVE org.eclipse.rap.rwt_1.0.0.200706081749
16 ACTIVE org.eclipse.rap.ui.workbench_1.0.0.200706081749
17 ACTIVE org.eclipse.rap.w4t_1.0.0.200706081749
18 ACTIVE org.eclipse.update.configurator_3.2.2.R32x_v20070111
31 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
Master=0

Vedran Blazevic
Previous Topic:Tiny clickable button on the title bar of Editor area
Next Topic:Theming like yoxos eclipse discovery application
Goto Forum:
  


Current Time: Wed May 29 13:12:06 GMT 2024

Powered by FUDForum. Page generated in 0.03687 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top