Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install plugin to Eclipse Kepler in Mac (Unable to install plugin to Eclipse Kepler in Mac )
Unable to install plugin to Eclipse Kepler in Mac [message #1865451] Fri, 03 May 2024 15:05 Go to next message
Vijayalakshmi laxman is currently offline Vijayalakshmi laxmanFriend
Messages: 22
Registered: June 2014
Junior Member
I have downloaded eclipse-standard-kepler-SR1-macosx-cocoa-x86_64 and installed Eclipse Kepler 4.3.1 and while trying to install the Kepler plugin the below error comes up. Please note that internet explorer is working.
Unable to read repository at http://marketplace.eclipse.org/content.xml.

eclipse.buildId=4.3.0.M20130911-1000
java.version=1.7.0_71
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_CAjavax.net.ssl.SSLPeerUnverifiedException: peer not authenticated
at sun.security.ssl.SSLSessionImpl.getPeerCertificates(SSLSessionImpl.java:421)
at org.apache.http.conn.ssl.AbstractVerifier.verify(AbstractVerifier.java:128)
at org.apache.http.conn.ssl.SSLSocketFactory.connectSocket(SSLSocketFactory.java:397)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:148)
at org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.java:150)
at org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPooledConnAdapter.java:121)
at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:575)
at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:425)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:820)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:754)
at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:263)
at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

[Updated on: Fri, 03 May 2024 15:05]

Report message to a moderator

Re: Unable to install plugin to Eclipse Kepler in Mac [message #1865472 is a reply to message #1865451] Sat, 04 May 2024 05:29 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33152
Registered: July 2009
Senior Member
It seems your very old version of Java doesn't recognize the root certificate of the certificate used by the server:

https://stackoverflow.com/questions/12961570/sslpeerunverifiedexception-peer-not-authenticated


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Save and Restore Split Window Layout
Next Topic:Can't use SWT in eclipse
Goto Forum:
  


Current Time: Sat May 25 12:27:39 GMT 2024

Powered by FUDForum. Page generated in 0.09525 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top