Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Scout » Cannot build war file with call mvn clean verify -DskipTests -e
Cannot build war file with call mvn clean verify -DskipTests -e [message #1864885] Thu, 18 April 2024 09:39
Miloslav Frajdl is currently offline Miloslav FrajdlFriend
Messages: 48
Registered: June 2018
Member
Today (18.4.2024) an unpleasant thing happened to me. I'm generating WAR using
call mvn clean verify -DskipTests -e


However, on startup, the process freezes right at the beginning
C:\Users\milos\eclipse-workspace-galerie\galis>call mvn clean verify -DskipTests -e
[INFO] Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] Galis Root                                                         [pom]
[INFO] Galis                                                              [pom]
[INFO] Galis Shared                                                       [jar]
[INFO] Galis Server                                                       [jar]
[INFO] Galis Client                                                       [jar]
[INFO] Galis Server Application                                           [war]
[INFO] Galis Server Application (Development)                             [war]
[INFO] Galis HTML UI                                                      [jar]
[INFO] Galis HTML UI Application                                          [war]
[INFO] ILU HTML UI Application (Development)                              [war]
[INFO]
[INFO] -------------------------< cz.a4b:galis-root >--------------------------
[INFO] Building Galis Root 1.2.9                                         [1/10]
[INFO] --------------------------------[ pom ]---------------------------------
[INFO]
[INFO] --- maven-clean-plugin:3.2.0:clean (default-clean) @ galis-root ---
[INFO] Deleting C:\Users\milos\eclipse-workspace-galerie\galis\target
[INFO]
[INFO] --- maven-enforcer-plugin:3.1.0:enforce (enforce-rules) @ galis-root ---
[INFO]
[INFO] --- jacoco-maven-plugin:0.8.8:prepare-agent (default) @ galis-root ---
[INFO] Skipping JaCoCo execution because property jacoco.skip is set.
[INFO] master_test_jacocoArgLine set to empty
[INFO]
[INFO] --- maven-antrun-plugin:3.1.0:run (check-node-install) @ galis-root ---
[INFO] Executing tasks
[INFO] Executed tasks
[INFO]
[INFO] --- maven-antrun-plugin:3.1.0:run (check-npm-install-workspace) @ galis-root ---
[INFO] Executing tasks
[INFO]     [touch] Creating C:\Users\milos\eclipse-workspace-galerie\galis\target\npm_update.marker
[INFO] Executed tasks
[INFO]
[INFO] --- frontend-maven-plugin:1.12.1:install-node-and-npm (install-node-and-npm) @ galis-root ---
[INFO] Installing node version v18.12.1
[INFO] Unpacking C:\Users\milos\.m2\repository\com\github\eirslett\node\18.12.1\node-18.12.1-win-x64.zip into C:\Users\milos\eclipse-workspace-galerie\galis\target\node\..\node\tmp
[INFO] Copying node binary from C:\Users\milos\eclipse-workspace-galerie\galis\target\node\..\node\tmp\node-v18.12.1-win-x64\node.exe to C:\Users\milos\eclipse-workspace-galerie\galis\target\node\..\node\node.exe
[INFO] Installed node locally.
[INFO]
[INFO] --- exec-maven-plugin:3.1.0:exec (install-node-tools) @ galis-root ---  <--- HERE IT FREEZES


In Eclipse by run js build I get warnings / errors like:
WARN GET https://registry.npmjs.org/make-dir error (UNABLE_TO_VERIFY_LEAF_SIGNATURE). Will retry in 1 minute. 1 retries left.

When I waited, it finally went through and now it doesn't report it anymore. But creating WAR still doesn't work unfortunately.


Yesterday (17.4.2024) it worked normally.

Can anyone advise me where to look and above all fix the problem?

Thank you.

Environment:
Windows 11
Eclipse:
Version: 2022-06 (4.24.0)
Build id: 20220609-1112
Previous Topic:Single Outline with View Tab
Next Topic:Know server session Id from Client session id or vice versa
Goto Forum:
  


Current Time: Sat May 25 14:41:35 GMT 2024

Powered by FUDForum. Page generated in 0.03514 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top