Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse IDE font change broken (Changing font in the Eclipse IDE only apply to one out of two projects)
Eclipse IDE font change broken [message #1863506] Tue, 06 February 2024 23:27 Go to next message
Mads Boyd-Madsen is currently offline Mads Boyd-MadsenFriend
Messages: 1
Registered: February 2024
Junior Member
I am trying to change the font I use for editing Java files in the Eclipse IDE, and it's not working as I would expect. Font-changes are not applied consistently.

I'm running:
Eclipse IDE for Enterprise Java Developers.
Version: 2019-09 R (4.13.0)
Build id: 20190917-1200

I try to change the font by doing:
"Window" > "Preferences" > "General" > "Appearance" > "Colors and Fonts"
Then select "Java" > "Java Editor Text Font"
Now I click "Edit" and select "JetBrains Mono Thin 12" and click "Ok"
Finally I click "Apply and Close".

I've got two projects in my Workspace.
When I select a Java-file from the project that appear first in the Project Explorer, the font-change is applied correctly.
When I do the same for a file in the second project, the font has not changed.

I've already tried the following:
* Check that I don't have any project-specific settings that might apply. I don't
* Checked the .settings-, .metadata and .project-files for both projects. Nothing untoward that I can see.
* Deleted the .settings-, .metadata and .project-files files for both projects. No effect (except of course, other stuff is not right, but the fonts are still changed correctly for first project and not for the second)
* Checked "org.eclipse.ui.workbench.prefs" under the "org.eclipse.core.runtime"-folder and can see my setting-changes in there. Nothing unusual.
* Moved the problematic project to a new Workspace via direct import. Still cannot change font for Java-files in that new work-space.
* Moved the problematic project to a new Workspace into an empty project-folder via Export to Archive and Import from Archive. NOW I CAN CHANGE THE FONT!
* Did the same, but created new Project from Archive. Font changes take no effect.

I'd like to understand what might be causing this problem.
It's a bit of pain to re-configure the project in a new Workspace.

[Updated on: Tue, 06 February 2024 23:54]

Report message to a moderator

Re: Eclipse IDE font change broken [message #1863600 is a reply to message #1863506] Wed, 14 February 2024 20:14 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4472
Registered: July 2009
Senior Member

I'm not sure per-project font choices were ever intentionally possible in the Java Editor, but the first thing to try should have been getting onto the current release. You were using one from late 2019. Did you install anything else onto it? Anything for themes or colors?

_
Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 14 February 2024 20:15]

Report message to a moderator

Previous Topic:EclipseStore And Postgres Demo Application
Next Topic:[SOLVED] Error with Signing Eclipse Contributor Agreement
Goto Forum:
  


Current Time: Mon Jul 15 00:13:15 GMT 2024

Powered by FUDForum. Page generated in 0.09909 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top