Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error while Building project
Error while Building project [message #1860112] Tue, 18 July 2023 13:06 Go to next message
S I is currently offline S IFriend
Messages: 2
Registered: July 2023
Junior Member
Hi,
was trying to build a project in eclipse Eclipse for RCP and RAP Developers, Version: Luna Service Release 2 (4.4.2) , getting this error

The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR] The project org.eclipse.om2m:org.eclipse.om2m:1.1.0-SNAPSHOT (C:\Users\user\git\om2m\org.eclipse.om2m\pom.xml) has 1 error
[ERROR] Unresolveable build extension: Plugin org.eclipse.tycho:tycho-maven-plugin:0.25.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.eclipse.tycho:tycho-maven-plugin:jar:0.25.0: Could not transfer artifact org.eclipse.tycho:tycho-maven-plugin:pom:0.25.0 from/to central (http: //repo.maven.apache.org/maven2): Failed to transfer http: //repo.maven.apache.org/maven2/org/eclipse/tycho/tycho-maven-plugin/0.25.0/tycho-maven-plugin-0.25.0.pom. Error code 501, HTTPS Required -> [Help 2]


For this , after installing eclipse,
i had installed Tycho from Help->Install New Software ,
then had cloned a git repository using url: https://git.eclipse.org/r/om2m/org.eclipse.om2m
and run it as Maven install when i recieved this error.

Does any one know how to resolve this ?
Re: Error while Building project [message #1860115 is a reply to message #1860112] Tue, 18 July 2023 14:37 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33152
Registered: July 2009
Senior Member
Wow, is that old! In any case, you must us https to access Maven now if if you can't do that with such an ancient version of Tycho then you can't do it at all. You really need to modernize before you fall off the edge of the cliff...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Error while Building project [message #1860128 is a reply to message #1860115] Wed, 19 July 2023 05:50 Go to previous messageGo to next message
S I is currently offline S IFriend
Messages: 2
Registered: July 2023
Junior Member
index.php/fa/43337/0/Yes i know ,but can you tell me how to change the url of central maven in global repository .
Re: Error while Building project [message #1860132 is a reply to message #1860128] Wed, 19 July 2023 07:42 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33152
Registered: July 2009
Senior Member
I would Google "how to change the url of central ma.ven in global repository" and look for answers. Very few people answer questions here so it's unlikely someone who knows the answer will read your question here. You might ask here:

https://github.com/eclipse-tycho/tycho/discussions

But they are likely to tell you to use newer versions of everything.


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:error while installing darkest dark theme
Next Topic:CVS in Eclipse 2022-03 is missing
Goto Forum:
  


Current Time: Fri May 24 13:32:07 GMT 2024

Powered by FUDForum. Page generated in 0.08332 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top