Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debugging using Eclipse IDE, source not found
Debugging using Eclipse IDE, source not found [message #1860003] Mon, 10 July 2023 08:43 Go to next message
Léa Massiot is currently offline Léa MassiotFriend
Messages: 7
Registered: January 2020
Junior Member
Hello,

Thank you for reading my post.

In the Eclipse IDE, I have a workspace with several interdependent projects:
- four dynamic Web projects,
- one Java project
- and three Web fragments.

After setting breakpoints, when I try to debug my project, instead of allowing me to trace the code step by step after the breakpoint has been reached, I get an empty window with a "Source not found" message and a button labelled "Edit Source Lookup Path".

What is bizarre is that I can trace the code with one of dynamic Web projects but not inside the others.

Can you please help?

Best regards.
Re: Debugging using Eclipse IDE, source not found [message #1860089 is a reply to message #1860003] Sun, 16 July 2023 16:07 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4450
Registered: July 2009
Senior Member

How are you launching your project for debug?

_
Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Debugging using Eclipse IDE, source not found [message #1860110 is a reply to message #1860089] Tue, 18 July 2023 11:35 Go to previous messageGo to next message
Léa Massiot is currently offline Léa MassiotFriend
Messages: 7
Registered: January 2020
Junior Member
Hello,

I go to the "Servers" window which has an entry "Tomcat v10.0 Server at localhost".
I right-click on that entry and choose "Debug".

Best regards.
Re: Debugging using Eclipse IDE, source not found [message #1860381 is a reply to message #1860110] Wed, 02 August 2023 13:02 Go to previous message
Connor Evans is currently offline Connor EvansFriend
Messages: 12
Registered: August 2023
Junior Member
I've faced a similar issue before. It sounds like a source path problem. Try right-clicking on the project, then "Properties > Java Build Path > Source", and check if paths match. Good luck!

Cheers!

[Updated on: Thu, 03 August 2023 12:41]

Report message to a moderator

Previous Topic:error message ' could not create the view'
Next Topic:Python code hierarchy tool?
Goto Forum:
  


Current Time: Wed May 22 23:28:54 GMT 2024

Powered by FUDForum. Page generated in 0.08784 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top