Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't install StatET(Can't install StatET)
Can't install StatET [message #1859631] Tue, 20 June 2023 20:52 Go to next message
Alexander MacFarlane is currently offline Alexander MacFarlaneFriend
Messages: 5
Registered: June 2023
Junior Member
I am trying to install StatET.
Chose the base IDE for Java Developers then went to the marketplace but it won't install with these errors:

Cannot complete the install because one or more required items could not be found.
Software being installed: StatET IDE for R (Incubation) 4.3.0.202102180600-r (org.eclipse.statet.r.feature.group 4.3.0.202102180600-r)
Missing requirement: StatET IDE for R (Incubation) 4.3.0.202102180600-r (org.eclipse.statet.r.feature.group 4.3.0.202102180600-r) requires 'org.eclipse.equinox.p2.iu; org.eclipse.jdt.feature.group 3.18.0' but it could not be found


Any idea how to fix this?

Re: Can't install StatET [message #1859642 is a reply to message #1859631] Wed, 21 June 2023 07:15 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4450
Registered: July 2009
Senior Member

Which version is it failing to install into?

_
Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Can't install StatET [message #1859651 is a reply to message #1859642] Wed, 21 June 2023 13:08 Go to previous messageGo to next message
Alexander MacFarlane is currently offline Alexander MacFarlaneFriend
Messages: 5
Registered: June 2023
Junior Member
That happened with a new install of the latest version.
Re: Can't install StatET [message #1859655 is a reply to message #1859651] Wed, 21 June 2023 13:50 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33155
Registered: July 2009
Senior Member
It looks like those folks included the JDT feature in their feature and that specific version of JDT is only available in Eclipse 4.12 / 2019-06 release. That seems quite old suggesting that StatET is quite old...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Can't install StatET [message #1859656 is a reply to message #1859655] Wed, 21 June 2023 13:55 Go to previous messageGo to next message
Alexander MacFarlane is currently offline Alexander MacFarlaneFriend
Messages: 5
Registered: June 2023
Junior Member
It's not old.
https://projects.eclipse.org/projects/science.statet

The latest release was April 6 2023.
Re: Can't install StatET [message #1859657 is a reply to message #1859656] Wed, 21 June 2023 14:22 Go to previous messageGo to next message
Alexander MacFarlane is currently offline Alexander MacFarlaneFriend
Messages: 5
Registered: June 2023
Junior Member
The computer is old though.
It is still running Windows 7
Is there a way to install or reinstall JDT?

I just tried it on a newer computer running Linux and it installed fine
Re: Can't install StatET [message #1859662 is a reply to message #1859657] Wed, 21 June 2023 16:28 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4450
Registered: July 2009
Senior Member

You should be able to find the Java Development Tools right in your Install New Software dialog, off of the Help menu. The correct URL for the release
you're running should already be in the list of available update sites.


_
Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Can't install StatET [message #1859664 is a reply to message #1859662] Wed, 21 June 2023 17:25 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33155
Registered: July 2009
Senior Member
Somehow I think you are trying to install something old of that project then. Which URL are you using to install their stuff?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Can't install StatET [message #1859665 is a reply to message #1859664] Wed, 21 June 2023 17:41 Go to previous message
Alexander MacFarlane is currently offline Alexander MacFarlaneFriend
Messages: 5
Registered: June 2023
Junior Member
Thanks for the help everyone.

I am working from home today and was able to get it up and running in Manjaro.
The work computer is in an acedemic research lab running Windows 7 and can't get an OS upgrade for various reasons.

I will try installing the Java Development Tools when I am back on site tomorrow and then report back here.
Previous Topic:How to Silently Install /Deploy Eclipse IDE for Enterprise Java and Web Developers
Next Topic:Initial "Run" response
Goto Forum:
  


Current Time: Tue May 28 11:58:38 GMT 2024

Powered by FUDForum. Page generated in 0.09729 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top