Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Drag and drop of views fails in Eclipse(Trying to move a view in Eclipse fails - with error in the log. This always worked before)
Drag and drop of views fails in Eclipse [message #1859491] Sun, 11 June 2023 12:21 Go to next message
Peter Illing is currently offline Peter IllingFriend
Messages: 1
Registered: June 2023
Junior Member
I frequently set up Eclipse perspectives, moving views around in the display. I have used Eclipse for many years and this always worked perfectly.
Now, views don't move. Looking at the log file, I see that I keep getting an error that has to do with the graphics. No doubt, my setup is messed up, but I don't know in which way.

Here is a section from the call stack in the .log file in .metadata in my workspace:
at org.eclipse.swt.widgets.Tracker.drawRectangles(Tracker.java:361)
at org.eclipse.swt.widgets.Tracker.open(Tracker.java:806)
at ----> org.eclipse.e4.ui.workbench.addons.dndaddon.DnDManager.startDrag(DnDManager.java:230)
at org.eclipse.e4.ui.workbench.addons.dndaddon.DnDManager.lambda$0(DnDManager.java:84)

I am using Eclipse 2019-12 (4.14.0).
My Java is Java SE 1.8.0.271

My machine is a Macbook Pro, running Ventura 13.4, 2.4GHz Intel -core i5, Intel Iris Plus Graphics, 16GB. Pretty standard

I have attached an overview of the e4 section of the plugins folder.

I realize that Java 1.8 is no longer the latest, but the Eclipse - expect for this problem - works just fine. The software I work with needs Java 1.8, so I am hoping not to have to move.

Please offer a suggestion if you see what I have done wrong?

thanks, Peter
Re: Drag and drop of views fails in Eclipse [message #1859492 is a reply to message #1859491] Sun, 11 June 2023 15:59 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4450
Registered: July 2009
Senior Member

You can develop for Java 1.8 even if your release of Eclipse needs a higher version to run itself. That's why there's an Installed JREs
preference page, and one of the reasons it contains a list of JREs. Your problem most likely comes from using a release that's not at
all concurrent with your operating system, so update, and see if that fixes it. macOS changes API behavior between releases, sometimes
in odd and undocumented ways.


_
Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Microsoft DLL being loaded when launching our app
Next Topic:IWorkbenchHelpSystem.displayHelp freezes app
Goto Forum:
  


Current Time: Tue May 28 14:10:09 GMT 2024

Powered by FUDForum. Page generated in 0.19510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top