Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't install Papyrus(Problem with new Eclipse Papyrus install)
Can't install Papyrus [message #1858799] Sun, 23 April 2023 01:42 Go to next message
Eddie Monroe is currently offline Eddie MonroeFriend
Messages: 2
Registered: April 2023
Junior Member
I'm not sure where this topic really belongs. I'm certainly a newbie. It is a new Eclipse install and I'm trying to add the Papyrus plugin. Admin please feel free to move it where it belongs.

I am a retired computer programmer and working on a stamp album program, All my development software is free/open source. My project is a working c++ project of about 150 files (~60+ classes) that I wanted to import into UML to do some cleanup and re-write the C++.

I googled around and found that Eclipse Papyrus should be able to do the round tripping I want. I've never used Eclipse before.
This morning I installed Eclipse from the Eclipse Foundation download page. It seems to be working, Help->About says it is
Quote:

Eclipse IDE for C/C++ Developers (includes Incubating components)
Version: 2021-09 (4.21.0)
Build id: 20210910-1417


I tried to install Papyrus from the Help->"Install New Software" but get an error every time.
The error details say
Quote:
An error occurred while collecting items to be installed
session context was:(profile=_sandbox_Applications_Eclipse_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Result of processing steps.
OK
OK
OK
Public key not found for 8122282445186051625.
OK

I've tried several repositories including Kepler, Neon and Photon all with the same results. I don't have a clue what this error is telling me. I'm probably doing something dumb but I would appreciate someone telling me what to check for.

I'm running on Linux Mint 19.3.

Thanks ,
Eddie
Re: Can't install Papyrus [message #1858800 is a reply to message #1858799] Sun, 23 April 2023 06:43 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33155
Registered: July 2009
Senior Member
What you describe sounds very old (2021-09) compared to what I actually see here (2023-03):

https://www.eclipse.org/downloads/packages/

The problems you describe sound like what I'd expect from such an old version when handling PGP keys with what was at that point a buggy implementation.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Can't install Papyrus [message #1858802 is a reply to message #1858800] Sun, 23 April 2023 10:52 Go to previous message
Eddie Monroe is currently offline Eddie MonroeFriend
Messages: 2
Registered: April 2023
Junior Member
Thank you. It didn't occur to me that the installation that I downloaded using the download buttons on the main site would not give me a very recent release.
I downloaded again, got a 2023 release and Papyrus then loaded nicely.
Now let me see if I can figure out how to use this.
Thanks,
Eddie
Previous Topic:Fedora 37 and a very old Eclipse
Next Topic:Can you make templates?
Goto Forum:
  


Current Time: Tue May 28 10:15:54 GMT 2024

Powered by FUDForum. Page generated in 0.10678 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top