Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Eclipse Layout Kernel » Error installing Kieler (to get Gml Importer)(Error during mvn install of Kieler--fetching piccolo from U of Maryland)
Error installing Kieler (to get Gml Importer) [message #1858579] Mon, 10 April 2023 02:21 Go to next message
Michael Lynott is currently offline Michael LynottFriend
Messages: 11
Registered: September 2021
Junior Member
As part of my project I would like to use the GmlImporter in the Kieler project to read in Gml graphs to process with Elk. I cloned "pragmatics", but when I perform mvn install in a Windows command window, I get an error message as shown in the attached file. The script attempts to install "edu.umd.cs.piccolo:jar:1.3.4.v202003330". I can find no reference to this jar in the "pragmatics" folder. I can find no reference to it online. Can you provide guidance about how to complete this install? Thank you.
Re: Error installing Kieler (to get Gml Importer) [message #1858602 is a reply to message #1858579] Tue, 11 April 2023 06:48 Go to previous messageGo to next message
Sören Domrös is currently offline Sören DomrösFriend
Messages: 14
Registered: June 2021
Junior Member
We usually use an Oomph setup to install everything. Sadly this no longer exists only for the pragmatics but only for a pragmatics + semantics combination on the "Keith" stream in the semantics setup.
You can find the desired jar here as part of the klighd nightly update side.
Re: Error installing Kieler (to get Gml Importer) [message #1858609 is a reply to message #1858602] Tue, 11 April 2023 16:45 Go to previous message
Michael Lynott is currently offline Michael LynottFriend
Messages: 11
Registered: September 2021
Junior Member
I took an easier path, went to the pom file pragmatics/plugins.pom.xml and commented out the appropriate lines. That worked for me.
Thanks for the pointer though if I need that jar.
Previous Topic:Guidance on invoking AllCrossingsCounter
Next Topic:Issue with build/pom.xml
Goto Forum:
  


Current Time: Mon Jul 15 03:29:38 GMT 2024

Powered by FUDForum. Page generated in 0.03377 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top