Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Automatic closing brace timing(Need help with Eclipse's timing of automatically adding a closing brace)
Automatic closing brace timing [message #1856774] Sat, 31 December 2022 17:24 Go to next message
Rob Grieshaber is currently offline Rob GrieshaberFriend
Messages: 2
Registered: December 2022
Junior Member
My apologies if this question has been addressed, but I've been searching the forums for some time.

When typing a construct that has a pair of braces (parentheses, curly braces, or whatever), when the opening brace is typed Eclipse automatically adds the closing brace, and that's wonderful. BUT ...

If I type the opening brace, Eclipse adds the closing brace, and if I immediately type the closing brace Eclipse leaves the cursor after that closing brace. But if I pause a moment before typing that closing brace, Eclipse adds that extra character, leaving the cursor before the closing brace that it added.
I think I'm explaining myself clearly, but please let me know if I'm not.
It doesn't take long for this to become irritating, especially when I'm trying some other editor or IDE and it doesn't have this issue. Of course, the other editor or IDE is ALWAYS lacking in something and I'm back to Eclipse :-)
Is there a setting for the timing of this behavior??
Re: Automatic closing brace timing [message #1856798 is a reply to message #1856774] Tue, 03 January 2023 08:58 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32663
Registered: July 2009
Senior Member
I'm not sure you can change the timing. I don't see a preference for that in Window -> Preferences -> Java -> Editor -> Typing which is where you could turn it off.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Automatic closing brace timing [message #1856809 is a reply to message #1856798] Tue, 03 January 2023 21:36 Go to previous message
Rob Grieshaber is currently offline Rob GrieshaberFriend
Messages: 2
Registered: December 2022
Junior Member
Interesting. There's a ton of settings, but I think you're right, I may be having to just adjust my typing to account for this. NOT a big deal, but I thought it was cheap to ask ;-). Thanks for your response!
Previous Topic:Accessing objects of the IDE
Next Topic:Cannot create CDS view for "Data Definition"
Goto Forum:
  


Current Time: Sat Feb 04 16:22:54 GMT 2023

Powered by FUDForum. Page generated in 0.73424 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top