Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Plugin Testing 4.19
Plugin Testing 4.19 [message #1854892] Fri, 16 September 2022 13:00
philipp huebner is currently offline philipp huebnerFriend
Messages: 67
Registered: July 2009
Member
Hello,

we are trying desperatly to get our unit tests to work in eclipse 4.19. It seems to be not possible anymore.

We tried the following:


    Download and unzipped eclipse SDK 4.19.
    Download and unzipped eclipse.test.framework.
    Build our test plugins as a feature/plugins set
    Copied that into the eclipse
    Tried to use the scripts in eclipse-Automated-Tests-4.19


Eclipse does not load our feature and does not show it in the about dialog. There is no chance to get any log or hint out of it.
Manually everything can be loaded with the osgi console.

When we try to invoke the tests via a test.xml we get dependency errors that point to SWT:

java.lang.NoClassDefFoundError: org/eclipse/swt/SWTException
	at org.eclipse.test.EclipseTestRunner.startStackDumpTimeoutTimer(EclipseTestRunner.java:329)
	at org.eclipse.test.EclipseTestRunner.run(EclipseTestRunner.java:179)
	at org.eclipse.test.CoreTestApplication.runTests(CoreTestApplication.java:52)
	at org.eclipse.test.CoreTestApplication.run(CoreTestApplication.java:35)
	at org.eclipse.test.CoreTestApplication.start(CoreTestApplication.java:43)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.base/java.lang.reflect.Method.invoke(Method.java:567)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1461)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1434)
	at org.eclipse.core.launcher.Main.main(Main.java:44)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.SWTException cannot be found by org.eclipse.e4.ui.workbench3_0.15.500.v20201021-1339
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:519)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:171)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:519)



Has anybody got the test framework to run in 4.19?
Or has an idea what is going on here?
Or knows another possibility to run Unit Test on 4.19?

Best regards,
Philipp

Previous Topic:The RCP app is running in the background without any UI. 
Next Topic:Eclipse Dropins Folder
Goto Forum:
  


Current Time: Thu May 30 16:05:05 GMT 2024

Powered by FUDForum. Page generated in 0.03907 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top