Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can seem to Install or Run Eclipse(Issues running)
Can seem to Install or Run Eclipse [message #1853859] Wed, 20 July 2022 07:53 Go to next message
Stef Dave is currently offline Stef DaveFriend
Messages: 4
Registered: July 2022
Junior Member
If i try to install it I get a message about an error log and if i download the package, extract it and run it i get the same message. this is the log file

!SESSION 2022-07-20 08:50:24.882 -----------------------------------------------
eclipse.buildId=4.20.0.I20210611-1600
java.version=16.0.1
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.osgi 4 0 2022-07-20 08:50:30.116
!MESSAGE Application error
!STACK 1
java.lang.NoClassDefFoundError: com/mercury/javashared/agentloader/AgentBootstrap
at org.eclipse.swt.widgets.Display.<init>(Display.java:557)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:742)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:168)
at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:182)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:125)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:78)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:567)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:654)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1462)
Caused by: java.lang.ClassNotFoundException: com.mercury.javashared.agentloader.AgentBootstrap cannot be found by org.eclipse.swt_3.116.100.v20210602-2209
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:519)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:170)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:519)
... 17 more
Re: Can seem to Install or Run Eclipse [message #1853866 is a reply to message #1853859] Wed, 20 July 2022 11:19 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4310
Registered: July 2009
Senior Member

What, exactly, did you download? What is the name of the file, and from where are you getting it?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Can seem to Install or Run Eclipse [message #1853867 is a reply to message #1853866] Wed, 20 July 2022 11:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32669
Registered: July 2009
Senior Member
It seems you've installed something additional so are seeing a problem like this:

https://knowledge.informatica.com/s/article/519707?language=en_US


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Can seem to Install or Run Eclipse [message #1853879 is a reply to message #1853867] Thu, 21 July 2022 06:34 Go to previous messageGo to next message
Stef Dave is currently offline Stef DaveFriend
Messages: 4
Registered: July 2022
Junior Member
I had Intellj installed but it didnt work with UFT / Leanft which is installed, I also have Maven and Java 18 installed and that is all as it is a a new VM machine.
Re: Can seem to Install or Run Eclipse [message #1853881 is a reply to message #1853866] Thu, 21 July 2022 06:36 Go to previous messageGo to next message
Stef Dave is currently offline Stef DaveFriend
Messages: 4
Registered: July 2022
Junior Member
i downloaded the Eclipse Installer 2021‑06 R from here - https://www.eclipse.org/downloads/packages/release/2021-06/r
Re: Can seem to Install or Run Eclipse [message #1853886 is a reply to message #1853881] Thu, 21 July 2022 07:28 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 521
Registered: August 2016
Senior Member
The problem is UFT. Compare

[Updated on: Thu, 21 July 2022 07:33]

Report message to a moderator

Re: Can seem to Install or Run Eclipse [message #1853887 is a reply to message #1853886] Thu, 21 July 2022 07:45 Go to previous messageGo to next message
Stef Dave is currently offline Stef DaveFriend
Messages: 4
Registered: July 2022
Junior Member
I removed the JAVA_TOOL_OPTIONS and now i run Eclipse and yes UFT is a big problem :)
Re: Can seem to Install or Run Eclipse [message #1853889 is a reply to message #1853887] Thu, 21 July 2022 08:14 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32669
Registered: July 2009
Senior Member
Thank you for confirming the cause of the problem.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Does AdoptiumOpenJDK come with JavaFX?
Next Topic:Informatica Developer 10.5.2
Goto Forum:
  


Current Time: Thu Feb 09 10:22:34 GMT 2023

Powered by FUDForum. Page generated in 0.03419 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top