Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » no JAR files, package X is not accessible
no JAR files, package X is not accessible [message #1853585] Sat, 09 July 2022 06:05 Go to next message
Allison Zhang is currently offline Allison ZhangFriend
Messages: 1
Registered: July 2022
Junior Member
Hello. I am new to programming so I am deeply confused about this new terminology, but I have found a previous forum thread about this problem and tried following one of the solutions posted to no avail. (https://www.eclipse.org/forums/index.php/t/1101004/)

I am using a macOS(v12), M1 chip and I just downloaded Eclipse so I'm assuming it's the latest version. I think I am using Java SRE 17.

I keep getting the error that java.awt is not accessible, so I tried Build Path > Configure Build Path > Add External JARs. When the window pops up to prompt me to select a JAR I don't have any. I'm not sure what folders I'm supposed to be looking in but all the ones I've checked don't have any jar files for me to add. I have no idea where to go from here. Do I need to download something first?

Much thanks in advance
Re: no JAR files, package X is not accessible [message #1853598 is a reply to message #1853585] Sun, 10 July 2022 18:42 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 739
Registered: August 2014
Senior Member
If your program is modular, having module-info.java in the root folder, edit your module-info.java to have the line 'requires java.desktop;' between the braces.


--

Tauno Voipio
Previous Topic:This error pops up whenever I press alt+/
Next Topic:Maven Integration Issue
Goto Forum:
  


Current Time: Tue Jan 31 08:38:42 GMT 2023

Powered by FUDForum. Page generated in 0.05404 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top